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Introduction 
The ICONICS InTouch To GraphWorX32 Translator uses SAX2 to parse and 
convert exported .xml InTouch windows into GraphWorX32 .gdf files. Therefore, 
implementation of XML3.0 or higher must be installed on your computer in order 
to run this utility successfully. 

 

IMPORTANT NOTE 
It is highly suggested that you run the ICONICS InTouch to GraphWorX32 
Translator on a machine with GraphWorX32 v7.x (or GENESIS32 v7.x) or higher 
installed. Since Wonderware pictures are saved in JPG or PNG format and 
GraphWorX32 v6.1 does not support importing *.jpg and *.png files, you can get 
expected results only with GraphWorX32 v7.x or higher. The translator utility will 
still work with GraphWorX32 v6.1, but no pictures will be created inside the 
converted window. 

InTouch To GraphWorX32 Translator 
The InTouch to GraphWorX32 Translator, shown in the figure below, was 
designed to enable the conversion of Wonderware™ InTouch™ windows into 
ICONICS GraphWorX32 displays as easily as possible. It can provide the 
conversion either for a single window, a set of windows or the whole project.  

You can specify file(s) to export in the Select Win-XML Exporter file edit box (or 
browse for the file by clicking the Browse button). You can either select a single 
window file (*.xml), Window Set file (wwcfg.xml) or Project file (*.wxe) as the 
source for translation. By default, it points to the Win-XML Exporter project file, 
which was created or worked on the last time the Win-XML Exporter was 
launched. (For more information about the Win-XML Exporter, please see the 
"InTouch to GraphWorX32 Conversion Tutorial" section below.) 

Then, fill in the Destination Directory path where you want to place your 
converted GraphWorX display files.  By default, the GENESIS32 Working 
Directory is preset in the edit box. The GENESIS32 working directory can be 
changed using the GraphWorX application by selecting Set Working Directory 
from the Tools menu. 
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InTouch Translator Utility 

Conversion Specifics 
The InTouch to GraphWorX32 Translator utility creates one GraphWorX 
display file per each exported InTouch window file. When the Window Set file is 
selected, it converts all windows within the Window Set.  

When the project file is selected, all Window Sets included in the project are 
converted. A subdirectory named after the Window Set is created for all project 
Window Sets. All windows in all Window Sets being converted are created under 
the corresponding subdirectory. 

Supported Conversion Types 
The table below lists conversion object pairs. The InTouch object on the left is 
converted into GraphWorX32 object on the right. 

 

Static Objects 
WonderWare  

InTouch 
ICONICS 

GraphWorX32 
Line GwxLine 

H/V Line GwxLine 
Polyline GwxLine 
Polygon GwxLine 

Rectangle GwxRectangle 
Rounded Rectangle GwxRectangle 

Text GwxText 
Bitmap GwxBitmap 

Real-time Trend NOT CONVERTED 
Historical Trend NOT CONVERTED 

Button GwxButton 
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Dynamic Objects 
Wonderware InTouch ICONICS 

GraphWorX32 
Line Color Discrete GwxDigitalColor 
 Analog GwxDigitalColor 
 Discrete 

Alarm NOT CONVERTED 

 Analog Alarm NOT CONVERTED 
Fill Color Discrete GwxDigitalColor 
 Analog GwxDigitalColor 
 Discrete 

Alarm NOT CONVERTED 

 Analog Alarm NOT CONVERTED 
Text Color Discrete GwxDigitalColor 
 Analog GwxDigitalColor 
 Discrete 

Alarm NOT CONVERTED 

 Analog Alarm NOT CONVERTED 
Object Size Height GwxSize 
 Width GwxSize 
Location Vertical GwxLocation 
 Horizontal GwxLocation 
Percent Fill Vertical GwxSize 
 Horizontal GwxSize 
Miscellaneous Visibility GwxHide 
 Blink GwxFlash 
 Orientation GwxRotation 
 Disable GwxHide 
Value Display Discrete GwxProcessPoint 
 Analog GwxProcessPoint 
 String GwxProcessPoint 
User Inputs Discrete NOT CONVERTED 
 Analog NOT CONVERTED 
 String NOT CONVERTED 
Sliders Vertical GwxLocation 
 Horizontal GwxLocation 
Touch 
Pushbuttons 

Discrete 
Value GwxPick 

 Action NOT CONVERTED 
 Show 

Window GwxPick 

 Hide Window NOT CONVERTED 
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Functional Limitations 
Functional limitations of the InTouch to GraphWorX32 Translator are imposed 
by the limitation of the GraphWorX32 OLE automation interface and limitations of 
Win-XML Exporter utility.  

The InTouch to GraphWorX32 Translator does not translate expressions and 
does not convert DDE tags into OPC tags. 

 

What Will Not Convert? 
Throughput of the process is fundamentally limited by Wonderware’s WIN-XML 
Exporter utility. The Wonderware utility does not convert:  

• Historical trends created using the Wonderware Historical Trend Wizard. 
• Alarm/event displays created using the Wonderware Alarm/event display 

wizard. 
• Statistical process control (SPC) elements. 
• QuickScripts, application scripts, window while showing scripts, data change 

scripts, or condition scripts. 
• Some objects from Wonderware’s Symbol Factory. 
 
NOTE The Win-XML Exporter works only with InTouch 7.1 or greater. Earlier 
InTouch windows must at minimum be opened and saved in InTouch 7.1 before 
conversion. 
 
The trend, alarm, and event elements can easily be created in GraphWorX 
through simple drop/drag/configure techniques. Much scripting required with 
Wonderware becomes unnecessary as ICONICS standard graphics objects, 
animations, and tools contain much if not more of the same functionality. 
Complex or custom scripting can easily be embedded using VBA, VBX, or Jscript 
within the ICONICS product. 

 

Translation Impurities 
Text Object 

GraphWorX32 text object has a gap/space between the string and its frame, 
while InTouch frame is close-knit to the text string. Therefore, GraphWorX32 text 
objects must be resize to approximately reflect the font size of InTouch text 
object.  

Orientation Dynamic 

The Orientation dynamic is translated as GwxRotation dynamic. The conversion 
utility creates the GwxRotation object filled with available attributes. It does not 
set the pivot and angle of rotation. Adjust them to make them precisely reflect the 
original situation. 

Value Display Dynamics 

Wonderware’s Value Display dynamic can be directly translated as a process 
point only if its text object string is empty. When it is not, such Value Display will 
be translated into two GraphWorX32 objects, static text object displaying the 
string and process point displaying the value. The frame of the process point will 
be placed next to the text object. User then has to adjust its size and position. 

Value Display Discrete Dynamic 
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The GraphWorX32 equivalent of Wonderware’s Value Display Discrete dynamic 
is a process point with its states set up. Unfortunately, GraphWorX32 v 6.x 
automation does not allow setting up the States of a process point. Therefore, 
the message strings belonging to the discrete values are placed into the custom 
data field of translated GraphWorX32 process point. 

To finish the translation of Value Display Discrete dynamic, please remove these 
strings (from custom data field) and use them to configure the states in State 
Field Configuration dialog. The first line of the custom data is the Wonderware’s 
“On Message,” while the second line is “Off Message.” 

Touch Pushbuttons and Show Window  

Only the very first InTouch window stated in the exported list of windows to open 
will be used. The rest of the InTouch windows are ignored.  

 

Win-XML Exporter 
The Win-XML Exporter utility is distributed with Wonderware’ SuiteVoyager. 

To install the Win-XML Exporter: 

1. From the SuiteVoyager Portal Home Page (obtain the URL or address from 
your SuiteVoyager Administrator) click the Converter Tool download link. The 
File Download dialog box appears. 

2. Choose Run this program from its current location. Click OK. The 
Security Warning dialog box appears. Click Yes. The Suite Voyager Win-
XML Exporter Installation Wizard dialog box appears, as shown in the figure 
below. Click the Next button to begin the installation. Then following the 
installation steps in the wizard. 

 
Win-XML Exporter Installation Running 
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3. The files are installed. When the Setup Complete dialog box appears, click 
Finish. 

4. To launch the Win-XML Exporter (shown in the figure below) from the 
Windows Start menu, select Programs > Wonderware > InTouch > Win-
XML Exporter. 

Note: For more information about the Win-XML Exporter, please see the 
"InTouch to GraphWorX32 Conversion Tutorial" section below.) 

 
Win-XML Exporter 

InTouch to GraphWorX32 Conversion Tutorial 
The process of converting a Wonderware InTouch application (Version 7.11 or 
8.0) to ICONICS GraphWorX32 (Version 7.x or 8.x) is a fairly straightforward and 
simple procedure the requires two basic steps. First, the Wonderware application 
windows will be converted from Wonderware’s proprietary .WIN format to XML 
using the Wonderware SuiteVoyager WIN-XML Exporter (Version 2) utility. 
Second, the new exported XML windows will be imported into GraphWorX using 
the ICONICS WWToGwxTranslator.exe utility.  

 

Step 1: Exporting InTouch Application .WIN’s to XML 
To convert the Wonderware application windows from Wonderware’s proprietary 
.WIN format to XML, use the SuiteVoyager WIN-XML Exporter utility and install it 
on the same node as the InTouch application. The installation will place the 
exporter in your Wonderware/InTouch Program Group. The exporter is called 
“Win-XML Exporter.” Launching the program and selecting the “?” button on the 
toolbar will provide online Help. 
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1. Launch the program. Select File > New Project, and select a Project Name 
and Local Project Path, as shown in the figure below. Click the Next button. 

 
Specifying Project Name and Location 

2. Fill in anything for the SuiteVoyager URL, as you will not be publishing to 
SuiteVoyager. Click Next. Click OK at the Warning dialog, as shown in the 
figure below. Then click Next twice. 

 
Publishing Properties 
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3. Your project summary appears, as shown in the figure below. Click Finish. 

 
New Project Information 

4. Your project with a WindowSet001 folder appears, as shown in the figure 
below. 

 
New Project in WinXML Exporter 

ICONICS  9 



5. Select File > Open InTouch Application… and browse to the InTouch 
application folder that you are exporting to XML, as shown in the figure 
below.  Click OK. 

 
Selecting Folder to Export 

6. With some ActiveX elements you may get the following dialog, as shown in 
the figure below. Click Cancel. 

 
CAB Dialog 
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7. Select a window that you wish to export with the left mouse button and drag it 
to the WindowSet001 folder.  This will invoke the Win-XML Exporter, as 
shown in the figure below. 

 
Exporting Application 

8. The XML representation of the window will be created in your destination 
folder (this example c:\MyWWXLMExport\MyICONICSProject.), as shown in 
the figure below. 

 
Destination Folder 
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9. Continue to drag and drop the windows to export from the upper right view 
window to the WindowSet001 folder.  If warnings or errors are incurred, they 
will be displayed in the right bottom status window, as shown in the figure 
below. 

 
Exporting Windows to Target Location 
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10. Conversion failures are also indicated in the status window, as shown in the 
figure below. 

 
Conversion Failures 
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11. A conversion error/warning report is generated for any window without a full 
export, as shown in the figure below. Select Report in the status window to 
view the report specifics. 

 
Conversion Error Report 
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12. Once all desired windows are exported into the Project folder, you must 
delete any windows that failed to export from the WindowSet001 folder by 
right-clicking on the window name and selecting Delete. 

 
Deleting Windows That Failed To Export 

 
Step 2: Run the Wonderware to GraphWorX32 Translator 
The second step in the conversion process is to import the new exported XML 
windows into GraphWorX using the ICONICS WWToGwxTranslator.exe utility: 

1. Launch the GENESIS32 WWtoGwxTranslator.exe utility from the Windows 
Start menu by selecting Programs > ICONICS GENESIS32 > Tools > 
Translators > Wonderware Convertor. Click Browse to select the Win-
XML Exporter file (use the .wxe Project file), as shown in the figure below. 
Browse to a Destination Directory to place the GraphWorX .gdf display 
files. Click Translate to begin a window-by-window translation.  
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Running the ICONICS InTouch to GraphWorX32 Translator 

2. Upon completion you should see a confirmation dialog, as shown in the 
figure below. 

 
Source File Conversion Successful 
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3. The .gdf displays are contained in the subfolder WindowSet001 in your 
specified destination directory, as shown in the figure below. 

 
Converted GraphWorX32 Display Files 
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