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Welcome To Help 
Use the Help system to lean more about the OPC Server for Allen-Bradley 
networks. 

• Find answers to your questions 

• Get connected easily using Quick Start  

• Connect to the web to get updates 

• Troubleshoot your server 

 

Copyright © 1999 ICONICS, Inc  All rights reserved.  

 

 
Using the 1784-PCMK on WIN NT 

Platforms: WIN NT 

The driver does not support PCMCIA socket services on WIN NT.   To use the 
1784-PCMK on WIN NT, you will need a copy of RSLinx-Lite (version 2.1 or 
later) to configure and allocate the WIN NT system resources used by the 1784-
PCMK.   

Once the system resources have been allocated, RSLinx-Lite does not need to 
run. 

If you do not have a copy of RSLinx-Lite,  a copy can be downloaded freely from 
the Web Updates area of the Rockwell Software support site 
http://support.software.rockwell.com/WebUpdates  Part # 9355WAB100END 

Procedure 

• Start RS-Linx Lite 

• From the RSLinx-Lite menu click  Communications -> Configure 
Drivers… 

• Select 1784-PCMK Devices from the Available Driver Types then click 
Add New..  

• Assign a name to the driver 

• Record the Board Address used by the 1784-PCMK (default D800) 

• All other RSLinx-Lite PCMK settings in are not required by the OPC 
Server. 

• Click Ok 

 

Select the Board Address value in the OPC Server driver configuration. 
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Using the 1784-PCMK on Windows 95/98 

Platforms: WIN 95/98 

The OPC Server does not support PCMCIA socket services on WIN 95/98.    To 
use the 1784-PCMK on WIN 95/98 you will need the Rockwell Software 1784-
PCMK Plug n-Play drivers.  If you do not have a copy of the Plug-n-Play driver, a 
copy can be downloaded freely from the Download area of the Rockwell 
Software support site 

http://www.software.rockwell.com/download/pcmk/rsipcmk.zip  

 

Procedure 

• Download the 1784-PCMK Plug-n-Play driver 

• Install the Plug-n-Play driver 

• Click Start -> Settings -> Control Panel -> System 

• Click Device Manager Tab of System Properties 

• Expand the Allen-Bradley PCMK Family device 

• Select Allen-Bradley 1784-PCMK/B (Driver 2.21) device 

• Click the Properties… button 

• Select the Resources Tab of the Allen-Bradley 1784-PCMK/B (Driver 
2.21) Properties 

• Record the first value of the Memory Range (e.g. 04010000 – 04010FFF) 

• Enter the Memory Range value in the OPC Server driver configuration. 

 
Using the 1784-PTKX on Win 95/98 

Platforms: WIN 95/98 

Only the single channel version of the 1784-PKTX is supported in this release.  
The dual-channel version (1784-PKTX/D) is not supported. 

You must install the PKTX Plug-n-Play driver in Windows 95/98 platforms. 

The Plug-n-Play driver is not required for WIN NT 

Installing the PKTX Plug-n-Play Driver 

• Click Start -> Settings -> Control Panel 

• Click Add New Hardware -> New Hardware Wizard 

• Select Unknown or Other -> (Standard System Devices) 
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• Select PCI Bus -> Have Disk "\Program Files\….\AB 
OPCServer\IGPKTX.INF" 

 
Quick Start 

Drivers 

What is a Driver ? 

 Add Serial DF1 Driver 

 Add Ethernet Driver to PLC/SLC 

 Ethernet Driver to Control Logix 5550 

 Add 1784-KT, KTX, PKTX, PCMK Card Driver 

 Add SS-Technologies 5136SD Card Driver 

 Edit an Existing Driver 

 Delete an Existing Driver 

 

Devices 

What is a Device ? 

 Add a Device 

 Edit a Device 

 Delete a Device 

 

Groups 

What is a Group  

 Add a Group 

 Edit a Group 

 Delete a Group 

 

Tags 

What is a Tag  

 Add a Tag 
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 Edit a Tag 

 Delete a Tag 

 Scaling a Tag Value 

 Tag Multiply 

 

OPC 

 What is OPC 

 OPC Test Client Application 
 
Adding a Serial DF1 Driver 

Platforms: WIN NT/95/98  WINCE 

What is a Driver  

Use this driver when communicating to PLC-5, SLC, MicroLogix and 
ControlLogix 5550 via Channel 0, 1770-KF2, 1770-KF3.   

Recommended Channel 0 Settings 

 PLC-5 

 SLC/MicroLogix 

 ControlLogix 5550 

 

Note:  The driver does not support the 1770-PIC module. 

• Click Edit -> Comm Settings … 

• From the Supported Drivers   
- select -  
Serial DF1 (Full Duplex ) to PLC/SLC/MicroLogix/L5550 

• Click Add… 

• Enter a Driver Name for the DF_1 driver.  
Examples of a Driver Name 
DF_1 
COM1_CH0 

• Click Ok 

• Select a Port  
Port Ranges COM1: to COM24: 
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• Select the Baud Rate  
Baud Rate = 300 -115200 
Select the baud rate that matches the PLC communication setting. 

• Select the Parity  
Parity = None, Odd, Even 
Select parity that matches the PLC communication setting.   
Normally the PLC is configured PARITY =  NONE 

• Select the Flow  
Flow =  Hardware RTS/CTS, Modem RTS+timeout, None 
Select the Flow that matches the communication setting of the PLC.   
Normally the PLC is configured for FLOW = NONE  

• Select the DataBits  
DataBits =  7 or 8   
Select the Databits that match the communication setting of the PLC.   
Normally the PLC is configured for DATABITS = 8 

• Select the StopBits  
StopBits =  1 or 2  
Select the StopBits that match the communication setting of the PLC.   
Normally the PLC is configured for STOPBITS = 1 
• Select the Checksum  
Checksum = BCC or CRC 
Select the Checksum that matches the communication setting of the PLC.   
CRC preferred checksum method  
• Click Ok 

 
Adding a Ethernet Driver to PLC/SLC 

Platforms: WIN NT/95/98  WINCE 

What is a Driver  

Use this driver when communicating Ethernet to a PLC-5 Processor, 1785-ENET 
Side Car module, or SLC 5/05 Ethernet Processor. 

 

• Click Edit -> Comm Settings… 

• From the Supported Drivers   
- select - 
AB 1785 ENET (PLC-5/SLC) 

• Click Add… 

• Enter a Driver Name for the Ethernet driver.   
Examples 
1785ENET_1 
PLC_ENET_6 

• Click Ok 
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• Enter the IP Address of the Ethernet PLC 

• Click Ok 

 

 
Adding 1784 Card Drivers 

Platforms: WIN NT/95/98 

What is a Driver  

Select the type of Communication Card you wish to add 

 Adding a 1784-KT Card 

 Adding a 1784-KTx Card 

 Adding a 1784-PKTX Card (PCI Card) 

 Adding a 1784-PCMK Card (PCMCIA Card) 

 

 

 
Adding a 1784-KT Card Driver 

Platforms: WIN NT/95/98 

Use this driver when using a 1784-KT (ISA Bus) Communication Interface Card 
for Data Highway Plus. 

 

Note:  Administrator Rights is required on WIN NT to add, delete or modify this 
driver. 

 

• Click Edit -> Comm Settings … 

• From the Supported Drivers  
- select -  
1784-KT/KTX(d)/PKTX/PCMK 

• Click Add … 

• Enter a Driver Name for the KT Card.   
Examples 
KT_1 
KT_NODE_77 

• Click Ok 
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• Select Network Type =  DH+ 

• Select Card Type = KT 

• Select the Base Address  
Base Address =  A0000-EF000  
The Base Address must match the DIP SW configuration settings of the 
KT Card. 

• Select a Station ID (Node Address) to assign the KT card.   
This must be a unique address from 00-77 octal and not conflict with any 
other nodes on the network. 

• Select the Baud Rate   
Only 57.6K is supported for the 1784-KT 

• (Optional) – Enter a Terminal Name for the KT Card.   
The Terminal Name can be 8 characters (MAX) 

• Click OK 

 

 
Adding a 1784-KTX/(d) Card Driver 

Platforms: WIN NT/95/98 

Use this driver when using a 1784-KTx or 1784-KTxD (ISA Bus) Communication 
Interface Card for Data Highway Plus or Data Highway 485. 

 

Note:  Administrator Rights is required on WIN NT to add, delete or modify this 
driver. 

 

• Click Edit -> Comm Settings … 

• From the Supported Drivers  
- select -  
1784-KT/KTX(d)/PKTX/PCMK 

• Click Add... 

• Enter a Driver Name for the KTX Card.   
Examples 
KTX_1 
KTX_DH485_17  

• Click Ok 

• Select Network Type =  DH+ or DH-485 

• Select Card Type = KTx(d) 
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• Select the Base Address setting for the 1784-KTx card  
Base Address = A0000-EF000.   
This setting must match the ROTARY SW configuration settings of the 
KTX Card. 

• Select a Station ID (Node Address) to assign the KTX card.   
This must be a unique number and not conflict with other nodes on the 
network 
DH+ = (00-77 octal) 
DH-485 = (00-31 decimal) 

• Select the Baud Rate   
DH+ Baud Rates =  57.6, 115K and 230K (default 57.6).    
DH-485 Baud Rates  =  9600 or 19200  (default 19200)  
The baud rate must match baud rate of the entire network, 

• (Optional) – Last Node (DH-485 Only).   
Select the last node address used on the DH-485 network.   
This can often increase the performance of the DH-485 network.  

• (Optional) - Enter a Terminal Name for the KTX Card.   
The Terminal Name can be 8 characters (MAX) 

• Click OK 

 
Adding a 1784-PTKX Card Driver 

Platforms: WIN NT/95/98 

Use this driver when using a 1784-PKTX (PCI Bus) Communication Interface 
Card for Data Highway Plus or Data Highway 485. 

 

See Release Note  Using the 1784-PTKX on Win 95/98  

 

Note:  Administrator Rights is required on WIN NT to add, delete, or modify this 
driver 

 

• Click Edit -> Comm Settings … 

• From the Supported Drivers  
- select - 
1784-KT/KTX(d)/PKTX/PCMK 

• Click Add... 

• Enter a Driver Name for the PKTX Card.   
Examples 
PKTX_0 
PKTX_1 
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• Click Ok 

• Select Network Type =  DH+ or DH-485 

• Select Card Type = PKTX 

• The Base Address Setting is disabled.   
The driver will acquire the PKTX base address from the PCI BIOS 

• Select a Station ID (Node Address) to assign the PKTX card.   
This must be a unique number and not conflict with other nodes on the 
network 
DH+ (00-77 octal) 
DH 485 (00-31 decimal) 

• Select the Baud Rate.   
DH+ Baud Rates  = 57.6, 115K and 230K (default 57.6).    
DH-485 Baud Rates  =  9600 or 19200 (default 19200).    
The baud rate must match baud rate of the entire network, 

• (Optional) – Last Node (DH-485 Only).   
Select the last node address used on the DH-485 network.   
This can often increase the performance of the DH-485 network.  

• (Optional) - Enter a Terminal Name for the PKTX Card.   
The Terminal Name can be 8 characters (MAX) 

• Click OK 

 
Adding a 1874-PCMK Card Driver 

Platforms: WIN NT/95/98 

Use this driver when using a 1784-PCMK (PCMCIA) Communication Interface 
Card for Data Highway Plus or Data Highway 485. 

 

Note:  Administrator Rights is required on WIN NT to add, delete, or modify this 
driver 

 

See Release Notes 

Using the 1784-PCMK on WIN NT  

Using the 1784-PCMK on Windows 95/98  

 

• Click Edit -> Comm Settings … 

• From the Supported Drivers  
- select - 
1784-KT/KTX(d)/PKTX/PCMK 

 10



• Click Add... 

• Enter a Driver Name for the PCMK Card.   
Examples 
PCMK_1 
PCMK_DHP_42  

• Click Ok 

• Select Network Type =  DH+ or DH-485 

• Select Card Type = PCMK 

• Enter the Base Address setting for the 1784-PCMK card  

• Select a Station ID (Node Address) to assign the PCMK card.   
This must be a unique number and not conflict with other nodes on the 
network. 
DH+ = (00-77 octal) 
DH-485 = (00-31 decimal)  

• Select the Baud Rate   
DH+ Baud Rates  =  57.6, 115K and 230K (default 57.6) 
DH-485 Baud Rates =  9600 or 19200 (default 19200).    
The baud rate must match baud rate of the entire network, 

• (Optional) – Last Node (DH-485 Only).   
Select the last node address used on the DH-485 network.   
This can often increase the performance of the DH-485 network.  

• (Optional) - Enter a Terminal Name for the PCMK Card.   
The Terminal Name can be 8 characters (MAX) 

• Click OK 

 

 
Adding a SS-Technologies 5136SD Card Driver 

Platforms: WIN NT/95/98 

What is a Driver  

Use this driver when using a SS-Technologies 5136SD (ISA Bus) 
Communication Interface Card for Data Highway Plus.  

Note:  Administrator Rights is required on WIN NT to add, delete, or modify this 
driver. 

 

• Click Edit -> Comm Settings … 

• From the Supported Drivers  
- select - 
SST-5136SD 
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• Click Add... 

• Enter a Driver Name for the SST Card.   
SST_1 
SST_DHP_77 

•  Click Ok 

• Select Card Personality =  Native DH+ (default)  or KT Emulation.   
KT Emulation permits the SST-5136SD card to be used concurrently by 
another application such as PLC Programming Software.  Consult the 
SST-56136SD Users Manual for more information regarding KT Emulation 
Mode. 

• Select I/O Port   
I/O Port = 200 – 2F8 and 600 – 6F8 (default = 250)   
Select the I/O Port assigned to the SST-5136SD by the DIP SWITCH 
settings on the card. 

• Select the Base Address setting to be assigned to the card  
Base Address = A0000-EF000.  

• Select a Station ID (Node Address) to assign the SST-5136SD card.   
DH+ = (00-77 octal) 
This must be a unique number and not conflict with other nodes on the 
network  

• Select the Baud Rate   
Baud Rates =  57.6, 115K and 230K (default = 57.6)  
The baud rate must match baud rate of the entire network, 

• (Optional) - Enter a Terminal Name for the SST-5136SD Card.   
The Terminal Name can be 8 characters (MAX) 

• Click OK 

 

 
OPC Device 

A Device is the end-point piece of hardware that you are communicating to such 
as a single node on a PLC network.  A Device is associated to a server Driver 
that is responsible for handling the details of communication.   You can configure 
as many devices in the OPC server as you like.  When naming Devices, you are 
encouraged to use intuitive names such as PLC5_StampPress42 

OPC Group 
A Group is an optional means for organizing data points from Devices.  You can 
define any of Groups underneath each Device to organize the data the way it 
would be most intuitive for your application.  For example, you can define a 
Group consisting solely of data points representing Temperature Readings, and 
have other Groups defined for data points representing Alarms, Presets or 
Setpoints. 
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An OPC client can configure the rate that an OPC server should provide the data 
changes to the OPC client. 

OPC Item 
An OPC Item (commonly referred to as a Tag ) represents a connection to a 
data source within the server.   All access to OPC Items is via an OPC Group 
objects that "contain" the OPC item, or simply where the OPC Item is defined. 

Adding A Device 
What is Device  

• Click Add -> New Device… 

• Enter a Name for the Device 
Examples: 
PLC-5 Node 17 Paint Booth 
SLC-ENET Assembly Line 6 
L5550-ENET Test Stand 11 

• Select the Driver Name to used to communicate to the Device  See Quick 
Start  

Serial Devices 

 Adding a PLC-5 Device 

 Adding a SLC Enhanced 

 Adding a SLC/MicroLogix 1000/1500 

 Adding a ControlLogix 5550 

Ethernet Devices 

 Adding a PLC-5 Device 

 Adding a SLC 5/05 Device 

 Adding a Control Logix 5550 

Data High Plus Devices 

 Adding a PLC-5 Device 

 Adding a SLC 5/04 Device 

Data Highway 485-Devices 

 Adding SLC Enhanced 

 Adding SLC/Micro Logix 1000/1500 
 

Adding a PLC-5 Serial Device 
Platforms: WIN NT/95/98  WINCE 
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PLC-5's Devices supported on DF1 
Under Device Properties 
• Select the DF1 Driver Name you created by Adding a Serial DF1 Driver  
• Select PLC-5 Family 
• (Optional) -  PLC Node (required when using a KF2 communication 
interface) 
PLC Node = (00-77 octal) 
• Enter a Timeout period (50-10000ms)  3000ms default. 
• (Optional)  Simulate  
• Click OK. 
 

Adding a SLC Enhanced Serial Device 
Platforms: WIN NT/95/98  WINCE 
SLC's (Enhanced) Devices supported on DF1 
• Select the DF1 Driver Name you created by Adding a Serial DF1 Driver  
• Select SLC Enhanced 
• (Optional) - PLC Node (required when using a KF2/KF3 communication 
interface) 
PLC Node = (00-77 decimal) KF2 to SLC 5/04 
PLC Node = (00-31 decimal) KF3 to SLC 5/03 
• Enter a Timeout period (50-10000ms)  3000ms. default. 
• (Optional) -  Simulate 
• Click OK. 
 

Adding a SLC/MicroLogix Serial Device 
Platforms: WIN NT/95/98  WINCE 

SLC/MicroLogix Devices supported on DF1 
• Select the DF1 Driver Name you created by Adding a Serial DF1 Driver  
• Select SLC/MicroLogix 
• (Optional) - PLC Node (required when using a KF3 communication 
interface) 
PLC Node = (00-31 decimal) 
• Enter a Timeout period (50-10000ms)  3000ms default. 
• (Optional) -  Simulate 
• Click OK. 

Adding a Control Logix 5550 Serial Device 
Platforms: WIN NT/95/98  WINCE 

• Select the DF1 Driver Name you created by Adding a Serial DF1 Driver  
• Select ControlLogix 
• Enter a CPU Slot of the ControlLogix 5550 
• Enter a Timeout period (50-10000ms)  3000ms default. 
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• (Optional) -  Simulate 
• Click OK. 
 

PLC-5 Devices Supported Under DF1 

Channel 0 and 1770-KF2 
PLC-5/10, PLC-5/15, PLC-5/20, PLC5-20E, PLC-5/25, PLC-5/30, PLC-5/40, 
PLC-5/40E, PLC-5/60, PLC-5/80, PLC-5/80E 

SLC Enhanced Devices Supported Under DF1 
Channel 0 - SLC 5/03, SLC 5/04, SLC 5/05 

1770-KF3 – SLC 5/03 

1770-KF2 – SLC 5/04 
SLC/MicroLogix Supported Under DF1 

Channel 0 – MicroLogix 1000/1500 
1770-KF3 – SLC 500, 5/01, 5/03 
 

Simulate 
Simulates data from a Device, but no I/O access to the Device occurs 
 

Adding a Ethernet Driver to Control Logix 5550 
Platforms: WIN NT/95/98   WINCE 

What is a Driver  

Use this driver when communicating Ethernet to a Control Logix 5550 Processor. 

 

• Click Edit -> Comm Settings… 

• From the Supported Drivers   
- select - 
AB 1756 ENET (Control Logix) 

• Click Add… 

• Enter a Driver Name for the Ethernet driver.   
Examples 
1756ENET_1 
L5550_LINE_4  

• Click Ok 

• Enter the IP Address of the Ethernet PLC 

• Click Ok 
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Adding a PLC-5 Ethernet Device 
Platforms: WIN NT/95/98  WINCE 
PLC-5 Devices supported on Ethernet 
Under Device Properties 
• Select the Ethernet Driver Name you created by Adding a Ethernet 
Driver to PLC/SLC  
• Select PLC-5 Family 
• (Optional) -  PLC Node  
• Enter a Timeout period (50-10000ms)  3000ms default. 
• (Optional)  Simulate  
• Click OK. 
 
 

PLC-5 Ethernet Devices 
• Ethernet Processors 

PLC-5/20E, PLC-5/40E, PLC-5/80E 

• 1785-ENET (Ethernet Side Car) 
PLC-5/10, PLC-5/15, PLC-5/20, PLC-2/25, PLC-5/30, PLC-5/40, PLC-5/60, 
PLC-5/80 

Adding a SLC 5/05 Ethernet Device 
Platforms: WIN NT/95/98  WINCE 
Under Device Properties 
• Select the Ethernet Driver Name you created by Adding a Ethernet 
Driver to PLC/SLC  
• Select SLC Enhanced 
• (Optional) -  PLC Node  
• Enter a Timeout period (50-10000ms)  3000ms default. 
• (Optional)  Simulate  
• Click OK. 

 

 
Adding a Control Logix 5550 Ethernet Device 

Platforms: WIN NT/95/98  WINCE 
Under Device Properties 
• Select the Ethernet Driver Name you created by Adding a Ethernet 
Driver to Control Logix 5550  
• Select Control Logix 5550 
• CPU Slot  Enter the rack I/O Slot where the Control Logix 5550 
Processor  resides 

 16



• Enter a Timeout period (50-10000ms)  3000ms default. 
• (Optional)  Simulate  
• Click OK. 

 
Adding a PLC-5 Data Highway Plus Device 

Platforms: WIN NT/95/98 

PLC-5 Devices supported on Data Highway Plus 
Under Device Properties 
• Select the KT/KTX/PKTX/PCMK/SST Driver Name you created by 
Adding 1784 Card Drivers  
• Select PLC-5 Family 
• PLC Node address of  the device 
PLC Node = (0-77 octal) 
• Enter a Timeout period (50-10000ms)  3000ms default. 
• (Optional)  Simulate  
• Click OK. 

 

 
PLC-5 Device supported on Data Highway Plus 

PLC-5/10, PLC-5/15, PLC-5/20, PLC5-20E, PLC-2/25, PLC-5/30, PLC-5/40, 
PLC-5/40E, PLC-5/60, PLC-5/80, PLC-5/80E 

 
Adding a SLC 5/04 Data Highway Plus Device 

Platforms: WIN NT/95/98 
Under Device Properties 
• Select the KT/KTX/PKTX/PCMK/SST Driver Name you created by 
Adding 1784 Card Drivers  
• Select SLC Enhanced 
• PLC Node address of the device 
PLC Node = (00-77 decimal) 
• Enter a Timeout period (50-10000ms)  3000ms default. 
• (Optional)  Simulate  
• Click OK. 

 
Modifying a Driver 

• Stop all client applications communicating to the server 
• Click View -> Comm Settings… 
• Double click the Driver Name in the list of Installed Drivers 
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• Edit the Driver Properties 
• Click OK 
 
 

Deleting A Driver 
• Stop all client applications communicating to the server 
• Click View -> Comm Settings… 
• Select the Driver Name in the list of Installed Drivers 
• Click the Delete button 
• Click OK 
 
IMPORTANT:  When deleting a driver, you must make sure the are no Devices 
referencing that driver. 
 
 

Modifying a Device 
• Stop any client applications using this Device 
• Select the Device to Modify in the Device/Group pane of the server. 
• Click Edit -> Properites 
• Edit the Device Settings 
• Click OK 
 
 
 

Deleting a Device 
• Stop all client applications communicating to the server 
• Select the Device to Modify in the Device/Group pane of the server. 
• Click Edit -> Delete 
• Click OK 
 
 
 

Adding A Tag 
What is a Tag  
• Select the Device or Group that you want to add tags to. 
• Click Add -> New Tag 
• Enter a Name for the Tag. 
Examples of Tag names: 
Temp Zone 1 Preset 
Batch Step Sequence Number 
• (Optional) – Enter a Description of the Tag 
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• Enter the data point for the Tag  
 PLC/SLC/MicroLogix Data Table File Addressing 
 ControlLogix 5550 CPU Tag Addressing 

• Select the Data Type for the Tag 
VT_BOOL  
VT_UI1  
VT_I2  
VT_I4  
VT_R4  
VT_BSTR  
• (Optional) – Scaling  
• (Optional) – Simulation signal 
• Click OK 
 

Adding a Group 
What is a Group  

• Click Add -> New Group… 

• Enter a name for the Group 
A Group name can be up to 32 characters (max), but cannot contain any 
periods "." 
Example Group names: 
Phase 1 Test Parameters 
Zone 3 Alarms 
Servo Positions 

• Click OK 

 

 
What is a Driver 

A driver is a configurable portion of the server that enables a specific piece of 
hardware (e.g. 1784-KTX communication interface card) to send and receive 
data packets to an end device (e.g. PLC-5). 

PLC/SLC Data Table Addressing 
The OPC Server supports native Allen-Bradley data-element addressing.   
FileType FileNumber:FileElement.FileSub-element 
Refer to your Allen-Bradley PLC Users Manual for additional information 
regarding data element addressing. 
Examples of data table addressing 
I:0, I:0/15 (PLC,SLC, Micro Discrete Input) 
I:1.3,  O:3.7 (SLC Analog Input) 
B3:100, B3:100/7, B3/255 
N7:15, N7:15/6 
F8:325 
T4:0.PRE, T4:8.DN 
PD32:11.SP, PD32:11.MO 
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FileType FileNumber FileElement FileSub-Element 

I – INPUT N/A 0-277 (oct) PLC-5 
0-30 (dec) SLC 
 
0 (MicroLogix) 

/0 to /15 (Discrete 
Input) 
/0 to /15 (Discrete 
Input)  
.0 to .31 (Analog 
Input) 
/0 to 15 (Discrete 
Input) 

O – OUTPUT N/A 0-277 (oct) PLC 
0-30 (dec) SLC 
 
0 (MicroLogix) 

/0 to /15 (Discrete 
Output) 
/0 to /15 (Discrete 
Output) 
.0 to .31 (Analog 
Output) 
/0 to /15 (Discrete 
Output) 

S – STATUS N/A 0-127 (PLC-5) 
0-82 (SLC) 
0-32 (MicroLogix) 

/0 to /15 

B – BINARY 3 (default) or user 
defined 

0-999 (PLC-5) 
0-255 (SLC) 
0-31 (MicroLogix) 

/0 to /15 

T – TIMER 4 (default) or user 
defined 

0-999 (PLC-5) 
0-255 (SLC) 
0-39 (MicroLogix) 

.EN  

.TT 

.DN 

.PRE 

.ACC 

C – COUNTER 5 (default) or user 
defined 

0-999 (PLC-5) 
0-255 (SLC) 
0-31 (MicroLogix) 

.CU 

.CD 

.DN 

.OV 

.UN 

.UA (SLC only) 

.PRE 

.ACC 

R – CONTROL 6 (default) or user 
defined 

0-999 (PLC-5) 
0-255 (SLC) 
0-15 (MicroLogix) 

.EN 

.EU 

.DN 

.EM 

.ER 

.UL 

.FD 

.UL 
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.IN 

.LEN 

.POS 

N – INTEGER 7 (default) or user 
defined 

0-999 (PLC-5) 
0-255 (SLC) 
0-104 (MicroLogix) 
 

/0 to /15 

F – FLOATING PT. 8 (default) or user 
defined 

0-999 (PLC-5) 
0-255 (SLC) 
N/A (MicroLogix) 

N/A 

D – BCD User defined 0-999 (PLC-5) 
0-255 (SLC) 
N/A (MicroLogix) 

/0 to /15 

A – ASCII User defined 0-999 (PLC-5) 
0-255 (SLC) 
N/A (MicroLogix) 

/0 to /15 

ST – STRING TBL User defined 0-999 (PLC-5) 
0-255 (SLC) 
N/A (MicroLogix) 

N/A 

PD – PID BLK User defined 0-999 (PLC-5) 
N/A (SLC/MicroLogix) 

.INI 

.SPOR 

.OLL 

.OLH 

.EWD 

.DVNA 

.DVPA 

.PVLA 

.PVHA 

.EN 

.CT 

.CL 

.PVT 

.DO 

.SWM 

.CA 

.MO 

.PE 

.SP 

.KP 

.KI 

.KD 

.BIAS 

.MAXS 

.MINS 

.MAXO 

.MINO 

.UDP 

.PV 
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.ERR 

.OUT 

.PVH 

.PVL 

.DVP 

.DVN 

.PVDB 

.DVDB 

.MAXI 

.MINI 

.TIE 

.ADDR[0-3] 

.DATA[0-13] 

SC – SFC Status User Defined 0-999 (PLC-5) 
N/A (SLC/MicroLogix) 

.SA 

.FS 

.LS 

.OV 

.ER 

.DN 

.PRE 

.TIM 

MG – MSG BLK User defined 0-999 (PLC-5) 
N/A (SLC/MicroLogix) 

.NR 

.TO 

.EN 

.ST 

.ER 

.CO 

.EW 

.ERR 

.RLEN 

.DLEN 

.DATA[0-51] 

BT – BLK XFR User Defined 0-999 (PLC-5) 
N/A (SLC/MicroLogix) 

.EN 

.ST 

.DN 

.ER 

.NR 

.TO 

.RW 

.RLEN 

.DLEN 

.FILE 

.ELEM 

.RGS 

 

 

 22



ControlLogix 5550 CPU Tag Addressing 
The OPC Server supports native ControlLogix 5550 CPU Tag addressing.  
Also see ControlLogix 5550 Optimized Reads  

For additional information on ControlLogix 5550 CPU tag addressing, refer to the 
ControlLogix 5550 Users Manual. 

• ControlLogix 5550 tags fall into 2 categories: 
Global and Program 

• Global Tag addressing syntax 
TagName 
Examples:   
MyTag 
MyArray[11] 
MyStruct.Subelement 

• Program Tag addressing syntax 
Program:ProgramName.TagName 
Examples:  
Program:MyProgram.MyTag  
Program:MyProgram.MyArray[11] 
Program:MyProgram.MyStruct.Subelement 

Tag or Array 
Type 

Sub - Element 

BOOL N/A 

SINT N/A 

INT N/A 

DINT N/A 

REAL N/A 

User Defined Data 
Type 

User Defined 

TIMER .PRE 
.ACC 
.EN 
.TT 
.DN 
.FS  
.LS 

COUNTER .PRE 
.ACC 
.CU 
.CD 
.DN 
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.OV 

.UN 

.UA 

MESSAGE .Flags 
.ERR 
.EXERR 
.DN_LEN 
.EW 
.DN 
.ST 
.TO 
.EN_CC 

MOTION_GROUP .GroupStatus,  
.MotionFault  
.ServoFault  
.GroupFault  
.InhibStatus. 
.GroupSynced  
.ACAsyncConnFault  
.ACSyncConnFault  
.POtrvlFault  
.NotrvlFault  
.PosErrorFault  
.EncCHALLossFault  
.EncCHBLossFault  
.EncCHZLossFault  
.EncNsFault  
.DriverFault  
.SyncConnFault  
.HardFault  
.GroupOverlapFault 

MOTION_STATU
S 

.Flags  

.ERR  

.STATUS  

.STATE  

.EN  

.EW  

.DN  

.ER  

.PC  

.IP 

PID .CTL  
.SP  
.KP  
.KI  
.KD  
.BIAS  
.MAXS  
.MINS 
.DB  
.SO  
.MAXO  
.MINO  
.UPD  
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.PV  

.ERR 

.OUT 

.PVH 

.PVL 

.DVP 

.DVN 

.PVDB 

.DVBD 

.MAXI 

.MINI 

.TIE 

.MAXCV 

.MINCV 

.MINTIE 

.MAXTIE 

.DATA[0-16] 

.INI 

.SPOR 

.OLL 

.OLH 

.EWD 

.DV 

.DVNA 

.DVPA 

.PVLA 

.PVHA 

.EN 

.CT 

.CL 

.PVT 

.DO 

.SWM 

.CA 

.MO 

.PE 

.NDF 

.NOZC 

.NOBC 
 

 

Edit a Group 
• Stop all client applications using the server 
• Select the Group to Modify in the Device/Group pane of the server. 
• Click Edit -> Properites 
• Edit the Group Name 
• Click OK 
 

Deleting a Group 
• Stop all client applications using the server 
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• Select the Group to Delete in the Device/Group pane of the server. 
• Click Edit -> Delete 
• Click OK 
 

Edit a Tag 
• Stop all client applications using the server 
• Select the Tag to Edit in the Tag pane of the server. 
• Click Edit -> Properties 
• Click OK 
 

Deleting a Tag 
• Stop all client applications using the server 
• Select the Tag to Delete in the Tag pane of the server. 
• Click Edit -> Delete 
• Click OK 
 

VT_BOOL Data Type 
VT_BOOL - Boolean, Discrete, ON/OFF, True/False 

• PLC-5/SLC/MicroLogix 
Bit-Level Element 

• ControlLogix 5550 
BOOL Tag 

VT_UI1 Data Type 
VT_UI1 - BYTE Value (0-255) 

• PLC-5/SLC/MicroLogix 
No equivalent data type 

• ControlLogix 5550 
SINT Tag 

VT_I2 Data Type 
VT_I2 – 16-Bit Signed Integer value ( positive 32767 to negative 32768) 
• PLC-5/SLC/MicroLogix  
Data Table Word Value 
• ControlLogix 5550  
INT Tag 

VT_I4 Data Type 
VT_I4 – 32-Bit signed long value (positive 2147483647 to negative 2147483648 ) 

• PLC-5/SLC/MicroLogix 
No equivalent data type 
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• ControlLogix 5550 
DINT Tag 

VT_R4 Data Type 
VT-R4 - 32-Bit IEEE single precision real (positive 3.40282347E+38 to negative 
1.40239846E-45) 
• PLC-5/SLC/MicroLogix 
Floating Point Data Table Element 

• ControlLogix 5550 
REAL Tag 

VT_BSTR Data Type 
VT_BSTR – String Data Type 

• PLC-5/SLC/MicroLogix 
ST Table, ASCII Table 

• ControlLogix 5550 
SINT Array 

 

 
Tag Multiply 

Tag Multiply allows you to quickly create a block tags derived from a root tag. 

• Tag Multiply only supports PLC-5/SLC/MicroLogix data table files  I, O, S, 
N, B, F 

• Tag Multiply cannot be used for structure-based data table files (e.g 
Timers/Counters/PD Blk, etc..) 

• Tag Multiply cannot be used for mnemonic data table sub-elements (e.g 
T4:0.PRE, C5:0.DN) 

• The user is responsible to ensure the tags created do not exceed the size 
of the data table 

• Tag Multiply cannot be used for ControlLogix 5550 CPU Tags 

 

Using Tag Multiply 

• Select a Tag from the Tag Pane of the server. 

• Click Add -> Multiply.. 

• Enter a Base Name for the Tag 

• Enter the File Addr  
This is the starting file address File Address (e.g. N7, B3, F8) 
For INPUTS enter I 
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For OUTPUTS enter O 
For STATUS enter S 

• Enter the First Element  
This is the starting data table element in the file address (e.g. 1, 13, 255) 

• (Optional) Bit 
Select the Bit checkbox 
Enter the value for the starting bit (0-15) 

• Enter the Number of Places 
This will pad the address and Tag Name with this number of characters (1-
6) 

• Enter the Number of Tags 
This is the number of Tags to create (1-999) 

•  Click OK. 

 

Example 
Base Name  = MyTag 
File Element = N7 
First Element = 1 
Number of Places = 3 
Number of Tags = 10 

Tags Created 

MyTag001 N7:001 

MyTag002 N7:002 

MyTag003 N7:003 

MyTag004 N7:004 

MyTag005 N7:005 

MyTag006 N7:006 

MyTag007 N7:007 

MyTag008 N7:008 

MyTag009 N7:009 

MyTag010 N7:010 

 

Bit Tag Example 
Base Name  = Bit Tag 
File Element = B3 
First Element = 0 
Number of Places = 3 
Number of Tags = 10 
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Tags Created 

Bit Tag001 B3:0/0 

Bit Tag002 B3:0/1 

Bit Tag003 B3:0/2 

Bit Tag004 B3:0/3 

Bit Tag005 B3:0/4 

Bit Tag006 B3:0/5 

Bit Tag007 B3:0/6 

Bit Tag008 B3:0/8 

Bit Tag009 B3:0/9 

Bit Tag010 B3:0/10 

 
 
 

 
File New 

File New creates a new workspace and tag database for the server 

Click File -> New 

 
File Open 

File Open loads an existing tag database to be used by the server 

Click File -> Open.. 

 
File Save 

File Save saves the current tag database 

Click File->Save 

 
File Save As 

File Save As saves the current tag database as a different filename 

Click File->Save As… 
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File ImportCSV 
File ImportCSV imports a CSV (Comma Separated Variable) file previously 
saved with File ExportCSV  

Click File->ImportCSV… 

Note: The CSV functions only import/export Device, Group and Tag Information.  
CSV functions do not import/export Driver information 

 

 
File ExportCSV 

File ExportCSV exports the Device, Group and Tag information to a CSV 
(Comma Separated Variable) file. 

Click File -> ExportCSV… 

 

 

 
File ReimportCSV 

File ReimportCSV re-imports the current CSV file 

Click File -> ReimportCSV 

Also See File ImportCSV  

 

 
File ReexportCSV 

File ReexportCSV re-exports the current CSV file 

Click File -> ReexportCSV 

Also See File ExportCSV  

 

 
Most Recently Used List 

File display the list of the Most Recently Used (MRU) tag databases 

Click the FileName in the MRU to open that tag database 
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OPC Server Window 
Platforms: WIN NT/95/98  WIN CE 

 

The OPC Server is divided into 3 Panes 

• Device/Group Pane 
Displays all the Devices and Groups defined in the server 

• Tag Pane 
Displays the Tags associated a given Device or Group 
Name – OPC Tag Name 
Type – Data Type of Tag 
Location – Data Source of the Tag 
Processing – Scaling, Simulation, etc.. 
Value – Current Tag Value 
Description – Tag Description 

• Driver Status Pane 
Displays Status and diagnostic information for the drivers used by the 
server 
Driver Name – Displays Driver and communication information 
Status – Current Status of the driver 
Sent – Driver Messages Sent to the Device(s) 
Recv – Driver Messages Received from the Device(s) 
Last Error – Last Communication Error the driver had with the Device(s) 

 

  

 

 
OPC Server Monitor 

Platforms: WIN NT/95/98 

The OPC Server allows you to monitor and test Drivers, Devices, Groups and 
Tags 

Click View -> Monitor 

 

 
Software Requirements 

Platforms: WIN NT/95/98 

• Microsoft Windows NT 4.0 Service Pack 3 or later is highly recommended 

• Microsoft Windows 95 with DCOM for Windows 95 

• Microsoft Windows 98 
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Platforms: WIN CE 

• Microsoft Windows CE 211 

 
Hardware Requirements 

Platforms: WIN NT/95/98 

Minimum Hardware Requirements 

• Intel-based Pentium Processor with at least 64 Megs of RAM 

• At least 10 Megs of available hard disk space 

• A 16-color SVGA display 

• A Windows-compatible pointing device 

 

Platforms: WIN CE 211 

• HPC X86 

• HPC SH/3 

• HPC SH/4 

• HPC StrongArm 

• HPC MIPS 

 
PLC-5 Channel 0 Settings 

Typical Channel 0 (DF1) Settings for a PLC-5 Device 

 

Communication Module 

• Point-To-Point 

Serial Port Tab 

• Baud Rate = 19.2K 

• Bits Per Char = 8 

• Stop Bits = 1  

• Control Line = No Handshaking  

• Parity = None  
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• Error Detect = CRC 

Options Tab 

• NAK Receive = 3 

• DF1 ENQ’s = 20 

• ACK Timeout = 50 

• Detect Duplicate Messages = Checked 

• Message Application Timeout = 30 Seconds 

 

 
SLC Channel 0 Settings 

Typical Channel 0 Settings for a SLC/MicroLogix Device 

Chan. 0 – System Tab 

• Driver = DF1 Full Duplex 

• Baud = 19200 

• Parity = NONE 

• Stop Bits  = 1 

Protocol Control Settings 

• Control Line = No Handshaking 

• Error Detection = CRC 

• Embedded Responses = Enabled 

• Duplicate Packet Detect = Checked 

• ACK Timeout (x20 ms) = 50 

• NAK Retries = 3 

• ENQ Retries = 3 

  

 

 
ControlLogix 5550 Channel 0 Settings 

Typical Channel 0 Settings for ControlLogix 5550 

Serial Port Tab 
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• Baud Rate = 19200 

• Parity = None 

• Data Bits = 7 

• Stop Bits = 1 

• Control Line = No Handshaking 

• RTS Send Delay (x20 ms) = 0 

• RTS Off Delay (x20 ms) = 0 

Serial Protocol Tab 

• Protocol = DF1 Pt to Pt 

• Station Address = 0 

• NAK Receive Limit = 3 

• ENQ Transmit Limit = 3 

• ACK Timeout (x20 ms) = 50 

• Embedded Responses = Autodetect 

• Error Detection = CRC 

• Enable Duplicate Detection = Checked 

 

 
Adding a SLC Enhanced Device to DH-485 

Applies to SLC 5/03 
Under Device Properties 
• Select the KTX/PKTX/PCMK/SST Driver Name you created by Adding 
1784 Card Drivers  
• Select SLC Enhanced 
• PLC Node address of the device 
PLC Node = (00-31 decimal) 
• Enter a Timeout period (50-10000ms)  3000ms default. 
• (Optional)  Simulate  
• Click OK. 

 

 

 

 34



Adding a SLC/MicroLogix Device to DH-485 
Platforms: WIN NT/95/98 
 
Applies to SLC 500, 5/01, 5/02, MicroLogix AIC 
Under Device Properties 
• Select the KTX/PKTX/PCMK/SST Driver Name you created by Adding 
1784 Card Drivers  
• Select SLC/MicroLogix 
• PLC Node address of the device 
PLC Node = (00-31 decimal) 
• Enter a Timeout period (50-10000ms)  3000ms default. 
• (Optional)  Simulate  
• Click OK. 

 

 

 
Dialog Box Error Messages 
Message Cause Solution 

OLE Initialization Failed The OLE libraries failed to 
initialize 

Contact Product Support 

Windows sockets 
initialization failed 

WINSOCK libraries failed to 
initialize. 

Install Windows TCP/IP 
networking on your system 

Could not run …  The server did not recognize 
the command line parameter 

 REGSERVER  and 
UNREGSERVER are the only 
2 command line parameters 
available. 

No drivers have been 
installed 

A warning is being provided 
indicating that there are no 
drivers available for devices 

Add one or more drivers 

Please Enter a Driver Name A name was not assigned to a 
driver 

Assign a unique name to the 
driver 

DriverName is already using 
COMn: 

DriveName has already been 
assigned this COM Port 

Select an alternate COM Port 

DriverName is already using 
Address IP Address 

DriverName has already been 
assigned this IP Address 

Select an alternate IP Address 

DriverName is already using 
Base Address BaseAddress 

DriverName has already been 
assigned this BaseAddress 

Select an alternate Base 
Address 

Administrator rights are 
required to create registry 
settings for DriverName 

The current user does not 
have sufficient privileges to 
change the driver settings  

A user with Administrator 
privileges is required to 
change these settings 

DriverName is already using 
I/O Port PortNum 

DriverName has already been 
assigned this I/O Port 

Select an alternate I/O Port 
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Cannot change driver 
configuration while server is 
running or connected to 
clients 

An attempt was made to 
change a driver configuration 
while the server had clients 
connected 

Stop all client applications 
before changing driver 
configuration 

Invalid character(s) in Driver 
Name 

The Driver Name contains one 
or more invalid characters 

Rename the driver using 
characters "A-Z", "0-9" and 
underscore "_" 

Please enter an IP Address 
or computer name 

An IP Address or Computer 
Name was not provided for an 
Ethernet drivers 

Provide a valid IP Address or 
Computer Name. 

Select a Baud Rate A Baud Rate has not been 
assigned to the current driver 

Assign a baud rate 

Select a Station ID A Station ID has not been 
assigned to the current driver 

Assign a Station ID 

Select a driver for this 
device 

A driver has not been 
associated to a newly created 
device 

Select a Driver in Device 
Properties 

Group’s Name already 
exists 

The Group Name is already in 
use under device 

Provide a unique GroupName 

Group’s Name cannot 
accept Dots 

A Group Name contained one 
or more Dots "." 

Remove the Dots from the 
Group Name 

Tag Name already exists The Tag Name is already in 
use under Device/Group 

Provide a unique Tag name 

Tag Name cannot accept 
Dots 

A Tag Name contained one or 
more Dots "." 

Remove the Dots from the Tag 
Name 

Cannot Scale VT_BOOL or 
VT_BSTR data types 

An attempt was made to scale 
a VT_BOOL or VT_BSTR data 
type 

Scaling for VT_BOOL and 
VT_BSTR is not supported 

Unable to Open File The selected tag database 
failed is not valid.  The file/disk 
may be corrupt or damaged 

Select a valid tag database 

IMPORT FAILED, No Device 
or Group Available. 

No Device or Groups were 
found in the CSV File.  The file 
may be corrupt or damaged 

Export a CSV file containing 
appropriate Device/Groups 

Bad lines encountered. The CSV file contained invalid 
information. The file may be 
corrupt or damaged 

Export a CSV file containing 
appropriate information 

File exception while reading. An error occurred while 
reading the file from disk. The 
file/disk may be corrupt or 
damaged. 

Select and alternate file, or 
use a backup copy. 

Unable to create file. An error occurred while 
creating the file to disk.  The 
disk may be full, corrupt or 
damaged 

Select and alternate disk to 
save the file to. 

File exception while writing An error occurred while writing 
the file to disk.  The disk may 

Select and alternate disk to 
save the file to. 
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be full, corrupt or damaged 

 

 

 
Driver Error Messages 
Error Message Cause Solution 

ERROR! - Device Conflict The driver has detected a 
resource conflict with another 
system device 

Correct the system resource 
conflict 

ERROR! - Driver Cannot 
Connect to Hardware 

The driver cannot connect the 
hardware interface 

Contact Technical Support 

ERROR opening file 
FileName 

An error has occurred while 
attempting to open FileName.  
The file may not exist, or the 
file/disk is corrupt or damage 

Replace the file or disk with a 
back-up copy 

ERROR reading file 
FileName 

An error has occurred while 
reading FileName.  The 
file/disk is corrupt or damage 

Replace the file or disk with a 
back-up copy 

ERROR Diagnostic Failed A 1784 card device failed a 
diagnostic test 

Verify the Base Address 
Setting assigned to the card 

Replace the card 

ERROR  allocating PCL 
Memory 

Memory could not be allocated Contact Technical Support 

ERROR Protocol Load 
Failed 

The 1784 card device failed to 
load the protocol 

Replace the card 

ERROR Failed to go on line The DH+/DH-485 card failed 
to connect to network 

Verify network connection 

Replace the card 

ERROR Duplicate node 
detected 

The Station ID assigned to the 
DH+/DH-485 card is already 
being used by another node 
on the netword 

Change the Station ID 
assigned to the card 

ERROR! - Card is Not SD-2 
Type Card 

The SS-Technologies 5136SD 
is not a SD-2 type card. 

Replace the card with a SD-2 
type card. 

ERROR! - Cannot not 
access low memory block 

The driver could not access a 
low memory block of the SST-
5136SD card 

Verify driver settings 

Replace the card 

ERROR! - SST Card is in 
BUSY STATE 

The SST card has failed a 
diagnostic test and is not 
responding 

Verify driver settings 

Replace the card 

ERROR! - Card is not in a 
READY STATE 

The SST card has failed a 
diagnostic test and is not 
responding 

Verify driver settings 

Replace the card 

ERROR! - Card halted in 
TEST STATE 

The SST card has failed a 
diagnostic test and is not 

Verify driver settings 
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responding Replace the card 

ERROR Opening COM Port The driver could not open the 
Com Port. See Error Codes 

Verify the COM port is not 
being used by another 
application 

Verify the COM port settings 

ERROR GetCommState() 
Failed 

See Error Codes Verify the COM port is not 
being used by another 
application 

Verify the COM port settings 

ERROR  SetCommState() 
Failed 

See Error Codes Verify the COM port is not 
being used by another 
application 

Verify the COM port settings 

ERROR  
GetCommTimeouts() Failed 

See Error Codes Verify the COM port is not 
being used by another 
application 

Verify the COM port settings 

ERROR SetCommTimeouts() 
Failed 

See Error Codes Verify the COM port is not 
being used by another 
application 

Verify the COM port settings 

ERROR writing to COM Port An error occurred while 
attempting to write to the COM 
Port 

Verify the COM port settings 

Verify the connection to the 
device 

ERROR reading from COM 
Port 

An error occurred while 
attempting to write to the COM 
Port 

Verify the COM port settings 

Verify the connection to the 
device 

ERROR  Socket Create An error occurred while 
attempting to open a TCP/IP 
socket  See Error Codes 

Verify the operation of your 
TCP/IP network 

ERROR  Socket Connect An error occurred while 
attempting to establish a 
TCP/IP connection to the PLC   
See Error Codes 

Verify the operation of your 
TCP/IP network 

ERROR  Socket Send An error occurred while 
sending data to an Ethernet 
PLC  See Error Codes 

Verify the IP Address you 
assigned to the Ethernet 
driver. 

Verify the operation of your 
TCP/IP network 

ERROR Recv Socket An error occurred while 
sending data to an Ethernet 
PLC  See Error Codes 

Verify the IP Address you 
assigned to the Ethernet 
driver. 

Verify the operation of your 
TCP/IP network 
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ERROR PLC Connection 
Error 

An error occurred while 
attempting to establish dialog 
with a PLC-5/SLC Ethernet 
device 

Verify you are using the 1785-
ENET Driver  See Adding a 
Ethernet Driver to PLC/SLC  

ERROR ControlLogix 5550 
Connection Error 

An error occurred while 
attempting to establish dialog 
with a PLC-5/SLC Ethernet 
device 

Verify you are using the 1756-
ENET Driver See Adding a 
Ethernet Driver to Control 
Logix 5550  

 

 

 
Error Codes 

System/Driver Error Codes 

ERROR CODE Description 

2 (COM PORT) COM Port does not exist 

5 (COM PORT) Access is denied – COM Port is already in use 

6 (COM PORT ) Handle is invalid – COM Port cannot be accessed 

276D (WINSOCK)  Windows Sockets initialized 

2742 (WINSOCK) The network subsystem has failed 

274D (WINSOCK)  PLC refused connect attempt 

2743 (WINSOCK) The network cannot be reached from the Host at this time 

2747 (WINSOCK) No buffer space is available.  The socket cannot be 
connected 

  

 

PLC Communication Error Codes 

ERROR CODE Description 

104 Invalid Tag Name (ControlLogix 5550) 

1FF Invalid Data Type for Tag Name (ControlLogix 5550) 

200 Cannot guarantee delivery. 

300 duplicate token hold detected 

400 local port is disconnected 

500 application layer timed out waiting for response 
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600 duplicate node detected 

700 station is off line 

800 hardware fault 

1000 illegal command or format 

2000 host has problem and cannot communicate 

3000 remote node is missing, disconnected or shutdown 

4000 host could not complete function due to hardware fault 

5000 addressing problem 

6000 function disallowed 

7000 processor in program mode 

8000 compatibility mode file missing 

9000 remote node cannot buffer command 

B000 remote node problem due to download 

C000 cannot execute due to active IPBS 

F001 a field has an illegal value 

F002 less levels specified in address than minimum for any address 

F003 more levels specified in address than system supports 

F004 symbol not found 

F005 symbol is not proper format 

F006 file address doesn't point to something useful 

F007 file is wrong size 

F008 cannot complete request 

F009 data or file is too large 

F00A transaction plus word size is too large 

F00B access denied 

F00C condition cannot be generated 

F00D condition already exists 

F00E command cannot be executed 

F00F histogram overflow 

F010 no access 
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F011 illegal data type 

F012 invalid parameter or invalid data 

F013 address reference exists to deleted area 

F014 command execution failure for unknown reason 

F015 data conversion error 

 

 
OPC Test Client Connecting to the Server 

WIN NT/95/86 

• Start the OPC Test Client Application  OPCLIENT.EXE 

• Click OPC -> Connect … 

• Select the Iconics.ABServer Server 

• Click OK 

 

WIN CE 

• Start the OPC Test Client Application OPCLIENTCE.EXE 

• Click OPC -> Connect … 

• Select the ABWinCE Server 

• Click OK 

 
OPC Test Client Tag Browsing 

• Click OPC -> Add Item … 

• Select the Device in the Browse items Window 

• Select a Group under the Device 

• Select a Tag from the Group 

• Click OK. 

The data value for the Tag and the Value will be shown in the test client window. 

Browse for additional Tags if desired 
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OPC Test Client Writing a Value 
• Select a Tag from the OPC Test Client Window 

• Click OPC -> Write Value to Item… 

• Enter a new value for the Item 

• Click OK 

 

 

 

 
OPC Test Client 

 Connecting to the Server 

 Tag Browsing 

 Writing a Value 

 

 
What is OPC 

OPC stands for OLE for Process Control.  OPC is a specification that defines 
how two software applications should communicate with each other.  OPC is a 
specification that is specific to the manufacturing automation industry.  OPC was 
created by manufacturers and users in the automation industry.  The OPC 
specification is managed by the independent OPC Foundation, whose members 
include over 200 automation industry software developers from around the world.   
The OPC Foundation was founded in 1996.   The OPC technical specifications 
are based upon the Microsoft Component Object Model (COM) and the 
Distributed Component Object Model (DCOM).  The COM and DCOM 
specifications are the core architectural pieces that make up the Microsoft 
Windows 95,98, and NT operating systems.  

 

 OPC Server 

 OPC Device 

 OPC Group 

 OPC Item 

 OPC Client 

 OPC Client/Server Relationship 
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Learn More… 

OPC Foundation  

Microsoft's Manufacturing Industry Section  

 

 

 
OPC Servers and Clients 

OPC Client/Server Relationship 

The drawing below illustrates graphically the concept of OPC Client and Server 
applications interacting with each other.  An interesting point to note is that the 
client and server applications need not reside on the same computer.  When the 
do, the COM architecture is used for communications.  When the client and 
server are on separate PCs with a network connecting them, the Microsoft 
DCOM architecture is used for communications.  

 

OPC Servers and Clients go much further than just device communications 
drivers.  In fact, a single application can be an OPC Client and an OPC Server.  
For example, there are some HMI packages that are OPC Clients and they 
connect to OPC Servers, which in turn gather the data from the user’s PLCs or 
control hardware.  At the same time, some of those same HMI packages are also 
OPC Servers and make their tag databases available to other OPC Client 
applications.  

 

 

 

 
OPC Client 

OPC Client 

The requesting program or application is called an OPC Client. A single OPC 
Client application can talk to multiple OPC Server applications.   Examples of 
OPC Client applications include many Human Machine Interface (HMI) 
packages, including IconicsTM Genesis32TM, GE CimplicityTM, RS-View32TM, 
CitectTM, Wonderware InTouchTM, Intellution iFix/Fix DynamicsTM, and many 
more.  With over 200 member companies supporting the OPC specification, the 
number and variety of OPC client applications continues to grow.  
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OPC Server 
OPC Server 

An OPC DataAccess Server is comprised of several objects: the server, the 
Group, and the Item.  The OPC server object maintains information about the 
server and serves as a container for OPC group objects.  The OPC group object 
maintains information about itself and provides the mechanism for containing and 
logically organizing OPC items. 

 

 
Tag Scaling 

Scaling allows you to convert a raw (unscaled value) to given numeric range 

Raw 

• Enter the Min Raw Value to be scaled 

• Enter the Max Raw Value to be scaled 

Scales to 

• (Optional) – Enter a Units of Measure Identifier (e.g. Degrees C) 

• Enter the Min value of the scaled units 

• Enter the Max value of the scaled units 

Conversion Method 

• Linear Conversion 

• Square Root Conversion 

 

 

 
Tag Simulation 

Simulates a data value for the Tag 

This feature is enabled when the Device Simulate option is selected. 

Tag Scaling can be applied to simulated values. 

 

Types of Tag Simulation 

• Sine 

• Ramp 
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• Random 

 

 
WIN CE Server 

The Windows CE version of the OPC Server is an In-Process DLL. 
(ABWINCE.DLL) 

Since the .DLL itself has no user interface, a configuration application is provided 
to create and maintain the tag database. 

Communication Interfaces Supported 

• 1785-ENET for PLC-5, SLC-5/05 

• 1756-ENET for ControlLogix 5550 

• Full Duplex DF1 Serial, PLC-5/SLC/MicroLogix/ControlLogix 5550 

Using the ABWINCE.DLL in-process server for Windows CE 

• Create a tag database on your desktop computer using the configuration 
program 

• Save the tag database under the filename ABWINCE.TDB. 

• Copy ABWINCE.DLL and ABWINCE.TDB to any directory on the Windows 
CE device. 
NOTE:  ABWINCE.DLL and ABWINCE.TDB must reside in the same 
directory. 

• Run REGSVRCE /ABWINCE.DLL to set CE registry information for the 
server 

 

 
What's Not Supported 

• Control Logix 5550 via DH+ 

• PLC-2 Family of Processors 

• PLC-3 Family of Processors 

• PLC-5/250 Processors 

• ControlLogix Gateway 

• 1770-PIC/AIC Communication Interfaces 

• Unsolicited Messages 

• DH+/DH-485 Network Bridge and Routing 
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OPC Server Features 

General Features 

• Intuitive and easy to use 

• Multiple communication interfaces supported in a single server 

• Does not rely on middle-ware drivers 

• Serial DF1 to PLC-5/SLC/MicroLogix/ControlLogix 5550 (COM1 ~ COM 
24) 

• ENET to PLC-5/SLC 

• ENET to ControlLogix 5550 

• 1784-KT/KTX/PKTX/PCMK/SST-5136 to PLC-5/SLC Data Highway Plus 
(Up to 230K Baud) 

• 1784-KTX/PKTX/PCMK to SLC/MicroLogix Data Highway 485 

• Use any mix and any number of communication interfaces concurrently 

• 32-Bit multi-threaded driver operation for fast throughput 

• Optimized Block Read/Write Operations 

• Supports a wide range of OPC Clients 

OPC Features 

• OPC Specification Version 1.0/2.0 Compatible 

• OPC Item (Tag) Browsing 

• On-line/Off-Line Operation 

 

 

 
Allen-Bradley Knowledge Base 

Search the Allen-Bradley Knowledge Base  

 

 
Driver Name 

General 

• Driver names must be unique  
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• Driver names can be up to 15 characters (MAX)  

• Driver names can consist of letters "A-Z", numbers "0-9" and an 
underscore "_" 

1784-PKTX  

• Driver name must be PKTX_0 for the first PKTX card, PKTX_1 for the 
second, PKTX_2 for the third, etc… 

 
Device Names 

General 

• Device names must be unique  

• Device names can be up to 32 characters (MAX)  

• Device names can consist of any character except Dots (periods ".")  
Tag Names 

General 

• Tag names must be unique  

• Tag names can be up to 32 characters (MAX)  

• Tag names can consist of any character except Dots (periods ".")  
Group Names 

General 

• Group names must be unique  

• Group names can be up to 32 characters (MAX)  

• Group names can consist of any character except Dots (periods ".") 

 
Software Registration 

To register the OPC Server 

• Click -> License 

• Select Server Registration… 

 

Contact your software vendor and provide 

• Installation ID 

• Serial Number you received when you purchased the Server 
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The software vendor will provide you with the Registration Code 

• Click OK 

If the Product Registration code is invalid, the server will operate in a 2-hour 
demo mode 

 

 
Temporary Software License 

You can immediately assign the server a one-time, 10-Day Temporary Software 
License.  

• Click -> License 

• Select Temporary License 

• Restart the Server. 
 
The server will operate without restriction for 10-Days.    

• After the 10-Day period you will be required to register the server with your 
software vendor.   

• If you do not register within the 10-Day period, the server will resume a 2-
hour demo mode. 

• You can register the server at any time during or after the 10-Day period. 

• The server recognizes attempts to back up the system clock, and will 
revert to the 2-hour demo if detected. 

 

 
Notice 

Microsoft, Windows WIN NT, Windows 95/Windows 98, Windows CE, are 
trademarks of the Microsoft Corporation.  Allen-Bradley, PLC, SLC, MicroLogix, 
ControlLogix, ControlLogix Gateway, DataHighway, Data Highway Plus, Data 
Highway 485, are trademarks of the Allen-Bradley Company, Inc. a division of 
Rockwell Automation.  All other trademarks are owned by their respective 
companies.   

 
Information in this document is subject to change without notice. No part of this 
document may be reproduced or transmitted in any form or by any means, 
electronic or mechanical, for any purpose, without express written permission of t 
NCONICS, Inc. The software described in this document is furnished under a 
license agreement or nondisclosure agreement. The software may be used or 
copied only in accordance with the terms of the License Agreement. It is against 
the law to copy the software except as specifically allowed in the license or 
nondisclosure agreement. No part of this document may be reproduced or 
transmitted in any form or by any means, electronic or mechanical, including 
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photocopying, recording, or information storage and retrieval systems, for any 
purpose other than the purchaser's personal use, without the express written 
permission of ICONICS, Inc.  

 
Software License Agreement 

 

ICONICS LICENSE AGREEMENT 
 

YOU SHOULD CAREFULLY READ THE FOLLOWING TERMS 
AND CONDITIONS! 

 

Opening and using the enclosed software for any purpose indicates your 
acceptance of the terms and conditions of this license agreement.  

If you do not agree with them you should return all software, documentation and 
copy protection keys within seven days of shipment unopened and your money 
will be refunded. 

 

ICONICS provides this program and licenses its use in the United States, Puerto 
Rico, or internationally.  

You assume the responsibility for the selection of the program to achieve your 
intended results, and for the installation, use and results obtained from this 
program. 

 

LICENSE 
 

You are granted a personal license to use this program under the terms stated in 
this Agreement.  

You may:  

1) Install and use the program on a single machine.  

2) Make archival back-up copies of the program for the sole purpose of 
supporting your use of the single program on a single machine.  

3) You may not use, copy, modify, or transfer the program, or transfer any copy, 
in whole or in part, except as expressly provided in this license, or with a written 
contractual agreement with ICONICS, Inc. 
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TERM 
 

The license is effective until terminated. It will terminate if you fail to comply with 
any term or condition of this Agreement. You agree, upon such termination, to 
destroy the program and all copies which were made from it and to promptly 
return any copy protection key(s) to ICONICS. 

 

LIMITED WARRANTY 
 

ICONICS WARRANTS THE CD-ROM OR PHYSICAL DISKETTES, ON WHICH 
THE PROGRAM IS FURNISHED, AND PHYSICAL DOCUMENTATION TO BE 
FREE OF DEFECTS IN MATERIALS AND WORKMANSHIP UNDER NORMAL 
USE FOR A PERIOD OF NINETY(90) DAYS FROM THE DATE OF DELIVERY 
TO YOU AS EVIDENCED BY YOUR RECEIPT. THIS PROGRAM IS PROVIDED 
"AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR 
IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE 
ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE 
PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, 
YOU ASSUME THE ENTIRE COST OF ALL NECESSARY SERVICING, 
REPAIR, OR CORRECTION. 

 

ICONICS SPECIFICALLY DISCLAIMS ALL OTHER WARRANTIES, 
EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO, IMPLIED 
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE. IN PARTICULAR, WITH RESPECT TO ANY PARTICULAR 
APPLICATION, USE OR PURPOSE, IN NO EVENT SHALL ICONICS INC. BE 
LIABLE FOR ANY OTHER COMMERCIAL DAMAGE, INCLUDING BUT NOT 
LIMITED TO SPECIAL, INCIDENTAL, CONSEQUENTIAL OR OTHER 
DAMAGES. ICONICS DOES NOT WARRANT THAT THE FUNCTIONS 
CONTAINED IN THE PROGRAM WILL MEET YOUR REQUIREMENTS OR 
THAT THE OPERATION OF THE PROGRAM WILL BE UNINTERRUPTED OR 
ERROR FREE. 

 

LIMITATION OF REMEDIES 

 
ICONICS’ entire liability and your exclusive remedy shall be the replacement of 
any CD-ROM or diskette not meeting ICONICS’ "Limited Warranty" which is 
returned to ICONICS with a copy of your receipt within the warranty period. The 
remedy for breach of this warranty shall be limited to replacement and shall not 
encompass any other damages including but not limited to loss of profit, special, 
incidental, consequential, or other similar claims arising out of the use or inability 
to use such program even if ICONICS has been advised of the possibility of such 
damages, or for any claim by any other third party. 
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Year 2000 Statement 

The AB OPC Server does not use dates in its functionality, and only uses a date 
one time when installed,  AB OPC Server will not produce errors processing date 
data in connection with the year change from December 31, 1999 to January 1, 
2000 when used with other products (e.g., other software, firmware and 
hardware) that properly exchange date data in compliance with year 2000 
requirements. 

This statement of compliance does not constitute a warranty or extend the terms 
of any existing warranty. Any warranty for ICONICS  products is set forth in the 
License Agreement and Limited Warranty accompanying the particular product. 
All information provided by ICONICS  concerning year 2000 issues is furnished 
on an "as is" basis, is subject to change, and is intended solely for the purpose of 
assisting  ICONICS customers in planning for their transition to the year 2000.  

 
License Move 

Often if is necessary to install and use the server on one computer for 
development and testing purposes, with the finally installation deployed on a 
different computer. License Move allows you to transfer the license from 
computer to computer.  However, only one computer may use the license at a 
time.  See License Agreement  
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Moving the license is a 3 step process 

1. Create a transfer disk on the non-registered server 

2. Move the license from a registered server to the transfer disk 

3. Move the license from the transfer disk to a non-registered server 

 

Creating a Transfer Disk 

Creating a transfer disk identifies the machine that has the non-registered server.  
To create a transfer disk: 

• Insert a blank floppy disk into driver A or B of the machine of the non-
registered server 

• Click  License -> Move License 

In the Create License Transfer Disk area 

• Select the drive letter A: or B: where the floppy disk is inserted 

• Click the Create button… 

A license transfer file IGOPCAB.LTF is created on the floppy disk.  This file can 
be e-mailed if you are transferring a license from a remote location. 

 

Moving the license from a registered server to the transfer disk. 

This moves a server license to the transfer disk.  Only a registered license can 
be moved to a transfer disk. 

• Insert the transfer disk into a floppy drive A: or B: 

• Click   License -> Move License… 

In the Move License area 

• From: Select SYSTEM 

• To: Select A: or B: 

• Click OK 
The license file IGOPCAB.CLF is moved to the transfer disk.  This file can be e-
mailed if you are moving the license to a remove location. 
Only the machine that created the transfer disk can use this license file. 
Once the license has been transferred from the server: 
• The server will operate in demo mode 
• Re-installing the server software, or re-entering the software registration 
codes will not re-activate the license on the server. 
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Moving the license to a non-registered server. 

Transfers the license to the non-registered server that created the Transfer Disk 

• Insert the transfer disk into floppy drive A: or B: 

• Click   License -> Move License… 

From the Move License area 

• From: Select A: or B: 

• To: Select SYSTEM 

• Click OK 

 

 
ControlLogix Optimized Reads 

Unlike the PLC/SLC family of processors that have fixed data tables for registers, 
the ControlLogix 5550 implements user-defined variable declarations similar in 
nature to a high-level language.  With the ControlLogix 5550 processor you can 
declare variables with similar names but different data types. 

Example: 

Var1  as BOOL 
Var2  as REAL 
Var3  as INT 

The AB OPC Server cannot determine in advance the tag data type or where the 
tag is located in ControlLogix 5550 memory, making it difficult for the server to 
optimize read packets.  As a result, server performance may suffer when reading 
a large number of tags from ControlLogix 5550 controller. 

 

To achieve the optimum performance from the AB OPC server, you are 
encouraged to use ControlLogix 5550 array data types.   Array data types occupy 
contiguous blocks of memory within the controller that can be read as a block of 
data by the OPC Server 

 

Array Types  
Supported 

  

SINT VT_UI1 Byte - singlle and multi-dimensional arrays 

INT VT_I2 16-Bit signed integer – single and multi-dimensional arrays  

DINT VT_I4 32-Bit singed integer – single and multi-dimensional arrays 

REAL VT_R4 32Bit IEEE floating point – single and multi-dimensional arrays 

BOOL VT_BOOL Discrete bit array – single and multi-dimensional arrays.  
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