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Introduction to Simulator OPC Server 
The ICONICS OPC Simulator is an OPC-compliant server simulator that serves 
data to OPC clients. The Simulator OPC server was implemented using 
advanced programming concepts of the current version of the OPC 
specification for use in developing next generation industrial software 
applications. 

The OPC Simulator communicates with OPC clients, and internal simulation 
occurs generating different devices. The OPC Simulator is based on several 
simulation signals, such as Sine, Random, Ramp and a square wave signal.  It 
also has dummy output digital bits and registers that allow "writing to." The OPC 
Simulator server/client is an ideal way to learn about the OPC standard, and it 
can be used to test other OPC-compliant clients. 

Key features of the OPC Simulator include: 

• Advanced OPC data quality and data conversion to client’s request. 

• OPC Simulator server utilizes advanced free-threading capabilities. 

• Supports multiple groups for easy configuration and manageability. 

• Internally simulated for configuration and testing. 

• Supports, Sine, Ramp, Random and Square signals in addition to 
static. 

• Read/write functionality. 

• Tag multiplier allows you to create hundreds of tags in seconds.  

• OPC client for rapid testing of your OPC data connections. 

• User interface for viewing tags, groups, and simulated values. 

• Full online help. 

• Change Device, Group and Tag properties online. 

• Flexible engineering units and signal ranges. 
 

The Simulator OPC Server product contains two parts: a user interface 
configuration module and the actual OPC server, the runtime module.  

The configuration module allows you to create a database that holds 
configuration data of the tags. Such as the tag name, the ranging, and the 
alarm settings.  The runtime module uses a runtime database to access the 
actual values of the tags configured. Structures of both databases are indicated 
in the following sections.  

Changes made to the configuration are accepted only after a restart of the OPC 
server. However, changes made to the runtime database are accepted online. 
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What Is OLE for Process Control? 
OLE™ for Process Control (OPC) is a standards-based approach for 
connecting data sources (e.g., PLCs, controllers, I/O devices, databases, etc.) 
with HMI client applications (graphics, trending, alarming, etc.). It enhances the 
interface between client and server applications by providing a universally 
supported and well-documented mechanism to communicate data from a data 
source to any client application. Included are not only a detailed guide on how 
to pass the data, but also specific information on other attributes to supplement 
those data, such as range information, data type, quality flags, and date and 
time information. The figure below shows the OPC Architecture, which was 
introduced by the OPC Foundation. By following the OPC Architecture, a device 
needs only one standard driver, which is an OPC-compliant server. All OPC-
compliant client applications can then be connected to that device, either locally 
or over a network. Furthermore, connections can be made to more than one 
OPC server at the same time. 

 

OPC-Based Client-Server Architecture 

Any OPC client application can connect to any OPC server. In other words, 
OPC offers true Plug-and-Play capability in the fields of HMI and industrial 
automation. OPC server types include OPC Data Access (DA), OPC Alarm and 
Events (AE), and OPC Historical Data Access (HDA). 

 

 

Simulator Configurator 
The OPC Simulator Configurator is used to configure the data items (tags). This 
configuration is stored to the configuration (.sim) database. The OPC Simulator 
runtime module will read this database on startup. 
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Starting the Simulator Configurator 
To open the OPC Simulator Configurator from the Windows Start menu, select 
Programs > ICONICS GENESIS32 > OPC Simulator.  

The Configurator screen will open, as shown in the figure below. The screen 
consists of a split window with a tree control view in the left-hand pane and a 
configuration view in the right-hand pane. The installation provides a default, 
configured file ("Simulator.sim") that provides a standard format for the 
configuration database. The Configurator also includes a toolbar and menus 
with many command functions. For a description of the toolbar and menu 
functions, please see the sections below. 

The OPC Simulator uses an Explorer style user interface to display a hierarchical 
tree of devices and groups and their associated tags. Tags represent registers 
and coils within a device. Groups are like subdirectories that logically group tags. 
A device may have subgroups that all have tags within them, but all of the tags 
really belong to their device when they are scanned to perform I/O. 

Devices and groups are displayed in the left hand pane in a tree control. Tags 
are displayed in the right hand pane. Right clicking on any object brings up a 
menu appropriate for the context. Tags can be cut, copied, deleted, or edited. 
Tags that are cut or copied can be pasted into the selected device or group. Tags 
can also be dragged to a device or group. Following the drag and drop standard, 
drag means move, while drag with the CTRL key depressed means copy. 
Multiple tags can be selected for these operations. If tags are dragged or pasted 
and there is a name conflict, a dialog prompts you to rename, overwrite, skip, or 
cancel.  

 

 

OPC Simulator Configurator 
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Toolbar 
The OPC Simulator Configurator toolbar, shown below, contains the following 
command buttons: 

• New Device: Creates a new device in the tree control. 

• New Group: Creates a new subfolder in the tree control. 

• New Tag: Creates a new tag. 

• Cut: Deletes the current selection, sending it to the clipboard. 

• Copy: Copies the current selection to the clipboard. 

• Paste: Pastes the current contents of the clipboard. 
For more information on menu functions, please refer to the Menus section 
below. 

 

OPC Simulator Toolbar 

Menus 
The menu bar of the Configurator contains the following menus: 

• File  

• Add 

• Edit  

• View  

• Help  

Note: You can also access many of the menu commands by right-clicking items 
in the tree control of the Configurator and selecting command functions from 
the pop-up menus. 

File Menu 
The File menu commands are listed in the table below. 

File Menu Commands 

Command Shortcut 
Keys 

Function 

New CTRL+N Creates a new configuration 
database. 

Open CTRL+O Opens an existing database (.sim) 
file. 

Save  Saves the current database. 
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Save As  Saves the current database under 
a different name as a .sim file. 

Import CSV  Imports data into your configuration 
database from a Microsoft Excel 
file (.csv).  

Reimport 
CSV 

 Reimports data into your 
configuration database from the 
previously imported Microsoft Excel 
file (.csv). 

Export CSV  Exports configuration data from 
your database to a Microsoft Excel 
file (.csv).  

Re-export 
CSV 

 Re-exports data from your 
database to the previously 
exported Microsoft Excel file (.csv). 

Exit  Closes the application. The current 
configuration database is 
automatically saved. 

 

Add Menu 
The Add menu commands are listed in the table below. 

Add Menu Commands  

Command Shortcut 
Keys 

Function 

New Device CTRL+D Creates a new device in the tree 
control. 

New Group CTRL+G Creates a new subfolder in the tree 
control. 

New Tag CTRL+T Creates a new tag. 

Multiply CTRL+M Opens the Multiply Tag dialog box, 
which allows you to duplicate the 
selected tag in the tree control.  

 

Multiplying Tags 
The Configurator allows you to multiply tags in the tree control. Multiplication 
provides a simple way of developing configurations where there are many 
similar items in a given category. To multiply a selected tag, choose Multiply 
from the Add menu.  
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Tag Multiplier 

This opens the Multiply Tag dialog box, as shown in the figure below. The Tag 
Multiplier provides an easy and fast method for creating many tags without 
having to individually enter all of them.  The dialog contains the following items: 

• Base Name: This is the prefix part of the tag name that will stay the 
same in all tags (defaults to the name of the original tag selected). 

• Duplicate: This simply generates the tag according to the following 
criteria selected from the drop-down list: Amplitude, Phase, or None. 

• Duplicator Factor: This represents the increment index for duplicating  
the tags. 

• First Number: This is the number to be appended to the first generated 
tag. Other tags will have consecutive numbers starting from this 
number up  
(defaults to 1). 

• Numeric Places: This is the number of digits that will be appended to 
base name (defaults 3). 

• Number of Tags: This is how many tags will be generated (defaults to 
100). 

The function generates copies of the originally selected tag, substituting new tag 
names and amplitude or phase. All other tag properties remain the same. For 
example, when following values are entered, notice the 4 numeric places after 
the base name: 

Base Name:  Sine 

First Number:  100 

Numeric Places:  4 

Duplicate Factor:  30 

Number of Tags:  300 

The following 300 tags will be generated when duplicating according  
to Phases: 

Sine0100 with Phase 30 

Sine0101 with Phase 60 

Sine0102 with Phase 90 

Etc..... up to  

Sine0399 with Phase 360 
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Edit Menu 
The Edit menu commands are listed in the table below. 

Edit Menu Commands  

Command Shortcut 
Keys 

Function 

Cut CTRL+X Cuts the selected object from the 
view and places it on the clipboard. 

Copy CTRL+C Copies the selected object to the 
clipboard. 

Paste CTRL+V Pastes the last object placed on the 
clipboard. 

Delete DEL Deletes the selected object. 

Properties CTRL+P Opens the Properties dialog box for 
the selected item. 

 

View Menu 
The View menu commands are listed in the table below. 

View Menu Commands 

Command Function 

Monitor  Monitors runtime values of tags. 

Status Bar Toggles the status bar at the bottom of the 
Configurator window. 

 

Help Menu 
The Help menu commands are listed in the table below. 

Help Menu Commands 

Command Function 

About 
Application 

Launches the About Box, which contains 
information about the product version number 
and copyright.  

Help Contents Launches the online Help for the Configurator.  
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Creating a New OPC Simulator Configuration 
To launch the ICONICS Simulator OPC Server from the Windows Start menu, 
select Programs > ICONICS GENESIS-32 > OPC Simulator.  

This will open the configuration screen for the OPC Simulator, as shown in the 
figure below.  Note that there are definitions already created for this server.  
Various portions of the GEN32Demo use these tags.  As such, you should 
leave these configurations intact so the various examples used in the 
GEN32Demo will function properly. 

 

OPC Simulator Configurator 

Creating a New Device 
The names in the left pane of the OPC Simulator Configurator (e.g. Disk IO, 
Global Variables, Recipe Storage, Simulate PLC), shown in the figure below, 
represent simulated "devices."  In the real world, "devices" could mean 
"Programmable Logic Controllers (PLCs)," "I/O Boards," or "Sensor Networks," 
etc.  A device may have any name, but avoid names with spaces or punctuation 
such as "|!.,". 
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OPC Simulator Configurator 

To create your own simulated device to hook up to the simulated network of 
I/O: 

1. From the Add menu, select New Device, as shown in the figure below. 

  

Creating a New Device 

2. In the Device Properties dialog, type a name for the device (e.g. 
"PLCSim") and then click OK, as shown in the figure below. The new 
device will appear in the tree control of the Configurator. 

 

Device Properties 
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Creating Groups 
A device can contain any number and level of groups, just like subdirectories. A 
group only has a name, which must be unique among its parent’s groups (just 
like subdirectories).  

With ICONICS OPC Servers, you can organize your I/O tags into convenient 
folders, making them easy to work with, connect to, view, and manage, etc.  
The example below shows how to create two groups: 

1. Right-click a device and select New Group from the pop-up menu, as 
shown in the figure below. 

 

Creating a New Group 

2. This opens the Group dialog box. Name the group (e.g. “Temperatures"), 
as shown in the figure below. Click OK. The new group will appear under 
the device. 

 

Naming the New Group 

With this OPC server, you can actually create groups within groups.  This 
hierarchical organization of groups makes it even easier to organize your I/O.  
Simply select the group/folder you wish to create another group in, and select 
New Group from the Add menu.  

In the example below, another group is added at the "root" level of the device: 

1. Right-click the device and select New Group from the pop-up menu. (Note: 
If you do not first click on the device, the new group is added as a sub-
folder to the "Temperatures" group.) 
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2. In the Group dialog box, give this second group a name (e.g. "Levels").  
Click OK. Your screen should look similar to the one shown in the figure 
below. 

 

Selecting the Device for the Second Group 

Creating Tags 
The OPC Simulator allows you to create “dummy” tags, which can be used in a 
variety of ways, including: 

• Testing your system  

• Global variable storage (accessible from any OPC client on the 
network) 

• Recipe storage 

• Operator manual-entry data storage 
Several example tags are created below:  

1. Right-click the Levels group and select New Tag from the pop-up menu, as 
shown in the figure below. 

 

Adding a New Tag to the "Levels" Group 
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2. This opens the Tag Properties dialog box, as shown in the figure below. A 
tag has a name, which must be unique within its group, a description, an 
amplitude, a phase and data type. Bits are always boolean. For example: 

• Name: Tank 1 

• Description: Water Level 

• Simulation Signal:  Sine 

• Data Type:  FLOAT 
 

 

Tag Properties 

The defined tags use a variety of data types and simulation signals. Only 
read and write registers are simulated. (Write registers are not modified by 
the server’s simulation mode.) A register’s data type can be 2 Bytes (Word), 
4 Bytes (Dword), or a 4 Byte floating point number. Other data types are 
INT, BIT, LONG and Strings. 

For simulation signal types to check the connectivity of clients to the OPC 
Simulator, you can select Ramp, Random, Sine or a Square wave signal. 
These simulation types determine how the tag value will be generated and 
how frequently it will change. 

 

Data Type Sine Random Ramp 
Boolean Toggles every 6 

seconds 
Random on/off Toggles every 6 

seconds 
Short 0 to 100, period 

is 2 min 
Random from 0 
to 100 

Increments at  
scan rate 

Long -1 to 1, period is 
2 min 

Random from 0 
to 100 

Increments of 
scan rate and 
amplitude 
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Note on naming: The OPC item name, or itemID, is made up of 
"device.group.tag" where the server uses periods as delimiters. Some clients 
may use other delimiters between server name, access path, and itemID. 
This is similar to the case of Excel’s DDE syntax "application|topic!item". To 
avoid possible naming conflicts in clients, the access path and itemID should 
be free of spaces and punctuation. 

3. The OPC specification also provides for passing OPC clients the scaling 
used for each OPC tag.  This aids in setting up ranges for animated 
graphics, trend logging scaling, etc.  You will now add scaling to this tag. 
Under the Scaling section, check the Enable check box, and then click on 
the Settings button.   

4. The Tag Process Settings dialog box appears, as shown in the figure 
below. The sine wave signal you have configured will go from -1 to 1.  Fill in 
the fields, as shown in the figure below, so this scales to 0 to 100 meters. 
Click OK.   
 
Tags can be scaled in the server, to convert to Engineering Units, for 
example. Scaled tags will be converted to double precision floating point 
numbers when they are scaled. 
 

 

OPC Tag Scaling 

5. The Tag Properties dialog box now appears as shown in the figure below. 
Click OK to save this tag. 
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Defining the Tag Properties 

Next, you will add a several tags to the Temperatures group/folder, using a 
special feature of our OPC servers.   

1. Right-click the Temperatures group and select New Tag from the pop-up 
menu, as shown in the figure below. 

 

Adding a New Tag to the "Temperatures" Group 

2. This opens the Tag Properties dialog box, as shown in the figure below. 
Change the following parameters: 

• Name: T 

• Enable Scaling: 0 to 100 scales to 32 to 212 Deg. 
Your tag should appear, as shown in the figure below. This is simply a 
“base tag," i.e., one that you will “multiply” to produce several tags. Click 
OK. 
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Base Tag 

3. Next, you will take this base tag and multiply it to create a series of OPC 
tags.  To do this, first select the tag T by clicking on it in the right-hand 
window frame, then choose Multiply from the Add menu, as shown in the 
figure below. 

 

Multiplying a Base Tag 

4. Set the Number of tags to 9, as shown in the figure below. Click OK.   

 

Multiply Tag Dialog Box 
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5. This creates 9 tags, named "T001," "T002," "T003," and so on.  You can 
delete the first base tag, "T," if you wish, by right-clicking on it and selecting 
Delete from the pop-up menu. 

6. The final step is to select Save from the File menu to save your changes.  

There are other features in the Simulator OPC Server, such as Monitor Mode 
(for viewing the OPC values without requiring a separate OPC client), importing 
and exporting tags to CSV files, etc.  

 

Sample OPC Client 
The Sample OPC Client is used as a test case to debug servers and 
demonstrate some of the OPC capabilities. Start the OPC client, as shown in 
the figure below. 

 

Sample OPC Client Screen 

From the OPC menu, select Connect. The Select OPC Server dialog box 
appears showing all registered OPC servers, as shown below. Select 
Simulator OPC Server and then click OK. This connects the OPC client to the 
Simulator OPC Server. 

 

Select OPC Server Dialog Box 
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From the OPC menu, choose Server Status to view the OPC server status 
dialog box, shown in the figure below. The server status dialog box 
continuously updates the server start time, the time of last update, the current 
time, the number of groups, and the bandwidth for the selected server. Use this 
window to verify that the server is running and is connected to the OPC client. 
Click OK to close the server status dialog box. 

 

Server Status Dialog Box 

From the OPC menu, choose Add Item. The Add Item dialog box appears, as 
shown in the figure below. The Add Item dialog box displays the devices, data 
blocks, and data tags defined in the current server configuration. These are 
filtered by expression “*” and by data type. You can enter an access path, type, 
or select an item name, and choose the data type in which you want to view the 
requested tag. In the Browse Items list, select the device, group, and tag. The 
full name appears in the Item Name field. Click OK. The item appears as a Tag 
in the OPC Client window with updating data values. You can add more tags by 
repeating the steps described above. 
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Add Item Dialog Box  

From the OPC menu, choose Group Parameters. This command displays the 
parameters of the group of tags.  

  

Group Parameters for the Selected Server 

The Update Rate determines how fast data are sent to the client (in 
milliseconds). The Active state (checked) initiates active communications 
between the client and the server. You can change the Active state or the 
Update Rate, for example, and click Apply to send changes to the server. If the 
group is not active, data are not sent to the client. You can choose to 
Disconnect from the OPC menu to restore all selections and to disconnect 
from the server. 

While a client is connected to a server, you cannot exit the server or open new 
configurations in the server. You can modify the existing server configuration 
while client(s) are connected; however, you cannot delete any device or tag in 
use. For example, you can take a device offline or change a tag’s scaling 
values without shutting down a client that may be controlling many devices. 
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Start another instance of the OPC client and make the same server connection 
as those defined in the first client instance. You can add items, change the 
group update rate and active states, and view the server status in each 
instance of the OPC clients independently of the other instances. For example, 
the number of groups is "1" in each client because each one only has one 
group.  

The only way that one client affects another is through data and data changes. 
Make sure both clients are showing the same tag.  

To write a value to an item or tag, highlight a tag in the client and choose Write 
Value to Item from the OPC menu. This allows you to write a value for the data 
item, as shown in the figure below. Enter a numeric value and click OK. The 
client displays the new value at the update rate defined above. The client writes 
the value typed in the Write Item Value dialog box to the correct item in the 
Group object. The method of writing data is determined by the Asynchronous 
check box. When data are written synchronously, the call to the server blocks 
until the operation has completed, which may take a long time. When data are 
written asynchronously, the call to the server returns quickly and the operation 
is carried out on another thread. When the write has finished, the client’s advise 
interface is notified with the results. 

Note: A client defined with a very slow update rate does not receive the value 
immediately. 

 

Writing a Value to a Data Item 

 

How the Client Connects to and Gets Data From a Server 
When OPC servers are installed on the system, they are registered so that 
clients can find them and users can view them in a list. To make a client/server 
connection, the user must first choose a server. The server name selected is 
used to get a class ID which, in turn, is used to create a COM object. If the user 
selects a server that is not currently running, the system starts the server and 
then creates the object in that server on behalf of the client. 

Once the COM object is created, the client application has an IOPCServer 
interface, as defined in the OPC specification. This is the main interface to an 
OPC server, and this document refers to this as the Server interface. (The other 
interface is Group.) An OPC client always creates a group in the server and 
registers an advise interface with it to get asynchronous data notification. 

When an item is added, the dialog displays either a hierarchy or a flat list of 
names, depending on the server. The names are queried from the Server 
object using the filter string and requested data type. When the user either 
types or selects a name, an item by that name is added to the Group object. 
This item is also read immediately to get an initial value. 
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Items in a group are scanned by the server; when their values change, the 
advise interface in the client is notified. A data structure containing the data for 
each item whose value or quality has changed (and only those items) is passed 
to the client’s advise interface. The client unpacks and uses the data. 

Server Status and Group Parameters 
The Server status dialog periodically queries the Server object for status and 
displays the results. The Group Parameters dialog box queries the group state 
and displays the results. The OK button and Apply button in the Group 
Parameters dialog box write the parameters from the dialog to the Group 
object and read the parameters back. This primarily controls the scanning and 
updating of data. When a group is inactive, it does not send data notifications to 
the client and, typically there is no reason to scan the items when the group is 
inactive. The Update Rate in the Group Parameters dialog box specifies the 
rate at which data notifications should be sent back to the client, assuming that 
data have changed. This is also the rate at which items are scanned on behalf 
of this client. 

Disconnecting the Client from the Server 
You can disconnect from the selected server by choosing Disconnect from the 
OPC menu. The Disconnect command unregisters the advise interface, 
releases the Group object, and then releases the Server object. Releasing an 
object means that the client is no longer interested in the object, so the system 
can delete the object in the server. 

Monitor Mode 
When tags are configured, their data can be viewed in Monitor mode. Choose 
Monitor from the View menu to toggle this mode. In monitor mode, the tag 
values are displayed in the tag view, updating periodically. The data are 
displayed in the appropriate format for the data type. Boolean data are either "on" 
or "off." Integer and floating point numbers are displayed in their native format. 
Scaled tags are displayed in floating point with the Engineering Units field. When 
in monitor mode, just the tags in view are scanned for data. Selecting a different 
device or group will remove any previous tags and add the tags now in view to 
the scan list. Monitoring is completely independent of OPC items that are 
scanned for data. Monitoring is also independent of a device’s simulator mode. 
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