
 

  
Your comments and suggestions on the operation of this software are 
welcome. Please address them to:  

 

ICONICS  

100 Foxborough Blvd.  

Foxborough, MA 02035  

Tel: 508-543-8600  

Fax: 508-543-1503  

E-Mail: support@iconics.com 

Web: www.iconics.com 
 

© ICONICS, Inc. All rights reserved. 

 

Contents 
Introduction  
Simulator OPC Server  
Simulator OPC Client  

 

 

 1

mailto:support@iconics.com
http://www.iconics.com/


Introduction 
The ICONICS Simulator OPC Server is an OPC compliant Server able to 
internally generate simulation signals that are constantly changing and serve 
data to OPC clients. The Simulator OPC Server was implemented using 
advanced programming concepts of the most current version of the OPC 
specification (Version 2.0) for use in developing next generation industrial 
software applications.  

The ICONICS Simulator OPC Server communicates with OPC clients and 
internal simulation occurs generating different devices. The Simulator OPC 
Server is based on several simulation signals such as Sine, Random, Ramp and 
a square wave signal.  It also has dummy output digital Bits and registers that 
allow "writing to." The Simulator OPC Server/Client is an ideal way to learn about 
the new emerging OPC standard and can also be used to test other OPC 
compliant Clients. 

 

Simulator OPC Server  features  
OPC Client application  
System Requirements  
Installing the Simulator OPC Server  

 

Simulator OPC Server  features 
 

The OPC Server is extremely flexible, and can be utilized and used with DCOM 
for intranet and internet applications. 

Key features of the Simulator OPC Server . 

• Advanced OPC data Quality and data conversion to client’s request 
• OPC Simulator server utilizes advanced free-threading capabilities. 
• Supports Multiple Groups for easy configuration and manageability 
• Internally Simulated for configuration and testing 
• Supports, Sine, Ramp, Random and Square signals in addition to static 
• Read/Write functionality 
• Tag Multiplier let you create hundreds of tags in seconds 
• OPC Client for rapid testing of your OPC data connections 
• GUI interface for viewing tags, groups, and simulated values 
• Full online help 
• Change Device, Group and Tag properties online 
• Flexible engineering units and signal ranges 
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OPC Client application 
 

An OPC test Client application, provided with the Simulator OPC Server, which 
has a rapid method for testing your Server’s configuration.  The OPC Client is 
able to browse the registry of PC and display the complete list of installed OPC 
Servers. Also provide real live data feedback and OPC Server browsing 
capabilities. 

OPC test Client is also helpful for verifying results and testing other 3rd party 
OPC servers. 

 

Simulator OPC Server 
Start the Simulator OPC Server from the program group and load the 
Sample.sim configuration file (located in the root installation directory). The 
Simulator OPC Server configuration appears with the tags defined for this 
sample file, as  
shown below. 

 

Sample.sim loaded in Simulator OPC Server  
 

Note: As explained in the installation section of this manual, Windows NT 4.0 
or Windows 95 with the DCOM is required to run the Simulator OPC Server . 

This sample configuration has one devices with defined subgroups and tags. The 
defined tags use a variety of data types and Simulator signals. Only Read and 
Write Registers are simulated. (Write Registers are not modified by the server’s 
simulation mode.) You can move the Splitters left or right, to better view the 
information shown in the two panes. 
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The Simulator OPC Server  uses an Explorer style user interface to display a 
hierarchical tree of devices and groups and their associated tags. Tags represent 
registers and coils within a device. Groups are like subdirectories that logically 
group tags. A device may have subgroups that all have tags within them, but all of 
the tags really belong to their device when they are scanned to perform I/O. 

To Create a Device, choose New Device from the Add menu. A Device may have 
any name, but avoid names with spaces or punctuation such as "|!.,".  
 

 
Device properties 

 

A device can contain any number and level of groups, just like subdirectories. To 
add a group, select the parent device or group, and choose New Group from the 
Add menu, or right click on the parent and choose New Group. A group only has a 
name, which must be unique among its parent’s groups (just like subdirectories).  

To add a tag, select the device or group on the left pane, and choose New Tag 
from the Add menu, or right click on the parent and choose New Tag. A tag has a 
name, which must be unique within its group, a description, an amplitude, a phase 
and data type. Bits are always boolean.  

A register’s data type can be 2 Bytes (Word), 4 Bytes (Dword), or a 4 Byte floating 
point number. Other data type are INT, BIT, LONG and Strings. 
 

 

Setting a data type 
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Tags can be scaled in the server, to convert to Engineering Units, for example. 
Selecting Enable Scaling and setting the scaling parameters accomplishes this. 
Scaled tags will be converted to double precision floating point numbers when  
they are scaled.  

 

Setting Ranges 

For Simulation Signal Types to check the connectivity of clients to the Simulator 
OPC Server, you can select Ramp, Random, Sine or a Square Wave signal. 
These simulation types determine how the tag value will be generated and how 
frequently it will change. 

 

Sine Random Ramp 

Toggles every 6 
seconds 

Random on/off Toggles every 6 
seconds 
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0 to 100, period is 2 
min 

Random from 0 to 
100 

Increments at  
scan rate 

-1 to 1, period is 2 
min 

Random from 0 to 
100 

Increments of scan 
rate and amplitude 

 

Note on naming: The OPC item name, or ItemID, is made up of 
"device.group.tag" where the server uses periods as delimiters. There are some 
clients that may use other delimiters between server name, access path, and 
itemID. This is similar to the case of Excel’s DDE syntax "application|topic!item". 
To avoid possible naming conflicts in clients, the access path and itemID should 
be free of spaces and punctuation. 

 

Tag Multiplier 
 

If you select a tag in the Tag view pane and then select Add/Multiply,a the 
following dialog is displayed: 
 

 

Tag Multiplier 

The Tag Multiplier provides an easy and fast method for creating many tags 
without having to individually enter all of them.  Within the Edit menu there is a 
Tag Multiplier which first chooses the tag that is to be multiplied, then does Tag 
Multiply. In the dialog, there are following items: 

Base name: This is the prefix part of the tag name that will stay the same in all 
tags (defaults to the name of the original tag selected) 

Duplicate: This simply generates the Tag according to criteria 

Amplitude, Phase, None – options that are available in the drop-down  
list box. 

Duplicator Factor: This represents the increment index for duplicating  
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the Tags 

First number: is the number to be appended to the first generated tag. Other 
tags will have consecutive numbers starting from this number up  
(defaults to 1) 

Numeric places: is the number of digits that will be appended to base name 
(defaults 3) 

Number of tags: is how many tags will be generated (defaults to 100). 

The function generates copies of the originally selected tag, substituting new tag 
names and amplitude or phase. All other tag properties remain the same. For 
example, when following values are entered, notice the 4 numeric places after 
the base name: 

Base name:  Sine 

First number:  100 

Numeric places:  4 

Duplicate Factor:  30 

Number of tags:  300 

The following 300 tags will be generated when duplicating according  
to Phases: 

Sine0100 with Phase 30 

Sine0101 with Phase 60 

Sine0102 with Phase 90 

Etc..... up to  

Sine0399 with Phase 360 
 

Devices and groups are displayed in the left hand pane in a tree. Tags are 
displayed in the right hand pane. Right clicking on any object brings up a menu 
appropriate for the context. Tags can be cut, copied, deleted, or edited. Tags that 
are cut or copied can be pasted into the selected device or group. Tags can also 
be dragged to a device or group. Following the drag and drop standard, drag 
means move, while drag with the control key depressed means copy. Multiple 
tags can be selected for these operations. If tags are dragged or pasted and 
there is a name conflict, a dialog prompts the user to rename, overwrite, skip, or 
cancel.  

When tags are configured, their data can be viewed in Monitor mode. Choose 
Monitor from the View menu to toggle this mode. In monitor mode, the tag values 
are displayed in the tag view, updating periodically. The data is displayed the 
appropriate format for its data type. Boolean data is either "on" or "off". Integer 
and floating point numbers are displayed in their native format. Scaled tags are 
displayed in floating point with the Engineering Units field. When in monitor 
mode, just the tags in view are scanned for data. Selecting a different device or 
group will remove any previous tags and add the tags now in view to the scan 
list. Monitoring is completely independent of OPC items that are scanned for 
data. Monitoring is also independent of a device’s Simulator mode. 
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Simulator OPC Client 
OPC Client 

The OPC Client is used as a TEST case to debug an OPC Compliant Server and 
access various some of the OPC variables and parameter configuration. 

• Start the OPC Client.  
• From the OPC menu, Choose Connect. The OPC Server menu appears 
showing all registered OPC servers.  
• Select ICONICS.Sample and click OK. This connects the OPC Client to 
the sample server.  
• From the OPC menu, choose Server Status to view the Simulator Server 
status window. Refer to the following figure. 
 

 

Server status window for the Simulator OPC Server 

The Server status window continuously updates the server start time, time of last 
update, and current time, the number of groups, and the bandwidth for the 
selected server. Use this window to verify that the server is running and is 
connected to the OPC Client. 

• Click OK to close the Server status window. 
• From the OPC menu, choose Add Item. The Add Item dialog box 
appears, as shown below. 
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Add Item dialog box listing devices defined in connected server 

The Add Item dialog box displays the devices, groups, and tags defined in the 
current server configuration. These are filtered by expression "*" and by data 
type. You can enter an access path, type or select an item name, and choose the 
data type in which you want to view the requested tag.  

In the Browse Items list, select the device, group, and tag. The full name appears 
in the Item Name field. For example, "Simulate.Float.Ramp" or 
"Simulate1.Bits.Out1." 

• Click OK. The item appears in the OPC Client window with updating data 
values.  

Add more tags repeating previous steps. An example of the OPC Client 
displaying three sample server items is shown in the following figure. 

 

OPC Client shown with three items 

 

• From the OPC menu, choose Group Parameters. This command 
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displays the parameters of the group of tags.  

 

 

Group Parameters dialog box for the selected sample server 
 

• The Update Rate determines how fast data is sent to the client, in 
milliseconds (mSec). The Simulator server’s minimum Update Rate is 10 mSec. 
The Active state initiates active communications between the client and the 
server. You can change the Active state or the Update Rate, for example, and 
click Apply to send changes to the server.  
• If the group is not active data is not sent to the client. You can choose 
Disconnect from the OPC menu to clean up all selections and disconnect from 
the server. 
• While a client is connected to a server, you cannot exit the server or 
open new configurations in the server. You can modify the existing server 
configuration while client(s) are connected; however, you cannot delete any 
device or tag in use. For example, you can take a device off-line or change a 
tag’s scaling values, without shutting down a client that may be controlling many 
devices. 
• Start another instance of the OPC Client and make the same server 
connection as those defined in the first Client instance.  
• You can add items, change the group update rate and active states, and 
view the server status in each instance of the OPC Client independently of the 
other instance. For example, the number of groups is "1" in each client because 
each one only has one group.  
• The only way that one client affects the other is through data and data 
changes. Make sure both clients are showing Simulate1.Out1. The data does not 
change while monitoring because it is an output.  
• In one of the clients, select Simulate1.Out1 in the window and choose 
Write Value to Item from the OPC menu. 
• Type a numeric value and click OK. Both clients display the new value at 
their own update rates. (Note that a client defined with a very slow update rate 
does not receive the value immediately.) 
• Edit the Simulator device by clicking on it and choosing Properties from 
the Edit menu or right clicking and choosing Properties. 
• From the View menu, choose Monitor to scan the Simulator and display  
tag values.  
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How the client connects and gets data from an OPC server 
 

When OPC servers are installed on the system, they are registered so that 
clients can find them and users can view them in a list. To make a client/server 
connection, the user must first choose a server. The server name selected (for 
example, "ICONICS.Simulator") is used to get a class ID which, in turn, is used to 
create a COM object. If the user selects a server that is not currently running, the 
system starts the server and then creates the object in that server on behalf of 
the client. 

Once the COM object is created, the client application has an IOPCServer 
interface, as defined in the OPC specification. This is the main interface to the 
OPC server and this document refers to this as a Server interface. (The other 
interface is Group.) This OPC client always creates a group and registers an 
advise interface with it to get asynchronous data notification. 

When an item is added, the dialog displays either a hierarchy or a flat list of 
names, depending on the server. The names are queried from the Server object 
using the filter string and requested data type. When the user either types or 
selects a name, an item by that name is added to the Group object. This item is 
also read immediately to get an initial value. 

Items in a group are scanned by the server; when their values change, the 
advise interface in the client is notified. A data structure containing the data for 
each item whose value or quality has changed (and only those items) is passed 
to the client’s advise interface. The client unpacks and uses the data. 

Server status and Group parameters 

The Server status dialog periodically queries the Server object for status and 
displays the results. The Group Parameters dialog queries the group state and 
displays the results. The OK or Apply buttons in the Group Parameters dialog 
box write the parameters from the dialog to the Group object and read the 
parameters back. This primarily controls the scanning and updating of data. 
When a group is inactive, it does not send data notifications to the client and, 
typically there is no reason to scan the items when the group is inactive. The 
Update Rate in the Group Parameters dialog box specifies the rate at which data 
notifications should be sent back to the client, assuming that data has changed. 
This is also the rate at which items are scanned on behalf of this client. 

To write a value to an item, select the item in the OPC Client windows and 
choose Write Value to Item from the OPC menu, The client writes the value 
typed in the Write Item Value dialog box to the correct item in the Group object. 
The method of writing data is determined by the "Asynchronous" checkbox. 
When data is written synchronously, the call to the server blocks until the 
operation has completed, which may take a long time. When data is written 
asynchronously, the call to the server returns quickly and the operation is carried 
out on another thread. When the write has finished, the client’s advise interface is 
notified with the results. 

The user can disconnect from the selected server by choosing Disconnect from 
the OPC menu, The Disconnect command unregisters the advise interface, 
releases the Group object, and then releases the Server object. Releasing an 
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object means that the client is no longer interested in the object, so the system 
can delete the object in the server. 
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