APPLICATIONS NOTE

Description: Guide to setting up Pocket devices with Pocket
GENESIS.

OS Requirement: Win 2000 Pro/Server, XP Pro, Server 2003.
General Requirement: Pocket PC, Active Sync, Genesis32 and
Pocket Genesis CD, License for Pocket Genesis.

Introduction

Pocket GENESIS is the first and most complete suite of robust
automation tools for Windows Mobile and Pocket PC Personal
Data Assistants (PDA), smart phones or data collection devices.
With Pocket GENESIS applications, you can visualize your
enterprise from an iPaq, Treo, T Mobile Dash or Motorola MC
series with a custom Human Machine Interface (HMI)
connecting to SCADA servers on desktops or servers. Windows
Mobile devices are ideal for mobile operators and maintenance
personnel who need real-time access to and control of the state
of operations.

Pocket GENESIS can connect via the Web, intranet or wireless
to virtually any enterprise automation application you have. It is
fully compliant with the latest OPC specifications for Data
Access, Alarm and Events, and Historical Data Access and will
integrate with any vendor’s system that is compliant to these
open standards.

You create HMI displays for your handheld device on the
desktop, and then synchronize display files to your handheld.
Pocket GENESIS adds the features you need to rapidly create
custom operator interfaces to your data sources. With Pocket
GENESIS’ rapid deployment environment someone with even
rudimentary programming skills can create and manage portable
applications in minutes. Displays allow users to visualize
systems in graphical displays, view complex trending/historian

systems, and perform alarm management on their mobile device.

Pocket GENESIS consists of the applications:

1. Pocket GraphWorX — provides real-time visualization
processes and systems through advanced HMI/SCADA
and graphics capability.

2. Pocket AlarmWorX - provides real-time alarm
visualization and acknowledgment capabilities using
OPC Data Access and Alarm and Events Plug and Play
standards.

3. Pocket TrendWorX — plots real-time and historical
data in numerous trend chart display formats, including
XY plots and new stackable plots.

4. Pocket Recipe Viewer — display any of your recipes or
formulas you use, and allow you to change the recipe or
create new ones from your mobile device.

5. Pocket DataSpy — provides analysis and diagnostics of
OPC real-time data. It tests and monitors OPC data,
alarms, and data quality.
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6. Pocket GenBroker — enables OPC over TCP/IP
between GENESIS32 desktop applications and your
Windows Mobile device, and enables device licensing
compliance.

7. Pocket Store and Forward — automatically connects
to available networks and performs data
synchronization.

8. Security Login — allows you to restrict which users can
perform certain actions.

These Pocket GENESIS applications are based on their
corresponding ICONICS  GENESIS32  applications.
GraphWorX32, AlarmWorX32 and TrendWorX32 are used
on a desktop PC as development tools. After the application
is configured on the desktop PC, the completed files are
downloaded to the target Pocket PC or Windows CE device.

ActiveSync Installation

Pocket GENESIS installs a set of mobile applications into your
synchronization folder. In order to install Pocket GENESIS, you
must first install Microsoft's ActiveSync (4.2 or greater).

To install ActiveSync:

1. Open the ActiveSync folder inside the Tools folder on the
Pocket GENESIS CD and run the ActiveSync
“SETUP.MSI” file. This launches the ActiveSync wizard,
which guides you through installing ActiveSync and setting
up your handheld device.

2. Reboot PC after the Active Sync installation finished.

Desktop installation

The desktop PC acts as the application manager for the
Windows Mobile device. If the Pocket GENESIS installer does
not detect that the GENESIS32 components are already installed
on your desktop, it will add them during the installation.

To install Pocket GENESIS:

1. Connect your Windows Mobile device to your desktop PC.

2. Insert the Pocket GENESIS CD into your CD-ROM drive.
If Autorun doesn’t start, double-click “RUNME.BAT” on
the CD-ROM.

3. When the introductory screen appears, click the
“Installation” link.

4. After the splash screen displays, you will see the Welcome
dialog box. Click “Next” to continue.

5. Accept the terms of the license agreement and click “Next”.

6. Select either a “Complete” (default), a “Custom”, or an
“Other” installation in the dialog box, then click “Next”.

NOTE: Space is at a premium on Pocket PC devices. The installer
indicates the space each component requires and how much space is
available on your handheld.
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However you can still select which Pocket GENESIS components
install to your handheld by making the appropriate selections in
Microsoft ActiveSync. Therefore ICONICS recommends that you
install all programs to your desktop.

7. Choose the right resolution, then click “Next”.

Setup Type
Select the setup type that b

Examples for the following resolutions are available. Pleaze chooze the rezolution.

O 240320
Fig 1: Appropriate resolution of the Pocket device

NOTE: The two choices are 480x640, which is the value most
Windows Mobile 5 and 6 devices have, or 240x320 which was used
by Pocket PC 2003 and 2003SE devices.

8. You will be asked to confirm your selection. Click “Install”
to begin.

9. Click the checkboxes to select or deselect the components
in the list and use the “Change” button to select or deselect
internal components which will also alter the amount of
space required.

10. Select the components you desire, then click “Next”.

11. Each handheld application may have additional components,
such as help files, contained within.

12. The Installer launches and posts a dialog box asking if it
can install applications to the default directory. Click “Yes”
to continue.

13. The ActiveSync installer will then post an alert box
reminding you to check your Windows Mobile device in
order to complete any additional steps in the setup. Click
“OK” to continue.

14. The Pocket GENESIS installer completes the installation
and posts the final Setup Complete dialog box. Click
“Finish”.

15. Attach your handheld to your computer and use ActiveSync
to synchronize Pocket GENESIS programs to your portable
device to complete the installation, or right click on the
ActiveSync icon in the System Tray and select the
Synchronize command.

Network configuration

Since you will be using ICONICS GenBroker communications,
you will need to configure and connect to a network. Employing
a network of applications, GenBroker uses OPC over TCP/IP
channels to achieve real-time and secure communications
between Web browser clients and Web servers. GenBroker also
enables your Pocket PC to access security and licensing
information from remote Security and License Server.

To configure for networking, on your CE device:

1. Select Start > Settings > Connections > Network cards.

2. In the “Network Adapters” tab, select the Ethernet Driver
(e.g. Dell Axim X51 WLAN Wireless Adapter).

3. If your network supports DHCP select “Use server-assigned
IP address” to obtain an IP address via DHCP, otherwise
specify an IP address manually.

4. If you wish to synchronize with a particular computer over
the network, go to the “Name Servers” tab and enter that
computer’s IP address under “DNS Server” and “WINS”.

5. Click “OK” to return to the “Network Configuration”
dialog box.

6. If you wish to add a username and password, go to the
“Identification” tab and enter the corresponding information.

7. Click “OK” to complete the configuration process.

To connect to the network:

1. Physically connect your CE device to the network. See the
CE device’s user manual for more instructions on how to do
this.

2. To test the connection from a desktop PC on the network,
select Start > Programs - Command Prompt.

3. At the command prompt, type “ping [IP]”, where “[IP]” is
the numeric IP address given to the CE device (e.g. “ping
192.168.1.60").

4. If the connection works, you will receive the following
message: “Reply from [IP]” (where “[IP]” is the IP number
given to the CE device). If the connection does not work,
you will receive the following message: “Request Timed
Out”.

NOTE: For more details on how to set up ActiveSync synchronization between
your device and desktop PC over the USB cable or WiFi look at the ActiveSync
documentation or see the application note entitled Pocket GENESIS -
Connecting a Pocket PC to a Desktop PC.

Configuring the Desktop

The desktop is the only part of Pocket GENESIS that has to be
configured for network activation. If the file download tool is
installed properly, it will be listed in the ActiveSync Manager.

To view the list of ActiveSync modules, do the following:

1. Select Start > Programs > Microsoft ActiveSync on the
desktop

2. Tap the Tools > Options button.

3. Tap the “Sync Options” tab of the Windows Options dialog
box in the Microsoft ActiveSync Options dialog box.

4. Enable the “Files” ActiveSync module in the ActiveSync
Manager by tapping the “Files” box, if required. Or you can
follow the Synchronization Setup Wizard where you can
specify the computer name.

5. Try to synchronize by clicking on the “Sync” button.
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Pocket GENESIS Download Configuration

GraphWorX32, TrendWorX32, and AlarmWorX32 have their

own version of the file download tool. To enable Pocket

GENESIS downloads:

1. In the GENESIS32 application select Tools = Windows
CE - Windows CE Preferences as shown below.
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Fig 2: Configuring for Windows CE

2. Click the “Download On Save” check box in the Windows
CE Preference dialog box.

3. Enter the destination directory for the handheld by entering
the path name in the “Download Directory” field. You can
also click the “Browse” button to select the destination
directory. Click on the “Browse” button to open the
“Browse for Folder” dialog box. A warning message box
will be displayed when the file download ActiveSync
module is inactive.

4. To establish a connection with the Windows Mobile device,
click “OK”.

NOTE: Use the Windows CE Preferences dialog box to configure other settings
for Windows Mobile. You can set the resolution of the target device by clicking
the Resolution button. This displays a list of resolutions from 200 x 320 up to
1024 x 768.
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Fig 3: Pocket GENESIS Windows CE Preferences dialog box

5. When you have finished configuring a display file and
would like to save it to Windows Mobile, choose “Save As”
from the “File” menu. This opens the “Save As” dialog box.

a. In GraphWorX32, enter the file name and select
either "GraphWorX32 Displays for WinCE
(*.GDC)" or "GraphWorX32 Templates for
WinCE (*.GDC)" from the “Save as Type” box.

b. In AlarmWorX32, enter the file name and select
"AWXview32 CE File (*.ACE)" from the “Save
as Type” box.

c. In TrendWorX32, enter the file name and select
"TWXviewerCE File (*.TCE)" from the “Save as
Type box”.

6. Click “OK” after you have selected the appropriate file
format. The Import File dialog box will appear, and the files
will be downloaded to your Windows Mobile device.

Starting Pocket applications

Once you have downloaded your GraphWorX32,
AlarmWorX32, or TrendWorX32 configuration files from your
desktop PC to your Windows Mobile device, run the
applications on your handheld. Open the Pocket GENESIS
client applications you wish to run, and then select File >
Open. Browse for the desired .GDC, .ACE, or .TCE file. An
example using Pocket GraphWorX32 is provided in the
following sections.

To open a Pocket GraphWorX32 display on your Windows
Mobile or Pocket PC device:

1. Tap File > Open.

2. Browse a Pocket GraphWorX32 (.gdc) file.
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Fig 4: Open dialog box of Pocket GENESIS.

The display file opens in Pocket GraphWorX with OPC data
displayed.

Condenser Liquid Temperature 140

Chilled Liquid Temperature 065

Fig 5: Pocket GENESIS display with real time OPC data

Copyright 2007 ICONICS, Inc. Page 3 of 3

Pocket GENESIS - Quick Start.doc



