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cases of intent.
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with the program applies.
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Introduction 4

1 Introduction

This manual describes the configuration of an S7-300 PLC with CPU 315-2 DP
as a PROFIBUS-DP Slave to connect to a Hilscher PROFIBUS-DP Master. The
example describes the configuration for two bytes input and two bytes output.

2 Hints and Validity

» This manual describes the S7-300 as a PROFIBUS-DP Slave
e STEP7 Version 5.0 SP 3 under Windows 95 (already installed)

» This manual describes the configuration for a data exchange only. The PLC
programer is responsible for the error handling. This is not part of this manual.
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The PLC S7-300 5

3 The PLC S7-300

3.1 Project

The first step is to create a project. To create a project selct menu File > New.
Enter the name for the project, e.g. DPSlave.

'EEEDPSIa?e -- CASIEMENSASTEP7AS 7projADPSlave

i

MPI[1]

3.2 Stations

This manual describes the configuration for an S7-300 as a PROFIBUS-DP
Slave and a Hilscher PROFIBUS-DP Master.

3.2.1 S7-300 Station 'DummyDPMaster for Config’

Insert a S7-300 station, select the menu Insert > Station > SIMATIC 300
Station and name it DummyDPMaster for Config. This station is only a
‘dummy" station, but necessary inside the STEP7 confguration tool.

3.2.2 S7-300 Station 'DPSlave'

Insert another S7-300 station, select the menu Insert > Station > SIMATIC 300
Station and name it DPSlave. This station is the PROFIBUS-DP Slave.

'E'EDFSIave - CASIEMENSASTEP?AS 7profADPSlave

o o \ \
#-[fl] DPSlave !!-E " || r ||
] DummyDPMaster for Config MPIf1) DummyDPMaster  DPSlave

far Config
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The PLC S7-300 6

3.3 Hardware Configuration S7 300 Station (DummyDPMaster for
Config)

Open the software for hardware configuration of the S7 station. Start with the
'DummyDPMaster for Config'.

27 DPSlave - C:ASIEMENSA\STEP7\S7proj\DPSlave M=

EI--% DFSlave Iﬂqn

#-ff DPSlave
O D iy D P aster for Config

Hardware

Select the icon Hardware. Then select the menu Edit > Open Object or double
click the Hardware icon to start the Hardware Configurator.

Select the menu View > Catalog.

@;HW Config - DummyDPMaster for Conlig
Station  Edit Insert PLC “iew Options Window Help

[fe[5-[® [F| & Cofi| o/l 22 2|

Hardware catalog =]

Ercfile IStandard j

= I EROFIBUS OF

r-[] (SIMATIC 300

m-F] SIMATIC 400

B[] SIMATIC PT Based Control 300/400
-8, SIMATIC PC Station

KN I _>IJ
[0 UR
SIMATIC 57-300, M7-300 and CF modules [central rack)
Fresz F1 to get Help. [

Select now step by step the hardware components of the S7 300 station.
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The PLC S7-300 7

3.3.1 The Rail

@;HW Config - DummyDPMaster for Conlig

Station  Edit Insert PLC “iew Options Window Help

[[e[5-[ (%] S| Bofi| o/l 22 2|

Hardware catalog =]

Ercfile IStandard j

= M PROFBUS OF

E-F SIMATIC 300
w3 C7

m-C0 CP-300

&0 CPU-300
B FM-300

& 1M-300

B0 MP-EXTENSION
-2 P5-300

- -0 5M-300
_,H w-[l SIMATIC 400

—y
ry
)
o

f |

-] SIMATIC PC Baszed Contral 300/400
-8 SIMATIC PC Station
[0 UR

Slat tdadule Order nurmber oM 3] B

1 -

2

3

4

5 o BES T 390-17770-0AA0

£ leweailable in various lengths

! ||

Inzertion pozzible Chg
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The PLC S7-300 8

3.3.2 The Power Supply

@;HW Config - DummyDPMaster for Conlig

Station  Edit Insert PLC “iew Options Window Help

DI|E-® %] 8| Bale| doldal @ 58] M2
T D ummyDPM aster for Config [Configuration) -- DPSlave

Ercfile IStandard j

= M PROFBUS OF
= SIMATIC 300
w0 C7

m-C0 CP-300

&0 CPU-300
B FM-300

& 1M-300

B0 MP-EXTENSION
223 P5-300

© [ PsanT o
] Psa07 2
i PsanTEs
B RACK-300
B2 5M-300

B SIMATIC 400

(@ UR [l SIMATIC PC Based Contral 3004400

Sliak Module ... | Order number M G & B SIMATIC P Station
PS 307 24 BESY 307-1BADD-04A0 -

BES T 307-1BADD-04AD
Load supply voltage 120,230 WVAC: 24 WDC /2 4

Inzertion pozsible Chg
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The PLC S7-300 9

3.3.3 The CPU (DummyDPMaster for Config)

Select for example CPU 315-2DP.

Hardware catalog x|
Profile i Standard __:j

=-_] CPU 52 DF
F& BES7 315-24F00-04E0
S RECES Y 215-24F01-08B0
-[® EES7 315-24F02-04E0
] BES7 315-24F03-04E0
- EES7 315-24F82-04E0
(L] BEST 315-24F83-04E0
CPU 316
L CPLL AR TP

EES? A5-20F01-04B0
48 EB waork memnony; 0.3 ma1 000 instructions; MPL + DFP
connections; for mulb-tier configuration up to 32 modules

L

Lo

Because this CPU type is usable for PROFIBUS-DP the following window
appears.

Properties - PROFIBUS interface DP Master [R0/52.1] ;

General Parameters ;

Address; ;E '; If a subriet is_ zelected,

the next avalable address is suggested.
Highest addrezs:126

Transmizsiaon rate:1.5 khbitds

Subnet;
-- ok netwarked - MHew... 1
aperties.. 1
[elete 1

Ahbrechen Hilfe

Press New.
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Propertiez - Mew subnetPROFIBUS

General ; Metwark Settings |

Mame: |PROFIBUS-DF

57 zubret [D ;DEQE - ;EIEIEI?

Froject path: ;DF‘SIave

Starage location :

of the project: iE:'xSIEMENS'\STEF'?"-.S profiDPS|ave

Athor; i

Date created: 06.01.2000 135613

Last modified: 06.01.2000 135613

LComment; _f:j
Abbrechen | Hite |

Set the Name, e.g. PROFIBUS-DP, then select Network Settings to open the

following window.

Propertiez - Mew subnetPROFIBUS

General  Metwork Settings i

Brofile;

Transmizzion B ate:

Highest FROFIEUS Address: |42 Ckemme

q
1
H ]
=
(w1
=
{I'm]
m

45 45 [71.25] kbit/s A
93,75 khitds
187 5 khit/s J
500 khit/s

hd

Standard
niverzal [DP/FRS]
Jzer-Defined

Options. ..

Bus Parameters. ..

]|

Abbrechen

Hilfe

Select the Transmission Rate, e.g. 1.5 Mbit/s.

Select the Profile, e.g. the profile DP.

Close the window by pressing OK.
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The PLC S7-300 11

Press several times OK to reach the following window.

@EHW Config - [DummyDPMaster for Config [Configuration] -- DPSlave]

E!h Station  Edit [nzet PLC Wiew Optionz ‘Window Help 18| x|
Df2(3-% 9| S| Belel| sl Sf@ 32 el
Hardware catalog ]
1 PS 207 24 . PROFIBUS-DP: DF master system (1] Profile iStandard _vJ
2 CPU 315 J
S ||| B Masta = & PROFIELIS DP I
3 = SIMATIC 300
o {:] C7
5 {:l CP-300
. =3 CPU-300
7 q-20 CPU 212 IFM
3 E|1:| CPU 313
3 - -0 CPU 214
w] =
1] |
- BEST 315-24F03-04B0
L U address | Comment EEST 315-26F82-04R0
; C f H-L FES7 315-24FB3-04R0
& CPU 315-2 DP |RES7 315-2AF01-0ABD m-I] CPU 316
Exal LSS FEETT w0 CPU 362 DP
3 B3 CPU 3182
4 & CPUET4
5 s W= TN LI
E BEST 315-24F01-04B0
7 48 KB work mermaory; 0.3 ma/1000 instructions: MEP
P + DP connections; far multi-tier configuration up to
32 modules
9
10
11 ...vJ
Inzertion possible [Ehg

Save the current settings by selecting the menu Station > Save.
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The PLC S7-300 12

3.4 Hardware Configuration S7 300 Station (DPSlave)

Open the software for hardware configuration of the S7 station. Start with the

'DPSlave'.
127 DPSlave - C:ASIEMENSASTEP7AS 7proj\D PSlave M=
EI--% DPSlave
R} D PS e liﬂﬂ

ﬂ DurnrnyD PR azter for Caonfig Hardware

Select the icon Hardware. Then select the menu Edit > Open Object or double
click the Hardware icon to start the Hardware Configurator.

Select the menu View > Catalog.

@;HW Config - [DPSlave [Configuration] -- DPSlave]

E“] Station Edit Insert PLC “iew Options “Window Help _|5’|ﬂ

D289 (8 & Fele| sinfsal 2|

Hardware catalog =]
Ercfile iStandard _"J
w PROFIEUS DP

- [SIMATIC 200

=-F SIMATIC 400

- SIMATIC PC Based Control 300400
&8 SIMATIC PC Station

| |

[@ UR

SIMATIC 57-300, #7-300 and CF modules [central
rack]

Fresz F1 to get Help. [

Select now step by step the hardware components of the S7 300 station.

Copyright * Hilscher Gesellschaft fur Systemautomation * An:S7TDPS#1E




The PLC S7-300 13

3.4.1 The Rail

@;HW Config - [DPSlave [Configuration] -- DPSlave]

E“] Station Edit Insert PLC “iew Options “Window Help _|5’|ﬂ

D289 (8 & Fele| sinfsal 2|

Hardware catalog =]

Ercfile iStandard _"J

w9 PROFIBLIS DF

- SIMATIC 200

-3 7

B CP-300

-3 CPU-300

-3 FM-300

B IM-300

-2 MPEXTENSION

E-23 P5-300

=3 RACK-300

I = Y

E-27 5M-300

=-Ef SIMATIC 400

-l SIMATIC PC Based Contral 3007400
-8, SIMATIC PC Station I

jury
pury

FY

0] UR

Ik Module Order nurmber MPI address | address [ adc

BESY 390-1770-0440
I8wvailable in warious lengths

e A=l DRy N SN EER NG )

Fresz F1 to get Help. [Ehg
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The PLC S7-300 14

3.4.2 The Power Supply

@;HW Config - [DPSlave [Configuration] -- DPSlave]

E“] Station Edit Insert PLC “iew Options “Window Help _|5’|ﬂ

[[e[5-[ (%] S| Bsfe| o/l 2 |

Hardware catalog =]
Ercfile iStandard _"J

= 5% PROFIBUS DP
=-El SIMATIC 300

F-C3 MFEXTENSION
E-23 P5-300
[ P5 307 106
PS5 307 24
[q Ps 3075
¥1-(21] RACK-300
B-C3 5M-300
EEE SIMATIC 400

.

. | = SIMATIC PC Based Control 300/400 J
B8, SIMATIC PC Station g
[ UR
Slat Module Order nurmber MPI address | addrezs | O adc
1 PS 307 24 BESY 307-1BADD-0AAD
2 BESY 307-1BAND-0AAD
3 Load supply voltage 1204230 WALC: 24 VDT /2 A
Fl
5
] [
7 [ ..'J
Fresz F1 to get Help. [Ehg
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3.4.3 The CPU (DPSlave)

Select for example CPU 315-2DP.

Hardware catalog x|

Frofile I Standard j

¥ FROFELS DF
=@ SIMATIC 300
&0 7
-] CP-300
=3 CPU-300
&0 CPU 312 IFM
&3 CPU 313
23 CPU 314
(I CPU 314 IFM
{23 CPU 315 —
=] CPU 3152 DF

- [B] BES7 315-24F00-04B0
BESY 315-24F01-0ABD
- [B BEST 315-24F02-04B0
-] EES7 315-24F03-04B0
- [H] BEST 315-24F52-04B0
-] BES7 315-24F83-04B0
-5 CPLLA1R LI

BESY 315-24F01-0AB0
48 LB work memon; 0.3 mad1 000 instructions; kP
+ DP connections; for multi-tier configuration up to

32 modules

Copyright * Hilscher Gesellschaft fur Systemautomation * An:S7TDPS#1E



The PLC S7-300 16

Because this CPU type is usable for PROFIBUS-DP the following window
appears.

Properties - PROFIBUS interface DP Master [R0/52.1] ;

General Parameters 1

Address: 13 "; If a zubnet iz zelected,

the next available address iz suggested.
Highest addresz:126

Transmizsian rate:1.5 khbitds

Subnet:
--- niot networked - Mew... 1
PROFIELIS-DP
Properties. .. i
Delete 1

Abbrechen Hilfe

Set the Station Address, e.g. 3. Select the Subnet PROFIBUS-DP that was
created before.

Copyright * Hilscher Gesellschaft fur Systemautomation * An:S7TDPS#1E




The PLC S7-300 17

Press several times OK to reach the following window.

E’;HW Config - [DPSlave [Configuration] -- DPSlave]

ﬁ“| Station  Edit [nzet PLC Wiew Optionz ‘Window Help 18| x|

Df(8-® || S| o[ ]l 22| x?|

FROFIBUS-DP: DF master gystem [1]
J Frafile IStandard ﬂ
M CRORIBUS DP =]
- SIMATIC 200
=3 7
&3 CP-300
=23 CPU-300
E-20 CPU 312 IFM
o]
({3 CPU 3152 DP
i..[@ BES7 315-24F00-04B0
BES7 315-24F01-0480
BES7 315-24F02-0480
-2 BEST 315-24F03-0480 _I;I
<] | BES7 315-2AF52-0AR0 5
-] BEST 315-24FE304E0 ——
0 UR -7 TP 316 jd
BES7 315-24F01-04E0 _ _
Slot IModule Order number MFI address | addresz | € iBDEEcb;sLiggrq2'rﬁ.f';0rDﬁu??ii’i!rnggr':ﬁsﬂ?acti“;nnz; h':fl
T |[] Psa072h EES7 307-1BA00-08A0 0 ? S
2 CPU 315-2 DP 6ES7 315-2AF01-0ABD |2
A 2P A FiT
3
1
5
3 hd
Press F1 ta get Help. [ [Ehg

Then select X2 DP Master and then select the menu Edit > Open Object or
double click the icon X2 DP Master to open the following window.
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The PLC S7-300 18

Properties - DP Master - [R0/552.1]

Set the Name to DP Slave.
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The PLC S7-300 19

Select Operating Mode to open the following window.

Properties - DP Master - [R0/552.1]

Set the operating mode to DP Slave.

Copyright * Hilscher Gesellschaft fir Systemautomation * An:S7TDPS#1E




The PLC S7-300 20

Select Configuration.
Set as Module 1: Input 2 bytes (unit).
Set as Module 2: Output 2 bytes (unit).

Properties - DP Slave - [R0O/52.1] |

Generall .ﬁ.ddressesl Operating Mode Configuration I

Modde DPSlave PROFIBUZ-DP partner
D (Add.. Diag.. PR... | W3 | &Address Pro.. |Length | Unit  |(Consiste. ..
1 M= | 0 1022 0 2 Byte it
2 WS o 0 1022 0 2 Byte IInit
3 MW=
1] | i

rzert B | Delete Fow |

— M5 Magter-Slave Configuration

b aster:
Statior;

Commernt; I

Cancel Help

Press OK.

The adresses for the input and the output are related to the addresses inside the
S7.

Note: The length of the process data module are limited to max. 32 bytes or 16
words per module. The number of modules and the number of the total process
data depends on the used CPU type.

Copyright * Hilscher Gesellschaft fur Systemautomation * An:S7TDPS#1E




The PLC S7-300

WHW Config - [DPSlave [Configuration] -- DPSlave]
Im} Station Edit Insert PLC “iew Options “Window Help

= o oo | o | on| 2= | oo 00E

=
4
Ty

D32 (%] & || sl 2@ 58 kel

Order number MPI address | address [ address Cornrmemt |
BESY 307-1BAD0-0AAD -
GES7 315-2AF01-0ABOD 2

Fege

Fresz F1 to get Help.

3.4.4 Download the Hardware Configuration

Select the menu PLC > Download to Module.

Select Destination Module

Destination Modules:

| selectan |

Cancel

Help

Select All and press OK.
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The PLC S7-300 22

Select Station Address ;

Ower which gtation addrezs is the programming device connected to the module CPU 315-2 DFP?

Slat:

Back: IEI _l:
=

Destination Station: % Local

) Carbe reached byimeans of gateway

Connection to destination station
Type | Address

Cancel Help |

Press OK.

The Download Window shows Module currently beeing processed [0/2/0] CPU
315-2DP.

3.4.5 Save and Exit the Hardware Configurator

Select menu Station > Save and the select the menu Station > EXxit.

The set the PLC into RUN mode.
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The Hilscher PROFIBUS-DP Master 23

4 The Hilscher DP Master

Before you start make sure that you have the right GSD file for the S7 300 CPU.
You can download this file via the GSD library on www.profibus.com)

4.1 SyCon PROFIBUS Project

Start the System Configurator SyCon.
Then select File > New or File > New > PROFIBUS.

4.2 Insert the GSD file for the S7-300

Select the menu File > Copy GSD.

CowGsD _HEHE]|
Suchen in: IEﬂ FramSisrmen: __:_! g;!

D ateinarme: ISiemED2f.gse Offren I
D ateityp: IGSE-fiIe [F.9ze] English j Abbrechen |

Copyright * Hilscher Gesellschaft fur Systemautomation * An:S7TDPS#1E
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The Hilscher PROFIBUS-DP Master 24

4.3 Insert the DP Master

Select the menu Insert > Master and insert the master that you want to use, e.g.
CIF 50-PB. Assign the Station adress, e.g. 1.

Inzert Master i

Ayailable masters Selected masters ok,
CIF100-PE CIFR0-FE

CIF104-DP-AB Add = Cahcel 1
CIF104-Fi5 —

CIF20-DPM / CIF104-DPM AR
CIF30-FMS

CIF30-PE / CIF104-FB

Add Al s

<< Remove All

CIFED-PE
CIFPS1-DPM << Bemove
CIFPS1-FrS :.j

COkd ThDkAd ! DR S0 CiOkd

A3

YWendor name Hilzzher GrmbH Station addrezz i'l

|dent number 11645 Description ;P'I:_M astel
G50 file name  HIL_1645.G5D

4.4 Insert DP Slave

Select the menu Insert > Slave and insert the Siemens DP Slave, e.g.
S7-315-2DP. Assign the Station adress, e.g. 3.

Inzert Slave ;
= Slave Filter
Vendor  |SIEMENS ] Master | CIF50-PE =l oK.
Slave type ;.-'f-.ll _:_i LCancel 1
Avalable slaves Selected zlaves
ET 200k [IM153-2] Add x> l ST-N5-2DP
ET 2005 [IM1571]
SY-300 CP342-5DF
57-315-2DP EEleD 1
<< Remove Al 1
<< Hemove i
YWendor name SIEMEMS Station address ;3
Ident number 0=B02F Description iS?_SIave
G50 file name SIEMB0ZF.GSE
G50 Revision W1.8
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This results in the following bus layout.

ESyEnn - [Unnamed1] [_ 5] =]
% Fle Edt “iew Inset Orline Seftngs Toolk Window Help
Dl=(E| 2|2

=& x|
| | | e

PC_Master

Station address 1
FMS/DP Master CIFS0-PB

| . [H[H[H S7_Slave

Station address 3
DF Slave

S57-315-2DP

For Help, press F1

|[PROFIBUS  |[Config Mode
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Click the symbol of the Slave with the left mouse button and then choose the
Settings > Slave Configuration menu.

or

Open the Slave configuration window by means of double clicking on the
PROFIBUS-DP Slave device.

Select step by step the modules, e.g.

First select 'first ID in general '

Then select 'second ID in general '

Then select 'third ID in general '

Then select 'Master_O Slave_| 2 by unit'

Finally select 'Master_| Slave_O 2 by unit’

Slavekonfiguration

Allgemein

Gerat 57-315-20F

Stationzadiezse

(2 Byte)
(2 Byte)

F

Beschreibung |S 7_Slave

[v Geratin der aktuellen Konfiguration akbvieren

| ok,

Parameterdaten...

|
abbrechen |
|
|

v Ansprechibenwachung aklbivieren G50 Datei  SIEMB02F.GSE
Max. Lahge d. Ein-4Ausg.-0. 244 Bute Lange d. Ein-Ahuzg. -0 4 Bute DPYT Parameter
Max. Lange d. Eingangsdaten 122 Eute Lange d. Eingangzdaten 2 Bute Zugeordneter Master
hax. Lange d. Auzgangzdaten 122 Byte Lange d. Auzgangzdaten 2 Buyte Statiohzadrezse 1
b aw. Anzahl der kodule il Anzahl der Module 5 PC Master
Modul Eingangliusging(Ein /das|Eannang - 1/ CIFR0-PE ﬂ
first ID in general Oz00 I
second ID in general OO0 fktueler Slave
third ID in general OO0 Statiohzadresse 3
Master I Zlawe_ 0 1 by unit |1 Eyte Ox1lo 57 Slave
Master I Slawe 0 2 by unit & Byte Oxl1ll

= = 357-N5-20P hal

Mazter I Slawve 0 £ by ttl |£ Eyte 0x31 hd | —J
=1lot|Tdx [Modul Syubol |Typ [E 2dr. [E-In. [ryp [& adr. |a-1n.

1 1 first ID Modulel
z 1 sacond ID ModuleZ
3 1 third IL Module:
d 1 Haster_0 Moduled
5 1 Mazter I HModulel

IE u] Z

QE 0 z

i‘ Maodul anhangen

todul entfernen

b odul einfugen

Fredefined Modules

j Sumbaolische Marmen

The adresses for input (I Addr) and output (O Addr) are allocated in the process
data memory in the Master.
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45 Set the Bus Parameters

Click on the Icon for the master and then select the menu Settings >
Busparameters and set the baudrate, e.g. 1.5 Mbaud.

4.6 Download the Configurtion

Click on the Icon for the master and then select the menu Online > Download.

4.7 Save the Configuration

Select the menu File > Save to save your configuration.
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