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Kurzbeschreibung
Diese CD beinhaltet

• die ladbare Firmware*
• den Systemkonfigurator SyCon**
• den OPC-Server**
• den CIF Device Driver
• die Treiber für SoftSPSen**
• die EDS-Dateien
• die Dokumentation
für alle unsere Communication InterFaces CIF.

Das Communication Interface führt den gesamten
Datenaustausch zwischen den angeschlossenen
Feldbus-Teilnehmern und dem PC durch. Dabei werden
die Daten als Prozessabbild im Dual-Port Memory des
CIFs zur Verfügung gestellt. 
Bei nachrichtenorientiertem Datenaustausch erfolgt die-
ser über eine Mailbox im Dual-Port Memory. 
Die PC-Applikation greift über den CIF Device Driver
oder einen speziellen SoftSPS-Treiber auf das Prozess-
abbild oder auf die Mailbox zu.
Die Konfiguration und Inbetriebnahme erfolgt durch den
Systemkonfigurator SyCon. Dieser kommuniziert mit dem
CIF über den CIF Device Driver oder über TCP/IP zu einem
Remote-PC oder über eine serielle Verbindung zwischen
dem COM-Port des PCs und der Diagnoseschnittstelle
des CIFs. Die Konfiguration wird auf dem CIF gespeichert,
sodass das CIF beim Starten sofort betriebsbereit ist.
*  Falls es eine neue Firmwareversion gibt, können Sie

diese von unserer Homepage herunterladen.
** Zum Betrieb des Systemkonfigurators, des OPC-Ser-

vers oder des SoftSPS-Treibers benötigen Sie einen
Lizenzcode. Wenn dieser im Lieferumfang mit enthal-
ten ist, finden Sie ihn für den Systemkonfigurator als
Label auf dieser CD oder in einem Briefumschlag ein
Lizenzcodeanforderungsformular bzw. für den OPC-
Server oder den SoftSPS-Treiber auf der Karte.
Andernfalls wenden Sie sich bitte an Ihren Distributor
oder direkt an uns.

Short Description
This CD contains

• loadable Firmware*
• System Configurator SyCon**
• OPC Server**
• CIF Device Driver
• Driver for SoftPLCs**
• EDS files
• Documentation
for all our Communication InterFaces CIF.

The Communication Interface handles the complete
data exchange between the connected fieldbus devices
and the PC. The data are available as process image in
the dual-port memory of the CIF. The message oriented
data exchange is handled via a mailbox in the dual-port
memory. 

The PC application has access on the process image or
the mailbox over the CIF Device Driver or a special
SoftPLC Driver.
The configuration and set up takes place through the
System Configurator SyCon. It communicates via the
CIF Device Driver or via TCP/IP to a remote PC or via a
serial connection between the COM port of the PC and
the diagnostic interface of the CIF. The configuration is
stored on the CIF, therefore the CIF is immediately
ready after the start.
*  If there is a new firmware version available you can

download it from our homepage.
** A license code is required to use the System Con-

figurator, the OPC Server or the SoftPLC Driver. If
this is included in the scope of delivery you will find it
for the System Configurator on a label on this CD or
in an envelope a license code request form respectively
for the OPC Server or the SoftPLC Driver on the card.
Otherwise please contact your distributor or us 
directly.
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Verzeichnisstruktur der CD
Sie erhalten auf dieser CD alle Dokumentationen im
Adobe-Acrobat-Reader-Format (PDF). Im Verzeichnis
ACROREAD ist eine Runtime-Version enthalten.

Directory Structure of the CD
All manuals on this CD are delivered in the Adobe
Acrobat Reader format (PDF). A runtime version of this
reader can be found in the ACROREAD directory.

Installation des Acrobat Readers, in Deutsch
und Englisch für verschiedene Windows-Ver-
sionen
Installation of Acrobat Reader, in German or
English language for different Windows 
versions

Installation des CIF Device Drivers
Installation of the CIF Device Driver

Manuals, Headers, Sample 
zur Treiberprogrammierung
for the driver programming

Häufig gestellte Fragen
Frequently asked questions

Dokumentation zum SyCon und
den Protokollen im Acrobat-Reader-Format

Documentation of SyCon and the protocols in
Acrobat Reader format

Installation SyCon
Installation of SyCon



6

Systemvoraussetzungen
• PC mit 486-, Pentium-Prozessor oder höher
• Windows 95/98/ME, Windows NT 4.0/2000/XP
• Freier Festplattenspeicher: 30-80 MByte
• CD-ROM-Laufwerk
• RAM: mind. 16 MByte
• Grafikauflösung: mind. 800 x 600 Bildpunkte
• Windows 95: Service Pack 1
• Windows NT: Service Pack 6 oder höher
• COM/DCOM für den OPC-Server
• Tastatur und Maus

Installation des CIFs
Um eine Beschädigung des PCs und des CIFs zu ver-
meiden, entladen Sie sich am metallischen Gehäuse
des PCs.

Stellen Sie sicher, dass die konfigurierten Speicherbereiche
und Interrupte nicht von anderen Geräten belegt sind. 

Um solche Fehler zu erkennen und zu verhindern,
wählen Sie unter

System Requirements
• PC with 486-, Pentium processor or higher
• Windows 95/98/ME, Windows NT 4.0/2000/XP
• Free disk space: 30-80 MByte
• CD ROM Drive
• RAM: min. 16 MByte
• Graphic resolution: min. 800 x 600 pixel
• Windows 95: Service Pack 1
• Windows NT: Service Pack 6 or higher
• COM/DCOM only for OPC Server
• Keyboard and Mouse

Installation of the CIF
To prevent damage to the PC or the CIF discharge
yourself at the metal cabinet of the PC.

Make sure that the configured memory areas and inter-
rupts are not used by another PC component. 

In order to identify and prevent such errors, select in

Windows Pfad / Path
2000/XP Start > Systemsteuerung > Verwaltung > Computerverwaltung > System > Systeminformationen > 

Hardwareressourcen
Start > Control Panel > Administrative Tools > Computer Management > System Information >
Hardware Resources

NT Start > Programme > Verwaltung > Windows-NT-Diagnose > Ressourcen
Start > Programs > Administrative Tools > Windows NT Diagnostics > Resources

95/98/ME Start > Einstellungen > Systemsteuerung > System > Gerätemanager
Start > Settings > Control Panel > System > Device Manager

ISA- und PC/104-Karten

1. Konfigurieren Sie die Startadresse des CIFs gemäß
den nachstehenden Abbildungen. Beachten Sie, dass
das CIF einen freien Speicherbereich von 2 bzw. 
8 KByte zwischen 0xA0000-0xFFFFF benötigt.

ISA and PC/104 cards

1. Configure the start address of the CIF according the
following description. Please note that a free memory
area of 2 KByte respectively 8 KByte between
0xA0000-0xFFFFF is necessary.
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2. Falls Sie im Interruptbetrieb arbeiten, stellen Sie
einen freien Interrupt auf dem CIF ein.

3. Schalten Sie zuerst die Betriebsspannung Ihres PCs
und aller angeschlossenen Geräte aus.

4. Öffnen Sie das Gehäuse des PCs und stecken Sie
das CIF auf einen freien ISA-Steckplatz. Der CIF Devi-
ce Driver unterstützt bis zu vier CIFs pro PC. Befestigen
Sie das CIF an der vorgesehenen Bohrung.

5. Schließen Sie wieder das PC-Gehäuse und schalten
Sie die Betriebsspannung des PCs ein.

PCI-Karten

1. Schalten Sie zuerst die Betriebsspannung Ihres PCs
und aller angeschlossenen Geräte aus.

2. Öffnen Sie das Gehäuse des PCs und stecken Sie
das CIF auf einen freien PCI-Steckplatz. Der CIF Devi-
ce Driver unterstützt bis zu vier CIFs pro PC. Befestigen
Sie das CIF an der vorgesehenen Bohrung.

3. Schließen Sie wieder das PC-Gehäuse und schalten
Sie die Betriebsspannung des PCs ein.

4a. Windows 2000/XP erkennen das CIF automatisch
und öffnen das Fenster Neue Hardware gefunden.
Das CIF wird als Anderes PCI-Brückengerät erkannt.
Der Installationsassistent erwartet eine Diskette/CD des
Hardware-Herstellers. Wechseln Sie hierzu in das Ver-
zeichnis Driver\Win2000_XP\PCI auf der CD oder bei
bereits installiertem CIF Device Driver in das Verzeich-
nis der Treiberhilfsprogramme 
(...\Programme\CIF Device Driver\Win2000_XP\PCI).

4b. Unter Windows NT werden PCI-Karten nicht auto-
matisch erkannt, sondern müssen manuell über den
CIF Device Driver aktiviert werden. Die Aktivierung
erfolgt mithilfe des Programms CIF Device Driver
Setup im Menü PCI > Setup > Activate PCI support. 

2. If you are using the interrupt mode you have to set up
a free interrupt on the CIF.

3. First switch off the power of the PC and all connected
devices.

4. Open the cabinet of the PC and plug in the CIF on a
free ISA slot. Up to four CIFs per PC are supported by
the CIF Device Driver. Fix the CIF using the hole inten-
ded.

5. Close the PC and switch on the power of the PC.

PCI cards

1. First switch off the power of the PC and all connected
devices.

2. Open the cabinet of the PC and plug in the CIF on a
free PCI slot. Up to four CIFs per PC are supported by
the CIF Device Driver. Fix the CIF using the hole inten-
ded.

3. Close the PC and switch on the power of the PC.

4a. Windows 2000/XP detect the CIF automatically and
will open the window New Hardware Found. The CIF
is detected as an Other Bridge Device. The installation
devices assistant asks for a disk/CD from the hardware
manufacturer. For this purpose, change to the directory
Driver\Win2000_XP\PCI on the CD or if the CIF Device
Driver is already installed into the directory of the driver
utilities 
(...Program Files\CIF Device Driver\
Win2000_XP\PCI).

4b. Under Windows NT the PCI cards are not detected
automatically, they have to be activated manually via
the CIF Device Driver. The activation is done with help
of the CIF Device Driver Setup Program in the menu
PCI > Setup > Activate PCI support.
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4c. Windows 95/98/ME erkennen das CIF automatisch
und öffnen das Fenster Neue Hardwarekomponente
gefunden. Der Installationsassistent erwartet eine Dis-
kette/CD des Hardware-Herstellers. Wechseln Sie hier-
zu in das Verzeichnis Driver\Win9x\PCI auf der CD
oder bei bereits installiertem CIF Device Driver in das
Verzeichnis der Treiberhilfsprogramme 
(...\Programme\CIF Device Driver\Win9x\PCI).

5. Nach erfolgreicher Installation ist der PC neu zu star-
ten.

4c. Windows 95/98/ME will detect the CIF automatical-
ly and will open the window New Hardware Found.
The installation assistent asks for a disk/CD from the
hardware manufacturer. For this purpose, change to the
directory Driver\Win9x\PCI on the CD or if the CIF
Device Driver is already installed into the directory of
the driver utilities 
(...\Programs\CIF Device Driver\Win9x\PCI).

5. After a successful installation the PC has to be
rebooted.
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Device DrawingsGerätezeichnungen
Typ / Type Karte / Card Dual-Port Memory Funktion / Function
CIF 30-ASM ISA 2 KByte AS-Interface Master 

(Zwei-Kanal / Two channel)

AS-Interface Kanal 1 (CH1)

AS-Interface Channel 1 (CH1)

AS-Interface Kanal 2 (CH2)

AS-Interface Channel 2 (CH2)

Diagnose-Schnittstelle
(DSub-Stecker 9-polig)

Diagnostic Interface
(DSub male connector 9 pin)

RDY  RUN
CH1  CH2

Die beiden Jumper 2K müssen gesetzt
sein.

The two jumper 2K have to be set.
X = Steckbrücke gesteckt / Jumper closed Grundeinstellung / Default configuration

Adresse / Address A11 A12 A13 A14 A15 A16 A17 A18 A19
CA000 X X X X X
CA800 X X X X
CB000 X X X X
CB800 X X X
CC000 X X X X X
CC800 X X X X
D0000 X X X X X X

Interrupt I15 I14 I12 I11 ... I3
Kein / no
15 X
14 X
12 X
11 X
...
3 X
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Typ / Type Karte / Card Dual-Port Memory Funktion / Function
CIF 50-ASM PCI 8 KByte AS-Interface Master

(Zwei-Kanal / Two channel)

AS-Interface Kanal 1 (CH1)

AS-Interface Channel 1 (CH1)

AS-Interface Kanal 2 (CH2)

AS-Interface Channel 2 (CH2)

Diagnose-Schnittstelle
(DSub-Stecker 9-polig)

Diagnostic Interface
(DSub male connector 9 pin)

RDY  RUN
CH1  CH2

Die Adresseinstellung erfolgt automatisch durch den
CIF Device Driver und kann mit dem Programm CIF
Device Driver Setup überprüft werden.

Für die Betriebssysteme Windows 95/98/ME und NT ist
der CIF Device Driver ab Version 3.010 oder höher zu
verwenden.

Für die Betriebssysteme Windows 2000 und XP ist der
CIF Device Driver Version 3.110 oder höher zu verwen-
den.

The address setting takes place automatically by the
CIF Device Driver and can be checked with the pro-
gram CIF Device Driver Setup.

For the operating systems Windows 95/98/ME and NT
you have to use the CIF Device Driver version 3.010 or
higher.

For the operating systems Windows 2000 and XP you
have to use the CIF Device Driver version 3.110 or hig-
her.



11

AS-Interface Kanal 1 (CH1)

AS-Interface Channel 1 (CH1)

AS-Interface Kanal 2 (CH2)

AS-Interface Channel 2 (CH2)

Diagnose-Schnittstelle
(DSub-Stecker 9-polig)

Diagnostic Interface
(DSub male connector 9 pin)

CH1
CH2

RUN
RDY

J3

Typ / Type Karte / Card Dual-Port Memory Funktion / Function
CIF 104-ASM PC/104 2 KByte (*) AS-Interface Master 

(Zwei-Kanal / Two channel)

X = Steckbrücke gesteckt / Jumper closed Grundeinstellung / Default configuration
Weitere Beispiele für Jumpereinstellungen finden Sie auf der CD im Verzeichnis CD:/Faq/jumper.pdf
Further examples for jumper settings are on the CD in the directory CD:/Faq/jumper.pdf

\P 10-polig gewinkelt
10 pin angled

\S 10-polig gerade
10 pin straight

\H 16-polig gewinkelt
16 pin angled

\V 16-polig gerade
16 pin straight

Option
Pfostenverbinder
anstelle von
DSub-Stecker

Option
Square post
connector instead
of a DSub connector

Adresse/Address A19 A18 A17 A16 A15 A14 A13
CA000 X X X
CC000 X X X
CE000 X X
D0000 X X X X
D2000 X X X
D4000 X X X
D6000

Interrupt I15 I14 I12 I11 ... I3
Kein / no
15 X
14 X
12 X
11 X
...
9 X

Jumper J3
Offen 2 KByte
Geschlossen 8 KByte

Hinweis (*): Die Größe des Dual-Port Memories kann
durch setzen des Jumpers J3 von 2 KByte auf 8 KByte
geändert werden.

Note (*): The size of the dual-port memory can be
changed from 2 KByte to 8 KByte by setting the jumper
J3.
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AS-Interface-Schnittstelle
Der AS-Interface Master entspricht laut Spezifikation
Version 2.11 (Annex B, Version 2.0) dem Profil M3 (Full
Extended Master).

AS-Interface Schnittstelle gemäß IEC 364-4-41.

AS-Interface Interface
The AS-Interface Master conforms to Complete Specifi-
cation 2.11 (Annex B, Version 2.0) the profile M3 (Full
Extended Master).

AS-Interface interface according IEC 364-4-41.

Es kann jedes Kabel verwendet werden (geschirmt oder
ungeschirmt), dass die folgenden Eigenschaften besitzt
(bei f = 167 kHz):

Every cable can be used, shielded or non-shielded
which meets the following characteristics 
(at f = 167 kHz):

Parameter Wert
Parameter Value
Widerstand < 90 mOhm/m
Resistance 
Kapazitätsbelag < 80 pF/m 
Capacity
Wellenwiderstand 70 ... 140 Ohm
Impedance
Induktivität 400 ... 1300 nH/m
Inductance
Empfohlener Leitungsquerschnitt 2 x 1,5 mm²
Recommended cable cross section

Außerdem möglich: AS-Interface Standardkabel nach
IEC 60352-6.

Eine maximale Gesamtlänge (inklusive aller Stichleitun-
gen) von 100 m darf aber nicht überschritten werden.
Abschlusswiderstände sind nicht erforderlich.

Durch Repeater kann die Gesamtlänge erhöht werden.

Also possible: AS-Interface standard cable according to
IEC 60352-6.

The total length of the AS-Interface line shall not exceed
100 meters. This length shall be calculated inclusive the
sum of all trunk lines. Termination resistors are not nee-
ded.

The total length can be increased by Repeater.

Anschluss mit 2-poligem Combicon Stecker Signal Bedeutung
Connection with 2 pin Combicon male connector Signal Meaning
1 AS-i + AS-Interface Spannung positiv / positive voltage
2 AS-i - AS-Interface Spannung negativ / negative 

voltage



13

Die AS-Interface Topologie ist eine Baumstruktur. Pro
Kanal können bis zu 31 AS-Interface Slaves mit beliebi-
gen Profil im unteren Adressbereich angeschlossen
werden. Durch Verwendung von Slaves mit dem Profil
x.A.y kann eine Adressverdopplung erreicht werden.
Die maximal mögliche Anzahl von 62 Slaves pro Kanal
wird ausschließlich durch die Verwendung von Slaves
mit Profil x.A.y erreicht.

Die empfohlene Spannung liegt im Bereich von 29,6 V
bis 31,6 V. Der Spannungsabfall zwischen dem Netzteil
und jedem anderen Punkt im Netzwerk darf 3 V nicht
übersteigen. 

Hinweis: Verwenden Sie unbedingt ein spezielles AS-
Interface Netzteil für die Speisung des Systems, da nur
ein solches Netzteil die notwendige Entkopplung von
Daten und Versorgungsspannung gewährleistet. 

Dieses Netzteil kann an jeder beliebigen Stelle im Netz-
werk angeschlossen werden. Außer dem Massean-
schluß des Netzteils darf innerhalb des AS-Interface
Systems keine weitere Verbindung zum Erdpotential
bestehen. 
Jeder Kanal benötigt ein eigenes Netzteil. Diese dürfen
nicht miteinander verbunden sein.

The AS-Interface topology is a tree structure. Per chan-
nel up to 31 AS-Interfaces Slaves with any profile within
the lower address range can be connected. By use of
Slaves with the profile x.A.y an address doubling can be
achieved. The maximally possible number of 62 Slaves
per channel is reached exclusively by the use of Slaves
with profile x.A.y.

The recommended voltage is in range of 29.6 V to 31.6
V. The voltage drop along the AS-Interface line between
power supply and any point of the network shall not
exceed 3 V. 

Note: It is strongly recommended to use a specific AS-
Interface power supply in order to provide the neces-
sary decoupling of data signals and DC power within
the system. 

The AS-Interface power supply can be connected at
any point of the network. There shall be no connection
to ground in the network apart from the port ground at
the power supply.

Each channel needs its own power supply. These may
not be connected with each other.
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Diagnose-Schnittstelle
Potentialgebundene RS-232C zum Anschluss an die
COM-Schnittstelle des PCs.

Diagnostic Interface
Non isolated RS-232C to connect with the 
COM port at the PC.

9-polige DSub-Buchse
9 pin DSub female connector

CTS

RTS

n.c.

DTR

TXD

RXD

CIF
Schirm am Steckergehäuse
Shield at connector casing

PC

RXD

TXD

GND

RTS

DTR

CTS

9-polige DSub-Buchse
9 pin DSub female connector

GND

DSR

DSub-Stecker Pfostenverbinder Signal Bedeutung Eingang / Ausgang
9-polig 10-polig 16-polig
DSub male square post connector Signal Meaning Input / Output
connector 9 pin 10 pin 16 pin

2 3 7 RXD Empfangsdaten / Receive Data Eingang / Input
3 5 9 TXD Sendedaten / Send Data Ausgang / Output
4 7 11 DTR Datenendeinrichtung betriebsbereit / Ausgang / Output

Data Terminal Ready
5 9 13 GND Betriebserde / Signal Ground -

(6) n.v. / n.c. n.v. / n.c. n.v. / n.c. DSR Betriebsbereitschaft / Eingang / Input
Data Set Ready

7 4 8 RTS Sendeteil einschalten / Ausgang / Output
Ready to Send 

8 6 10 CTS Sendebereitschaft / Eingang / Input
Clear to Send

n.v. nicht verwendet / n.c. not connected
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Installation of the Software
Close all application programs on the system!

Insert the CD in the local CD ROM drive. The installati-
on program will start by itself (Autostart enabled). Other-
wise change into the root directory on the CD and start
Autorun.exe (Autostart disabled).

NOTE Administrator privileges are required on
Windows NT/2000/XP systems for installation!

The installation program ask for the components you
want to install. Answer these questions with Yes or No. 

It will install 

• System Configurator SyCon
• OPC Server
• CIF Device Driver.

If a license code is included in the scope of delivery you
will find it for the System Configurator on a label on this
CD or in an envelope a license code request form. In
case you have a license code, answer the question for
an existing license code with Yes, otherwiese a basic
version of the system configurator will be installed.
Enter your name and the company name. 

Installation 
of the SoftPLC Driver
The description of the installation is on the CD in 
\DRIVER\SOFTPLC\. To use the SoftPLC Driver a
license on the CIF is necessary. 

Installation der Software
Schließen Sie alle Programme!

Legen Sie die CD in das lokale CD-ROM-Laufwerk. 
Das Installationsprogramm startet selbstständig
(Autostart eingeschaltet). Andernfalls wechseln Sie 
in das Root-Verzeichnis der CD und starten Sie
Autorun.exe (Autostart ausgeschaltet).

HINWEIS Unter Windows NT/2000/XP benötigen Sie
Administratorrechte zur Installation!

Das Installationsprogramm fragt, welche Komponenten
installiert werden sollen. Beantworten Sie diese Fragen
mit Ja bzw. Nein. 

Installiert werden

• Systemkonfigurator SyCon
• OPC-Server
• CIF Device Driver.

Wenn ein Lizenzcode im Lieferumfang mit enthalten ist,
finden Sie ihn für den Systemkonfigurator als Label auf
dieser CD oder in einem Briefumschlag ein Lizenzcode-
anforderungsformular. Falls ein Lizenzcode vorhanden
ist, beantworten Sie die Frage nach einem vorhande-
nen Lizenzcode mit Ja, ansonsten wird eine Basisversi-
on des Systemkonfigurators installiert. Geben Sie Ihren
Namen und den Firmennamen ein. 

Installation 
des SoftSPS-Treibers
Die Beschreibung der Installation ist auf der CD in 
\DRIVER\SOFTPLC\ vorhanden. Zum Betrieb des
SoftSPS-Treibers ist eine Lizenz auf dem CIF notwen-
dig. 
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Installation des
Systemkonfigurators SyCon
Bei der Installation müssen Sie Ihren Namen und den
Firmennamen eingeben. 

Wenn ein Lizenzcode im Lieferumfang mit enthalten ist,
finden Sie ihn für den Systemkonfigurator als Label auf
dieser CD oder in einem Briefumschlag ein Lizenzcode-
anforderungsformular. Falls ein Lizenzcode vorhanden
ist, beantworten Sie die Frage nach einem vorhande-
nen Lizenzcode mit Ja, ansonsten wird eine Basisversi-
on des Systemkonfigurators installiert. Ihnen stehen
dann alle Funktionen zur Verfügung, jedoch ist die Kon-
figuration auf zwei Geräte am Netzwerk beschränkt,
was für Slave-Teilnehmer ausreichend ist.

Unter dem Menüpunkt Hilfe > Lizenzierung können
Sie ein Bestellformular für Ihre Lizenz ausfüllen und an
Ihren Distributor oder direkt an uns faxen.

Folgen Sie den Anweisungen des Installationsprogram-
mes, wählen Sie die zu installierenden Feldbussysteme
aus und beantworten die Fragen mit JA oder WEITER.

Installation of the
System Configurator SyCon
During the installation the user and the company name
must be entered.

If a license code is included in the scope of delivery you
will find it for the System Configurator on a label on this
CD or in an envelope a license code request form. In
case you have a license code, answer the question for
an existing license code with Yes, otherwiese a basic
version of the system configurator will be installed. In
this case, all functions are available, but the configurati-
on is limited to two devices on the network, which is suf-
ficient for slave devices.

A license can be ordered by filling out the order form
under the menu item Help > Licensing and fax this
order form either to your distributor or directly to us.

Follow the instructions of the installation program by
selecting the fieldbus system to be installed and answe-
ring all the questions with OK or NEXT.
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Installation 
des OPC-Servers
Installieren Sie bei Windows 95 und Windows 98 die
Betriebssystemerweiterung DCOM95 oder DCOM98.
(Zu beziehen über 
www.microsoft.com/com/resources/download.asp
bzw. im Internet Explorer ab Version 4.0 enthalten)

Bei Windows NT, Windows 2000 und Windows XP
sind diese Erweiterungen bereits vorhanden. 

Installieren Sie den OPC-Server auf dem PC, in dem
das CIF installiert ist. 

Wenn der OPC-Client auf einem anderen PC ausge-
führt wird, dann installieren Sie zusätzlich auf diesem
PC den OPC-Server-Remote-PC. 

Zum Betrieb des OPC-Servers ist eine Lizenz auf dem
CIF notwendig. Weitere Angaben zur Installation finden
Sie auf der CD in
\MANUAL\DEUTSCH\OPC\OPC_OID.PDF.

Installation 
of the OPC Server
For Windows 95 and Windows 98 install the operating
system extension DCOM95 or DCOM98. (Available on
www.microsoft.com/com/resources/download.asp
or components of the Internet Explorer from version
4.0)

In Windows NT, Windows 2000 and Windows XP
these extensions already exist. 

Install the OPC Server on the PC that has the CIF
installed. 

If the OPC Client is executed on another PC, then
install additionally OPC-Server remote station on that
PC. 

To use the OPC Server a license on the CIF is neces-
sary. 
More information about the installation are on the CD in
\MANUAL\ENGLISH\OPC\OPC_OIE.PDF.
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Installation des
CIF Device Driver
Wählen Sie CIF Device Driver aus dem Installations-
menü oder starten Sie aus dem CD-Verzeichnis \Driver
das Programm Setup.exe.

Nach der Installation muss der CIF Device Driver ent-
sprechend des verwendeten CIFs konfiguriert werden.

Der Treiber akzeptiert maximal 4 Karten.

Konfiguration des 
CIF Device Driver
Starten Sie das Setup über Start > Programme > CIF
Device Driver > CIF Device Driver Setup. 

In den folgenden Abschnitten finden Sie eine Beschrei-
bung zur Konfiguration der von Ihnen verwendeten CIF-
Karte unter dem von Ihnen verwendeten Betriebssy-
stem.

ISA- und PC/104-Karten

ISA- und PC/104-Karten unter Windows 2000/XP

1. Öffnen Sie mit Systemsteuerung > System > Hard-
ware > Hardware-Assistent den Windows 2000 bzw.
XP Hardware-Assistenten .

2. Wählen Sie Gerät hinzufügen bzw. Problem behe-
ben.

3. Nach der automatischen Hardwareerkennung Suche
nach neuen Hardwarekomponenten wählen Sie
Neues Gerät hinzufügen.

Installation of the
CIF Device Driver
Select CIF Device Driver in the installation menu or
start the program Setup.exe from the CD directory
\Driver.

After the installation the Device Driver has to be confi-
gured according to the used CIF.

The driver accepts max. up to 4 cards. 

Configuration of the 
CIF Device Driver
StartStart the setup via Start > Programs > CIF Device
Driver > CIF Device Driver Setup. 

In the following sections you find a description of confi-
guring the CIF card which is used by you under the
used operating system.

ISA and PC/104 Cards

ISA and PC/104 cards under Windows 2000/XP

1. Open the Windows 2000 or the XP Hardware Wizard
with Control Panel > System > Hardware > Hard-
ware Wizard.

2. Choose Add/Troubleshoot a device.

3. After the automatic New Hardware Detection choo-
se Add new device. 
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4. Wählen Sie Nein, die Hardwarekomponenten
selbst aus einer Liste auswählen. Klicken Sie entwe-
der auf Andere Geräte oder falls vorhanden auf CIF
Communication Interface. Wählen Sie dann Daten-
träger... und wechseln Sie zum CD-Verzeichnis Dri-
ver\Win2000_XP\ISA oder, falls der Treiber bereits
installiert ist, in das Treiberinstallationsverzeichnis
...\Programme\CIF Device Driver\Win2000_XP\ISA.
Verfahren Sie bei CIF Communication Interface in glei-
cher Weise, wenn keine ISA-Karte zur Auswahl steht.

5. Wählen Sie, in Abhängigkeit der verwendeten Karte, 
CIF 10/30/40/104 (ISA-2KByte) oder 
CIF 10/30/40/104 (ISA-8KByte)

aus. Sie werden dann aufgefordert den Speicherbereich
und gegebenfalls den Interrupt des CIFs entsprechend
der Hardwarevorgabe einzustellen. 

6. Nach den Einstellungen müssen Sie Ihren PC neu
starten.

HINWEIS: Standardmäßig ist die Adresse CA000 und
kein Interrupt eingestellt (Basis-Konfiguration 0). Zum
Ändern der Adresse wählen Sie Basis-Konfiguration 1.
Interrupt und Adresse können unter Basis-Konfiguration
2 geändert werden. Weitere Hinweise finden Sie auf der
CD in \FAQ\DEUTSCH\ISA\isa_d.pdf. 

HINWEIS: Auf manchen PCs steht kein freier ISA-Spei-
cher im Bereich C0000-FF000 und kein ISA-Interrupt
zur Verfügung. Der Grund kann am Windows 2000
ACPI (Advanced Configuration and Power Management
Interface) liegen. Überprüfen Sie zuerst, ob Ihr PC
ACPI-konform ist und ob Sie das aktuellste BIOS des
Mainboardherstellers verwenden. Sollte es trotzdem
keine freien ISA-Ressourcen geben, so können Sie
auch versuchen Windows 2000 im "Standard PC"-
Modus (ACPI abgeschaltet) zu betreiben. Hierzu muss
die ACPI-HAL von Windows 2000 durch die STAN-
DARD-PC-HAL ersetzt oder Windows 2000 neu instal-
liert werden. Bitte kontaktieren Sie Microsoft zur Vorge-
hensweise, da die Installation unbrauchbar werden kann.

4. Select No, I want to select the hardware from a
list. Now click on either Other devices or CIF Commu-
nication Interface if available. From Other devices
choose Have disk and change to the CD directory Dri-
ver\Win2000_XP\ISA or the driver installation directory 
...\Program Files\CIF Device Driver\Win2000_XP\ISA.
Proceed in the same manner if you can't find an entry
for a CIF ISA card under CIF Communication Interface. 

5. Choose either
CIF 10/30/40/104 (ISA-2KByte) or 
CIF 10/30/40/104 (ISA-8KByte) 

depending on the hardware type. You will be asked to
set the memory area and if necessary to set an interrupt
both corresponding to the hardware settings of the CIF. 

6. After an installation you have to reboot the PC.

NOTE: The default setting is address CA000 and no
interrupt (Basis Configuration 0). To change the address
select Basis Configuration 1. The interrupt and the
address can be changed under Basis Configuration 2.
You will find more information on the CD in
\FAQ\ENGLISH\ISA\isa_e.pdf. 

NOTE: On some PCs it is not possible to find a free ISA
memory area between C0000-FF000 or a free ISA inter-
rupt in the Device Manager. This is Windows 2000 ACPI
(Advanced Configuration and Power Management Inter-
face) depending. Please check at first if your PC is
ACPI compatible and you are using the latest BIOS ver-
sion for your mainboard. Are there still problems to find
available ISA resources, you can try to run Windows
2000 in "Standard PC" mode (ACPI disabled). Therefo-
re the ACPI-HAL of Windows 2000 must be replaced
with the STANDARD-PC-HAL or Windows 2000 must
be installed new. Please contact Microsoft how to chan-
ge the Windows 2000-HAL, because this can make
your installation unusable. 
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ISA- und PC/104-Karten unter Windows
95/98/ME/NT

Geben Sie die konfigurierte Startadresse des CIFs in
Dual-Port Memory base address und die Größe des
Dual-Port Memory in Dual-Port Memory size ein. 

Betreiben Sie das CIF im Interrupt-Modus, dann ist in
Interrupt number der konfigurierte Interrupt anzuge-
ben, ansonsten ist Polling einzustellen.
Weitere Hinweise finden Sie auf der CD im Verzeichnis
\FAQ\DEUTSCH\ISA\isa_d.pdf.

PCI-Karten

PCI-Karten unter Windows 2000/XP

1. PCI-Karten werden von Windows 2000/XP automa-
tisch erkannt. Das System meldet sich mit Neue Hard-
ware gefunden. Falls nicht, starten Sie den Hardware-
Assistenten unter Systemsteuerung > System >
Hardware > Hardware-Assistent und wählen Sie
Gerät hinzufügen bzw. Problem beheben.

2. Windows 2000/XP sucht nun nach neuen Plug-and-
Play-Geräten. Die PCI-Karte wird als Anderes PCI-
Brückengerät angezeigt.

3. Wählen Sie Nach einem passenden Treiber für
das Gerät suchen (empfohlen) und klicken Sie auf
Weiter. 

4. Wählen Sie das CD-Verzeichnis
Driver\Win2000_XP\PCI oder, wenn der CIF Device
Driver bereits installiert ist, das Verzeichnis 
...\Programme\CIF Device Driver\Win2000_XP\PCI. 

5. Zeigt der Geräte-Manager bereits ein Anderes
Brückengrät an und ist dieses mit einem Fragezei-
chen/Ausrufezeichen markiert, klicken Sie das Gerät
mit der rechten Maustaste an und wählen Sie Deinstal-
lieren. Wiederholen Sie den Vorgang für all diese Geräte. 

ISA and PC/104 cards under Windows 95/98/ME/NT

Enter the configured start address of the CIF into Dual-
Port Memory base address and the size of the Dual-
Port Memory into Dual-Port Memory size. 

If an interrupt on the card has been set by means of a
jumper, then enter the same Interrupt number, if not
enter Polling.
You find more information on the CD in the directory
\FAQ\ENGLISH\ISA\isa_e.pdf. 

PCI Cards

PCI cards under Windows 2000/XP

1. Windows 2000/XP will recognize PCI cards automa-
tically during system startup. The system will show
New hardware found. If not choose the Hardware
Wizard under Control Panel > System > Hardware >
Hardware Wizard and select Add/Troubleshoot a
device. 

2. Windows 2000/XP searches for new Plug and Play
devices. The PCI card will be shown as Other PCI
Bridge Device.

3. Select Search for a suitable driver for my device
(recommended) and click Next.

4. Select on the CD the directory
Driver\Win2000_XP\PCI or if the CIF Device Driver is
already installed, the directory ...\Programs\CIF Devi-
ce Driver\Win2000_XP\PCI.

5. If the Device Manager already shows Other Bridge
Device marked with a question/exclamation mark,
make a right mouse click on the device and choose
Uninstall. Proceed in the same way for all such cards.
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6. Wählen Sie dann Aktion > Nach geänderter Hard-
ware suchen aus dem Menü. Wenn das System Neue
Hardware gefunden meldet, verfahren Sie wie bereits
oben beschrieben. 

7. Das CIF wird standardmäßig im Polling-Modus
installiert. Über das Programm CIF Device Driver
Setup kann der Interrupt-Modus ein- bzw. ausgeschal-
tet werden. 

8. Nach dem Umstellen des Modus muss der PC neu
gestartet werden.

PCI-Karten unter Windows 95/98/ME/NT

Die Unterstützung von PCI-Karten muss im CIF Device
Driver aktiviert werden. Das Aktivieren und Deaktivie-
ren erfolgt mithilfe des Programms CIF Device Driver
Setup. Die benötigten Ressourcen werden vom PC
(BIOS) automatisch zugeteilt.

1. Starten Sie das Programm CIF Device Driver Setup
aus der Programmgruppe CIF Device Driver. 

2. Im Menüpunkt PCI > Setup muss das Feld Activate
PCI support angehakt werden. Der Interruptbetrieb für
PCI-Karten wird mit Enable interrupt for board 0…3
ein- bzw. ausgeschaltet (Grundeinstellung: ausgeschaltet).

3. Setzen Sie alle Einstellungen für nicht installierte
ISA-Karten (Board 0..3) auf 00000 bzw. NONE.

4. Starten Sie nach der Konfiguration Ihren PC neu.

5. Während des Systemstarts werden die Konfigurati-
onsdaten vom CIF Device Driver ermittelt und vom Pro-
gramm CIF Device Driver Setup angezeigt. Der Treiber
verteilt die Board-Nummern der PCI-Karten automa-
tisch. Hier-zu werden nur freie (unbenutzte) Board-
Nummern verwendet, wobei diese aufsteigend von 0
bis 3 auf die PCI-Karten verteilt werden. Sind alle
Board-Nummern belegt, werden keine weiteren PCI-
Karten mehr vom Treiber akzeptiert.

6. After uninstallation choose Action > Scan for hard-
ware changes from the menu. When the system sig-
nals New hardware found follow the description
above. 

7. The CIF will be always installed in polling mode. Use
CIF Device Driver Setup Program to change the ope-
rating mode of the PCI cards from polling to interrupt. 

8. After changing the mode, you have to restart your
PC.

PCI cards under Windows 95/98/ME/NT

The driver support for PCI cards must be activated in
the CIF Device Driver. The activating and deactivating
is done with the help of the CIF Device Driver Setup
Program. The required resources are assigned automa-
tically by the PC (BIOS). 

1. Start the program CIF Device Driver Setup of the
program group CIF Device Driver. 

2. Select the menu PCI > Setup and check the Activa-
te PCI support field. Interrupt support for the cards will
be enabled or disabled by Enable interrupt for board
0…3 (default: disabled).

3. Set all entries for not installed ISA cards (Board 0..3)
to 00000 respectively NONE.

4. Restart your PC after configuration.

5. During system start, the configuration data will be
determined by the CIF Device Driver and will be shown
in the CIF Device Driver Setup program. Also the board
numbers for PCI cards will be assigned automatically by
the driver. Therefore, the driver uses only free (unused)
board numbers in rising order from 0 to 3. The driver
does not accept additional PCI boards if all board num-
bers are in use.



22

HINWEIS: Kontrollieren Sie, ob im PC-BIOS genügend
Interrupte zur Nutzung für PCI-Karten freigegeben sind
und vermeiden Sie die Mehrfachnutzung mit anderen
PCI-Geräten (z.B. Netzwerkkarten, Soundkarten o.Ä.).

Bei Timeout-Fehlern (z.B. -17, -18, -20) zwischen
Anwendungsprogramm und CIF deaktivieren Sie den
PCI-Interrupt des CIFs.

Weitere Hinweise finden Sie auf der CD in
\FAQ\DEUTSCH\PCI\pci_d.pdf.

NOTE: Check your PC-BIOS if there are enough inter-
rupts configured for the use by PCI devices and avoid
multiple use of interrupts by different PCI devices (e.g.
Network cards, sound cards etc.).

If you encounter timeout errors between your applicati-
on program and the CIF card (e.g. -17, -18, -20) deac-
tivate the PCI interrupt of the CIF card 

You find more information on the CD in
\FAQ\ENGLISH\PCI\pci_e.pdf.
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Aufrufen des 
CIF Device Driver
Von eigenen Windows-Applikationen können Sie den CIF
Device Driver benutzen, um auf das Prozessabbild
bzw. die Mailbox im Dual-Port Memory des CIFs zuzu-
greifen.

Das Manual DEVDRV.PDF beschreibt alle Funktionen
des CIF Device Drivers und gilt für alle Feldbussyste-
me. Die protokollspezifischen Befehle und Datenstruk-
turen sind jeweils in einem eigenen Manual beschrie-
ben, siehe hierzu nachfolgende Tabelle.

Wenn Sie einen eigenen Treiber schreiben möchten,
unter MS/DOS oder einem anderen Betriebssystem
arbeiten, bieten wir das Toolkit CIF-TKIT mit C-Quell-
code, Beispielprogrammen und einer genauen
Definition des Dual-Port Memory an.

Using the 
CIF Device Driver
From own Windows application you can use the CIF
Device Driver to get access on the process image res-
pectively the mailbox in the Dual-Port Memory of the
CIF.

The manual DEVDRV.PDF describes all functions of the
CIF Device Driver and is valid for all fieldbus systems.
The protocol specific commands and data structures
are described presently in own manuals, please refer to
the following table.

If you wish to write your own driver or you are working
with MS/DOS or an other operating system, we offer the
tool kit CIF-TKIT with C-Source code, example program
and the exact definition of the Dual-Port Memory.

Feldbus/Protokoll / Fieldbus/Protocol Manual
Programmieranleitung zum CIF Device Driver DEVDRV.PDF 
How to use the CIF Device Driver and the demo files
PROFIBUS-FMS Master FMS_PIE.PDF
PROFIBUS-DP Master DPM_PIE.PDF
PROFIBUS-DP Slave DPS_PIE.PDF
InterBus Master IBM_PIE.PDF
InterBus Slave IBS_PIE.PDF
AS-Interface Master ASIM_PIE.PDF
CANopen Master COM_PIE.PDF
CANopen Slave COS_PIE.PDF
DeviceNet Master DNM_PIE.PDF
DeviceNet Slave DNS_PIE.PDF
ControlNet Master (Scanner) CNM_PIE.PDF
ControlNet Slave (Adapter) CNS_PIE.PDF
ASCII, 3964R, RK512, Modbus RTU, Modbus Plus, STD_PIE.PDF
Modnet 1/N, Modnet 1/SFB
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Konfiguration des
AS-Interface-Netzwerks
AS-Interface Master:

Mit dem Systemkonfigurator legen Sie mit Datei > Neu
> AS-Interface das Bussystem fest und wählen mit 
Einfügen > Master den verwendeten Master aus.

Fügen Sie mit Einfügen > Slave die am AS-Interface-
Netzwerk verwendeten Slaves durch Auswahl des
Slave Profils in die Konfiguration an den Kanal 1 bzw.
Kanal 2 ein und weisen Sie diesen eine Geräteadresse
zu. 
Machen Sie einen Doppelklick auf die Slave-Icons und
konfigurieren Sie die einzelnen Geräte. Dabei ist der
erweiterte ID1 und ID2 Code, sowie Parameterdaten
anzugeben. Die Adressen im Prozessabbild werden bei
Autoadressierung vom SyCon vergeben, andernfalls
müssen Sie diese manuell eingeben.

Stellen Sie mit Einstellungen > Gerätezuordnung ein,
über welchen Treiber der Systemkonfigurator mit dem
CIF kommunizieren kann. 
Speichern Sie die Konfiguration zunächst auf dem PC
mit dem Menü Datei > Speichern und übertragen Sie
diese anschließend auf das Interface mit Online >
Download.

Überprüfen Sie die Kommunikation mit Online >
Debugmodus starten. Alle Linien zu den Slave Gerä-
ten müssen grün dargestellt werden. Wenn nicht,
machen Sie einen Doppelklick auf die Geräte mit roten
Linien und überprüfen Sie zunächst die Diagnosebits im
Diagnose-Fenster. 
Sie zeigen Fehler grundsätzlicher Natur, wie zum Bei-
spiel Keine Antwort oder Konfigurationsfehler. 

Configuration of
AS-Interface Network
AS-Interface Master:

In the System Configurator select the bus system with
File > New > AS-Interface. Select the used Master with
Insert > Master.

Insert the Slaves used at the AS-Interface network into
the configuration at channel 1 respectively at channel 2
by selecting the Slave profile with Insert > Slave and
assign their Address.

Double click on the slaves icons and configure the diffe-
rent devices. Thereby the extended ID1 and ID2 code
as well as parameter data have to be set. The addres-
ses in the process image are automatically assigned by
SyCon if Autoadressing is on, otherwise the addres-
ses must be entered manually.

Assign in Settings > Device Assignment via which dri-
ver the System Configurator will communicate to the
CIF. 
Save the configuration at the PC with the menu item
File > Save and afterwards transfer it into the interface
with Online > Download.

Check the communication with Online > Start Debug-
mode. All lines to the slave devices must be displayed
in green color. If not, double click the red colored ones
and check the diagnostic bits in the diagnostic window.

These bits indicate basic communication errors, like No
response or Configuration fault. 



25

Zusätzlich liefert das Diagnosefenster detaillierte Fehle-
rinformationen im Klartext, wenn das Gerät im Netzwerk
gefunden werden konnte, aber dennoch ein prinzipieller
Fehler vorliegt, der den Betrieb nicht zulässt. Dies
könnte beispielsweise ein falscher EA- oder falsche ID-
Codes (ID, ID1, ID2) sein.
Prüfen Sie mit Online > Live List > Kanal 1 / Kanal 2,
welche AS-Interface Slaves erkannt werden. 

Alternativ kann das AS-Interface-Netzwerk auch einge-
lesen werden. Dazu fügen Sie in eine leere Konfigura-
tion mit Einfügen > Master den verwendeten Master
ein.

Stellen Sie mit Einstellungen > Gerätezuordnung ein,
über welchen Treiber der Systemkonfigurator mit dem
CIF kommunizieren kann. Übertragen sie die Konfigura-
tion auf das Interface mit Online > Download.

Danach kann die AS-Interface-Netzwerkstruktur einge-
lesen werden. Das AS-Interface Master-Gerät bietet
hierfür die Funktion Online > Netzwerkstruktur 
einlesen > Kanal 1 / Kanal 2, um eines der ange-
schlossenen AS-Interface Netzwerke einzulesen.

Speichern Sie die Konfiguration zunächst auf dem PC
mit dem Menü Datei >  Speichern und übertragen Sie
diese anschließend auf das Communication Interface
mit Online > Download. 

Futhermore you will find some detailed error information
in the window, if the slave could be found in the net-
work, but principle errors prohibit the process data
exchange. Such an error could be a wrong configured
IO- or wrong ID-Codes (ID, ID1, ID2), for example.

Check with Online > Live List > Channel 1 / Channel
2 if the AS-Interface Slave is present on the network. 

Alternatively the AS-Interface network can also be scan-
ned. Therefore insert the used Master in an empty con-
figuration with Insert > Master.

With Settings > Device Assignment set via which dri-
ver the System Configurator can communicate with the
CIF. Transfer the configuration into the interface with 
Online > Download.

After that the AS-Interface network structure can be
scanned. Therefor the AS-Interface Master device pro-
vides the function Online > Automatic Network Scan
> Channel 1 / Channel 2 in order to read the current
network structure.

Save the configuration at the PC with the menu item
File > Save and afterwards transfer it into the communi-
cation interface with Online > Download. 



26

Fehlersuche
Dual-Port Memory 
– Prüfen Sie, dass der von dem CIF benutzte Speicher-

bereich im BIOS auf Shadow RAM disable einge-
stellt ist.

– Prüfen Sie, ob die Adresseinstellung der ISA- und
PC/104-Karten mit der Einstellung im CIF Device
Driver Setup übereinstimmt.

– Prüfen Sie, dass die eingestellte Dual-Port Memory
Größe im CIF Device Driver Setup der tatsächlichen
Größe entspricht. 

– Prüfen Sie, dass kein Adresskonflikt mit anderen PC-
Komponenten (z.B. SCSI-Controller) vorliegt.

– Weitere Hinweise finden Sie auf der CD in
\FAQ\DEUTSCH\ISA\ bzw. PCI. 

Kabel 
– Prüfen Sie, dass die Pinbelegung des verwendeten

Kabels richtig ist.
– Prüfen Sie, ob das verwendete Netzteil der AS-Inter-

face Spezifikation entspricht und dass alle Slaves
richtig mit dem Kabel verbunden sind (erkennbar z.B.
an der Power Status-LED am Slave-Gerät).

Troubleshooting
Dual-port Memory
– Check if the memory area used by the CIF is set to

Shadow RAM disable in the BIOS. 
– Check if the address setting on an ISA- and PC/104

cards matchs with the setting in the CIF Device Dri-
ver Setup.

– Check that the Dual-Port Memory size in the CIF
Device Driver Setup is the same as the real size.

– Check that there is no address conflict with another
PC component (e.g. SCSI controller). 

– More information are on the CD in
\FAQ\ENGLISH\ISA\ or PCI. 

Cable 
– Check that the pin occupation of the used cable is

correct 
– Verify that the power supply conforms to the AS-Inter-

face specification requirements. Make sure that all
slave devices have a proper connection to the AS-
Interface cable (see power indicator on the slave
device, for instance). 
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Diagnose mit dem Systemkonfigurator
– Prüfen Sie mit Online > Globales Statusfeld, ob ein

ASi Spannungsversorgungsdefekt vorliegt.
– Stellen Sie mit Online > Live List > Kanal 1 bzw.

Kanal 2 fest, welche Geräte am Bus erkannt werden
und ob diese den Konfigurationsvorgaben entspre-
chen. Ein einfacher Klick auf die Adresse des Slaves
innerhalb der Live Liste öffnet ein Fenster mit dem
tatsächlichen von Slave übertragenen EA-/ID-Codes
(ID, ID1, ID2-Code).

– Prüfen Sie, ob in den Busparametern für den Kanal 1
bzw. Kanal 2 Autostart angehakt ist, wenn der AS-
Interface Master automatisch in den Datenaustausch
gehen soll.

– Ermitteln Sie mit Online > Debugmode starten, zu
welchen Geräten ein Nutzdatenaustausch stattfindet
(grün dargestellte Linie zum Slave Icon).

– Lassen Sie sich mit Online > Gerätediagnose wei-
tergehende Information zu dem ausgewählten Gerät
anzeigen.

– Falls der Slave einen Konfigurationsfehler meldet,
überprüfen Sie mit Online > Netzwerkstruktur ein-
lesen > Kanal 1 bzw. Kanal 2 die aktuelle Netzwerk-
konfiguration und vergleichen Sie, ob diese mit der
im Systemkonfigurator angezeigten übereinstimmt. 

– Stellen Sie sicher, dass keine doppelten Adressen an
Slaves eines Kanals vergeben wurden. Beachten
Sie, dass Slaves, die fabrikneu an ein Netzwerk
angeschlossen werden, immer die Adresse 0 (Null)
haben. Um dem Slave eine von 0 (Null) verschiedene
Adresse zu zuweisen, wählen Sie Online > 
Geräteadresse ändern und setzen Sie diese auf die
geforderte Adresse.

– Verwenden Sie Online > E/A-Monitor, um die Über-
tragung von Ein- und Ausgangsdaten zu testen.
Berücksichtigen Sie, dass nur aktivierte Slaves in
den Datenaustausch einbezogen werden. 

Diagnostic using the System Configurator
– Check with Online > Global State Field, if an ASi

power fail exists.
– Observe devices which are identified at the network

by the Master using Online > Live List > Channel 1
respectively Channel 2 and check if they match the
configuration. Click at the slave address within the
Live List to bring up a window with the actual IO-/ID-
Codes transferred from the real slave device (ID, ID1,
ID2-Code).

– Check, whether Auto start is selected for channel 1
respectively channel 2 in the busparameters, if the
Master should go into data exchange automatically.

– Inquire devices which are included in the process
data exchange using Online > Start Debug Mode
(displayed with a green line to the Slave icon).

– Display further information concerning the specified
slave using Online > Device Diagnostics. 

– If a slave reports a configuration error check the cur-
rent network configuration using Online > Automatic
Network Scan > Channel 1 respectively Channel 2,
and compare the result with the real network structu-
re. 

– Make sure that there are no double addresses assig-
ned to slave devices on one channel. Note that the
factory address settings for a new slave always have
the address 0 (zero). To set a slave's address that
differs form 0 (zero) use the menu item Online > Set
Device Address and chose the required Slave
address.

– Use Online > IO-Monitor in order to test the transfer
of the process data. Note that only activated slaves
are included into data exchange.
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LED Zustand / State Bedeutung / Meaning

RDY Ein / On Gerät ist bereit / Device is ready
gelb / Blinkt zyklisch mit 5 Hz / Firmware-Download wird durchgeführt / 
yellow Flashing cyclic at 5 Hz Firmware download is in progress

Blinkt zyklisch mit 1 Hz / Gerät ist in Bootstraploadermodus und wartet auf Firmware-Download / 
Flashing cyclic at 1 Hz Device is in bootloader mode and is waiting for firmware download
Blinkt unregelmäßig (*) / Hardware- oder schwerer Systemfehler erkannt / 
Flashing irregular (*) Hardware or heavy runtime error detected
Aus / Off Versorgungsspannung für das Gerät fehlt oder Hardwaredefekt /

Device has no power supply or hardware defect
RUN Ein / On Kommunikation läuft, das Gerät hat mindestens eine Verbindung zu
grün / einem konfigurierten Teilnehmer aufgebaut / Communication is running,
green the device has established at least one configured fieldbus connection

Blinkt zyklisch mit 5 Hz / Kein Fehler in der Konfiguration, Kommunikation gestoppt oder bereit 
Flashing cyclic at 5 Hz für Kommunikation, aber keine Verbindung zu einem Slave /

No error in configuration found, communication is stopped or ready 
for communication but no connection to any Slave

Blinkt unregelmäßig (*) / Anlauf: Fehlende oder fehlerhafte Konfiguration, Inbetriebnahme nötig,
Flashing irregular (*) Laufzeit: Host Watchdog Zeitfehler / Power Up: Configuration missing or 

faulty, device needs commissioning, Runtime: Host Watchdog timeout
Aus / Off Keine Kommunikation / No Communication

CH1 / Ein grün / On green Konfiguration fehlerfrei, Datenaustausch aktiv /
CH2 No configuration error, data exchange active
grün/rot Blinkt grün / Konfigurationsfehler, Datenaustausch aktiv /
green/red Flashing green Configuration error, data exchange active

Blinkt grün und rot / Projektierungsmodus aktiv / Project mode active
Flashing green and red
Blinkt rot / Flashing red AS-Interface Power Fail / AS-Interface power fail
Ein rot / On red Schwerer System- bzw. Hardwarefehler / 

Heavy System error or hardware failure
Aus / Off Keine Konfiguration für diesen Kanal gefunden /

No configuration found for this channel

LED-Anzeigen LED Displays

G

RG

R

R

G

(*) 3 mal schnell mit 5 Hz, 8 mal zwischen 0,5 Hz und 
1 Hz

(*) 3 times fast at 5 Hz, 8 times between 0,5 Hz and 
1 Hz



AS-Interface Master Slaves / Slaves max. 62 je Kanal / per channel
Eingänge / Input max. 4 Bits pro Slave / per Slave
Ausgänge / Output max. 4 Bits pro Slave A / per Slave A

max. 3 Bits pro Slave B / per Slave B
Die Analogwerte (16 Bit je Wert) der Slaveprofile 7.3.y und 7.4.y werden 
vom AS-Interface Master gemultiplext /
The analog values (16 bits for each value) of the Slave profiles 7.3.y and 
7.4.y are multiplexed by the AS-Interface Master

Prozessabbild / Process Image AS-Interface Master max. 465 Bits pro Kanal / per channel
Prozessor / Processor EC1
Speicher CIF 30-ASM 2 KB DPM, 512 KB FLASH, 128 KB RAM
Memory CIF 50-ASM 8 KB DPM, 512 KB FLASH, 128 KB RAM

CIF 104-ASM 2 (8)KB DPM, 512 KB FLASH, 128 KB RAM
(einstellbar über J3 / adjustable via J3)

Master ASIC EC1
AS-Interface Schnittstelle 2 x COMBICON 2-polig, gemäß IEC 62026-2 / EN 50295, 167 kBaud, 
AS-Interface Interface potentialfrei / 2 x COMBICON 2 pin, according IEC 62026-2 / EN 50295, 

167 kBaud, isolated
Diagnoseschnittstelle DSub-Stecker 9-polig, RS-232C, 9600 Baud, potentialgebunden / 
Diagnostic Interface DSub male connector 9 pin, RS-232C, 9600 Baud, non isolated
Betriebsspannung CIF 30-ASM +5 V ±5% / 550 mA, ±12 V ±5% / 50 mA
Power Supply CIF 50-ASM +3,3 V ±5% / 410 mA, +5 V ±5% / 280 mA,

±12 V ±5% / 50 mA
CIF 104-ASM +5 V ±5% / 550 mA

Betriebstemp. / Operating Temp. 0 ... 55 °C
Maße (L x B x H) CIF 30-ASM 134 x 107 x 20 mm ISA
Dimensions (L x W x H) CIF 50-ASM 134 x 107 x 20 mm PCI

CIF 104-ASM 90 x 96 x 25 mm PC/104
CE Zeichen CE-Zeichen EN 61000-6-4 für Emission / for emission
CE Indication EN 61000-6-2 für Störfestigkeit / for noise immunity
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Haftungsausschluss
Der Inhalt dieses Manuals wurde auf Übereinstimmung
mit der beschriebenen Hard- und Software geprüft.
Dennoch können Abweichungen nicht ausgeschlossen
werden, so dass wir für die vollständige Übereinstim-
mung keine Gewähr übernehmen. Die Angaben in die-
sem Manual werden jedoch regelmäßig überprüft. Not-
wendige Korrekturen sind in den nachfolgenden
Auflagen enthalten. Für Verbesserungsvorschläge sind
wir dankbar.

Exemption from Liability
The contents of this manual were checked for agreement
with the described hardware and software. However,
deviations may occur so that no guarantee can be made
for complete agreement with the documentation. Howe-
ver, the information in this manual is controlled regular-
ly. Necessary corrections are contained in the following
editions. We are grateful for improvement suggestions.
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Headquarter
Hilscher Gesellschaft für Systemautomation mbH
Rheinstrasse 15 
D-65795 Hattersheim
Telefon: +49 (0) 6190 / 9907-0
Telefax: +49 (0) 6190 / 9907-50
E-Mail: info@hilscher.com
Homepage: www.hilscher.com

Weltweit: Distributoren
Besuchen Sie dazu unsere Homepage unter
www.hilscher.com

World-wide: Distributors
Please visit our homepage on
www.hilscher.com 

Subsidiary
North America
Hilscher North America, Inc.
4320 Winfield Road, Suite 200
Warrenville, Illinois 60555, USA
Phone: +1 / 630.836.8677
Fax: +1 / 630.836.8010
E-Mail: info@hilscher.us
Homepage: www.hilscher.com

France
Hilscher France s.a.r.l.
12 rue de 35ième Régiment d’Aviation
Miniparc du Chêne, F-69500 Bron
Phone:  +33 (0) 472379840
Telefax: +33 (0) 478268327
E-Mail: info@hilscher.fr
Homepage: www.hilscher.com

Italy
Hilscher Italia s.r.l.
Via Grandi, 25
I-20090 Vimodrone (MI)
Phone: +39 / 0225007068 
Telefax: +39 / 0225029973 
E-Mail: info@hilscher.it
Homepage: www.hilscher.com

Switzerland
Hilscher Swiss GmbH
Hubelmattstrasse 29 
CH-4500 Solothurn
Phone:  +41 (0) 326236633
Telefax: +41 (0) 326236632
E-Mail: info@hilscher.ch
Homepage: www.hilscher.com



Bei weiteren Fragen wenden Sie sich

bitte an Ihren lokalen Distributor

oder an unseren techischen Support:

If you have any question please

contact your local distributor or 

our technical support:

Tel.: +49 (0) 6190 / 9907-99 
E-Mail: hotline@hilscher.com

Please notice: 
Windows 95/98/ME and Windows NT/2000/CE/XP are 
registered trademarks of Microsoft Corporation.

AS-Interface System Software
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