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List of Revisions

Index Date Version Chapter Revision
1 06.06.02 SyCon.exe 2.643

NetNode.dll 2.010
all created

NetNode (Conversion Ethernet to serial Protocols, NN40,
NN42)
NetLink (NL-MPI)

2 25.06.02 SyCon.exe 2.643
NetNode.dll 2.010

all revised

Although this program has been developed with great care and intensively
tested, Hilscher Gesellschaft für Systemautomation mbH cannot guarantee
the suitability of this program for any purpose not confirmed by us in writing.
Guarantee claims shall be limited to the right to require rectification. Liability
for any damages which may have arisen from the use of this program or its
documentation shall be limited to cases of intent.
We reserve the right to modify our products and their specifications at any
time in as far as this contributes to technical progress. The version of the
manual supplied with the program applies.
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1 Overview SyCon
1.1 Main Functions

The main functions of the NetDevices System Configurator are:
Function Section Short Description

Configuration Overview Overview about possible protocol
conversions and description of
configuration steps

Diagnostic Diagnostic Functions Extended Device Diagnostic,
Message Monitor

Project Information Set the project informationDocumentation
Print Print out the configuration

Table 1: SyCon Main Functions

1.2 SyConND
SyConND is a System Configurator for NetDevices. To NetDevices belong
NetNode 40, NetNode 42 and NetLink MPI.
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2 Installation and Licensing
2.1 System Requirements

•  PC with 586-, Pentium processor or higher

•  Windows 95/98/ME, Windows NT/2000/XP

•  Free disk space: 30 - 80 MByte

•  CD ROM drive

•  RAM: min. 16 MByte

•  Graphic resolution: min. 800 x 600 pixel

•  Windows 95: Service Pack 1 or higher

•  Windows NT: Service Pack 3 or higher

•  Keyboard and Mouse
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2.2 Software Installation
Close all application programs on the system!
Insert the Hilscher NetDevices CD in the local CD ROM drive. The
installation program starts by itself (Autostart enabled). Otherwise change
into the root directory on the CD and start Autorun.exe (Autostart disabled).

Note: Administrator privileges are required on Windows NT/2000/XP
systems for installation!

The installation program asks for the components you want to install.
Answer these questions with Yes or No.

Figure 1: Selection for the Installation of the System Configurator and iCon-L in basic
version

Note: iCon-L is only for NetNode 40 and NetNode 42, but not for NetLink.
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Figure 2: Selection for the Installation of the Programs SyCon and the licensed iCon-L
version

It can be installed:

•  System Configurator SyCon (Configuration and diagnostic tool)

•  iCon-L (graphical programming system with module library and
diagnostic tool)

If you have a license code or it is print on the label of the CD, then answer
the question for an existing license code with yes, otherwise a basic
version of iCon-L will be installed.

Note: For SyCon no license is needed, because the basic version includes
all functions for operating the NetDevices.
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2.3 Installation of the SyCon and iCon-L
During the installation of the licensed version of iCon-L you have to insert
your Name and your Company Name during installation.
If you have a license code or it is labeled on the CD, it must also be entered
now. Otherwise iCon-L will work as a basic version.
In the basic version of the System Configurator all functions of SyCon for
operating the NetDevices are available.
In the basic version of iCon-L you have the possibility to load projects and
download it to the NetNode. In this version you also can do diagnostic. In
the licensed version you have the same possibilities and in addition to this
you can create own projects with up to 100 blocks and do project
engineering.
Follow the instructions of the installation program and answer the questions
with OK or NEXT.

A license code for iCon-L can be ordered also subsequently by filling out
the order form under the menu item Help > Licensing and fax this order
form either to the distributor or directly to us.

Figure 3: Enter the Name, the Company Name and the license code

Note: The license code 0123456789ABCDEF is no valid code and is only
used for explanation.

It is necessary to fill in the Name and the Company Name. It is optional to
fill in the Address, the City, State, Zip and Country.
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The installation program offers the following selections:

Figure 4: Selection of the destination directory and the NetDevices during installation

The installation program copies the program files and Bitmaps to the PC.
Finally the system DLLs and the application are entered into the Registry.

2.4 Licensing
This section describes the steps to license iCon-L from the already installed
basic version of this program. The licensing during installation was already
described above.
Deliveries that contain a license for the module library iCon-L have a
formula with. Fill out this paper (formulary) and fax it to your distributor or
directly to us. After you receive the license code enter it as described in
section Enter the Licensecode below on page 15.
An order form for a license for iCon-L can be printed out with the System
Configurator and is described in the next section.
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2.4.1 Ordering a License for iCon-L
This section describes how to act by iCon-L starting from the already
installed basic version of this program. The licensing during installation was
already described above.
To order the license code iCon-L select the menu Help > Licensing. The
licensing window is opened.
Fill in your name, the company name and the address for license
information into the fields.
To order a license code iCon-L select the iCon-L module by clicking on it.
There are three tables to do this. The first table list the modules, that are
not licensed. Doubleclick or select a module and click the Add button to
move them into the table in the middle that are printed on the order form
later.
The modules, which are already licensed, are shown in the last table.

Figure 5: Selection of the Module iCon-L

After selecting the modules select the button Print Order Form and send
us this paper by fax or by mail.
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2.4.2 Enter the Licensecode
Check if the name and the company name was entered exactly as printed
on the fax.

Note: Observe that the spelling is the same as on the fax, especially the
small and capital letters.

Then select the button Enter License Code. The following windows
appears. Enter the 16 digits of the license code.

Figure 6: Enter the Licence Code

Note: The license code 0123456789ABCDEF showed above is an invalid
license code and is only used for explanation.

After you have entered the license code select the button OK. The code is
verified. If the license code is valid SyCon will ask you to exit and restart
the System Configurator to activate the license. If the license code is invalid
the following window appears.

Figure 7: Note license code invalid

In this case check:

•  the license code with the information on the fax

•  the right spelling of the name and the company name with the
information on the fax. Check especially for small and capital letters.
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2.5 Scope of Functions

2.5.1 Scope of Functions of the Basic Versions
The basic version of the System Configurator SyCon has the following
functionality:

•  Full functionality for operating the NetDevices (both NetLink and
NetNode)

•  All diagnostic functions

The basic version of iCon-L contains:

•  In the basic version existing projects can be opened, parameter of the
modules can be changed and it can be sent to the NetNode

•  The diagnostic functions for existing projects are available

•  Modules can not be deleted or added!

2.5.2 Scope of Functions of the licensed iCon-L Version
The licensed version of the iCon-L has the following functionality:

•  Projects with up to 100 blocks can be created

•  It is possible to create new and to open existing projects, the
parameters of modules can be changed and loaded into the NetNode

•  Diagnostic functions

•  Blocks can be deleted or added
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3 Configuration Steps - Getting Started
3.1 Overview Protocol Conversions

Select from the following table the device you want to use. The
configuration steps are described in the given section.

Note: The booklet with the CD ROM contains information for the hardware
installation and information to the cable. At this point it is presupposed that
the hardware installation was already done.

There are two different kinds of NetDevices:
Device Page

NetLink 17
NetNode 17

Table 2: Overview NetDevices

3.1.1 NetLink
Device Ethernet Protocol Described in section Page

NetLink Hilscher TCP/IP PROFIBUS MPI Configuration NetLink MPI 18

Table 3: Overview NetLink Communication

3.1.2 NetNode
Device Ethernet Protocol Described in section Page

Ethernet 3946R / RK512 Configuration of NetNode 40/42 with Ethernet /
3946R/RK512 Conversion

19

Ethernet ASCII Configuration of NetNode 40/42 with Ethernet /
ASCII Conversion

20

Ethernet Modbus RTU Configuration of NetNode 40/42 with Ethernet /
Modbus RTU Conversion

21

NetNode 40/42

Ethernet + FTP ASCII Configuration of NetNode 40/42 with
Ethernet+FTP / ASCII Conversion

22

Table 4: Overview Protocol Conversions NetNode
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3.2 Configuration NetLink

3.2.1 Configuration NetLink MPI
The following table describes the steps to configure a Hilscher NetLink MPI
device.

# Action Menu in the System Configurator Detail information in section Page
1 Create a new project File > New > NetDevices Setting up the NetDevices

Configuration
23

2 Choose Hilscher NetLink
device

Insert > Device > NetLink Insert Device 24

3 Set Device Assignment Settings > Device Assignment > CIF
TCP/UDP IP Driver

CIF TCP/IP Driver 30

4 Set Protocol Parameter Settings > NetLink Parameter Device Parameter 35
IP Address 36
PROFIBUS Parameter 39

5 Save project File > Save Save and Save As 69

6 Download Online > Download Downloading the
Configuration

57

Table 5: Configuration NetLink MPI
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3.3 Configuration NetNode

3.3.1 Configuration of NetNode 40/42 with Ethernet / 3946R/RK512
Conversion

In the following table the steps to configure a Hilscher NetNode device with
the conversion from Ethernet to 3946R / RK512 are described.

# Action Menu in the System Configurator Detail information in section Page
1 Create a new project File > New > NetDevices Setting up the NetDevices

Configuration
23

2 Choose Hilscher NetNode
device

Insert > Device > NetNode 40
or
Insert > Device > NetNode 42

Insert Device 24

3 Select Protocol Conversion Protocol 1: Ethernet
Protocol 2: 3946R / RK512

Select NetNode Protocol
Conversion

25

4 Set Protocol Parameter Settings > NetNode Parameter Device Parameter 35
IP Address 36
TCP Parameter 38
3964R / RK512 Parameter 42

5 Set Device Assignment Settings > Device Assignment Device Assignment 27

6 Save project File > Save Save and Save As 69

7 Download Online > Download Downloading the
Configuration

57

Table 6: Configuration of NetNode 40/42 with Ethernet / 3946R/RK512 Conversion
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3.3.2 Configuration of NetNode 40/42 with Ethernet / ASCII
Conversion

In the following table the steps to configure a Hilscher NetNode device with
the conversion from Ethernet to ASCII are described.

# Action Menu in the System Configurator Detail information in section Page
1 Create a new project File > New > NetDevices Setting up the NetDevices

Configuration
23

2 Choose Hilscher NetNode
device

Insert > Device > NetNode 40
or
Insert > Device > NetNode 42

Insert Device 24

3 Select Protocol Conversion Protocol 1: Ethernet
Protocol 2: ASCII

Select NetNode Protocol
Conversion

25

4 Set Protocol Parameter Settings > NetNode Parameter Device Parameter 35
IP Address 36
TCP Parameter 38
ASCII Parameter 44

5 Set Device Assignment Settings > Device Assignment Device Assignment 27
6 Save project File > Save Save and Save As 69

7 Download Online > Download Downloading the
Configuration

57

Table 7: Configuration of NetNode 40/42 with Ethernet / ASCII Conversion
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3.3.3 Configuration of NetNode 40/42 with Ethernet / Modbus RTU
Conversion

In the following table the steps to configure a Hilscher NetNode device with
the conversion from Ethernet to Modbus RTU are described.

# Action Menu in the System Configurator Detail information in section Page
1 Create a new project File > New > NetDevices Setting up the NetDevices

Configuration
23

2 Choose Hilscher NetNode
device

Insert > Device > NetNode 40
or
Insert > Device > NetNode 42

Insert Device 24

3 Select Protocol Conversion Protocol 1: Ethernet
Protocol 2: Modbus RTU

Select NetNode Protocol
Conversion

25

4 Set Protocol Parameter Settings > NetNode Parameter Device Parameter 35
IP Address 36
TCP Parameter 38
Modbus RTU Parameter 49

5 Set Device Assignment Settings > Device Assignment Device Assignment 27
6 Save project File > Save Save and Save As 69

7 Download Online > Download Downloading the
Configuration

57

Table 8: Configuration of NetNode 40/42 with Ethernet / Modbus RTU Conversion
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3.3.4 Configuration of NetNode 40/42 with Ethernet+FTP / ASCII
Conversion

In the following table the steps to configure a Hilscher NetNode device with
the conversion from Ethernet + FTP to ASCII are described.

# Action Menu in the System Configurator Detail information in section Page
1 Create a new project File > New > NetDevices Setting up the NetDevices

Configuration
23

2 Choose Hilscher NetNode
device

Insert > Device > NetNode 40
or
Insert > Device > NetNode 42

Insert Device 24

3 Select Protocol Conversion Protocol 1: Ethernet + FTP
Protocol 2: ASCII

Select NetNode Protocol
Conversion

25

4 Set Protocol Parameter Settings > NetNode Parameter Device Parameter 35
IP Address 36
TCP Parameter 38
ASCII Parameter 44

5 Set Device Assignment Settings > Device Assignment Device Assignment 27
6 Save project File > Save Save and Save As 69

7 Download Online > Download Downloading the
Configuration

57

Table 9: Configuration of NetNode 40/42 with Ethernet+FTP / ASCII Conversion

Note: In case of Ethernet + FTP / ASCII conversion maximal two serial
interfaces can be used.
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4 Configuration of NetDevices with SyCon
4.1 Setting up the NetDevices Configuration

To create a new configuration, choose the File > New menu. This will offer
a selection list of fieldbus systems. Choose the NetDevices. If only the
NetDevices was installed, then the configuration window will open directly.
The name of the configuration file can be allocated when the configuration
is finished or with File > Save As.
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4.2 Insert Device
In order to insert a NetDevice into the configuration, choose the Insert >
Device menu, in order to open the selection window, or click on the
symbol:
Insert > Device

Figure 8: Symbol Insert > Device

A dialog box opens, from which exactly one device can be selected.

Figure 9: Insert > Device

In this window you select the device you want by clicking on it in the list
Available Devices and then click the Add button or make a double click on
the device to put the device to the list Selected Devices. With OK you
confirm the selection.
This example shows a Net Node40 device that is inserted with the
Description NetNode. The shown description depends on the insert
device and can be changed the user.
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4.2.1 Select NetNode Protocol Conversion

Note: This dialogue appears only, if a NetNode device is inserted into the
configuration. In case of a NetLink this setting has not to be made.

After the selection of the NetNode device was confirmed by clicking at the
OK button a new window appears where you have to select the protocol for
this device.

Figure 10: Select NetNode Protocol (here ASCII)

Here you see the possible protocol conversions:
Protocol 1 Protocol 2 Firmware

Ethernet 3946R / RK512 NNENNVR
Ethernet ASCII NNENASC
Ethernet Modbus RTU NNENMBR
Ethernet + FTP ASCII NNFTPASC

Table 10: Possible Protocol Conversions for NetNode Configuration

If you have selected a protocol and you confirm your selection by clicking
on the OK button the NetNode will be insert with this protocol.
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4.2.2 Replace Device
If a device already exists in the configuration and should be replaced
against another device, you have to choose the menu Insert > Device or
select the "Insert Device" Symbol.
The question appears if the device should be replaced.

Figure 11: Security question replace device

If you click the Yes button a new window opens, where you can replace the
device against another one.

Figure 12: Edit > Replace Device

In this window you select the device you want by clicking on it in the list
Available devices. By clicking the Add button you put the device in the list
Selected devices. With OK you confirm the selection and the device will
be replaced.

Note: If the previous device is replaced by a NetNode, you also have to
select the protocol conversion, like descriped in section Select NetNode
Protocol Conversion on page 25.
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5 Settings
5.1 Device Assignment

The Device Assignment setting determines how the System Configurator
communicates with the device. This is set in the device assignment via the
menu Settings > Device Assignment. The following possibilities are
available:
CIF Serial Driver CIF TCP/IP Driver

CIF Serial Driver:
•  CIF Serial Driver: The System Configurator communicates with the

NetNode over a serial connection. In this case, a COM port of the PC
must be connected via a diagnostic cable with the diagnostic interface
of the NetNode.

•  This communication is utilized when the System Configurator has
access the device over the diagnostic interface of the Hilscher device.

CIF TCP/IP Driver:
•  CIF TCP/IP Driver: The System Configurator communicates with the

Hilscher device via a TCP/IP connection.
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5.1.1 CIF Serial Driver
The serial driver supports COM1 to COM 4, in order to communicate via the
diagnostic interface with the device.
The Serial Driver is selected via Settings > Device Assignment.

Figure 13: Driver Selection - CIF Serial Driver

Choose the CIF Serial Driver and then OK, in order to select the CIF Serial
Driver.
The connection must first be established using the button Connect COM1
or Connect COM2 or Connect COM3 or Connect COM4. They can be
used depending on which COM ports are installed and free on the PC.
The System Configurator sends a request to the corresponding COM port
and polls the Firmware name of the device. A display of the Firmware will
indicate when a device is connected. In the other case, a Timeout error
(-51) appears, which will state that no device is connected.
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Figure 14: CIF Serial Driver - Device Assignment

The error number –20 indicates that this COM interface is not available or
free.
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5.1.2 CIF TCP/IP Driver
The TCP/IP driver connects up to four devices that can be accessed over a
TCP/IP connection.
The TCP/IP driver is chosen via Settings > Device Assignment.

Figure 15: Driver Selection - CIF TCP/IP Driver

In order to select the CIF TCP/IP driver, choose CIF TCP/IP Driver and
then OK.

Figure 16: CIF TCP/IP Driver > Device Assignment
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5.1.2.1 NetIdent Configuration
With the button NetIdent Configuration you can look for existing
NetDevices in the network. A new window appears:

Figure 17: NetIdent Configuration

By clicking the Start Poll button the network is scanned for NetDevices.

Figure 18: NetIdent Configuration > Start Poll

If one or more devices were found, they are shown with their MAC
Address. Further more the device Type, the Serial Number and the IP
Address are displayed.

Caution: To find devices with NetIdent and to set their IP Address, the
devices have to be in the same network as the used PC.
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If you type in the found IP Address of the required device and confirm by
clicking the Connect to Server button, the device appears in the Board
Selection if the Connection was successfull. If the name agrees with
device in the configuration, now the device can be selected.

Figure 19: CIF TCP/IP Driver - Device Assignment

By confirming with the OK button, the device is assigned to the Device
Assignment via TCP/IP.
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5.2 Device Settings

Note: The device settings are only valid for NetNode devices. If a NetLink
configuration is loaded, this menu point is not shown.

To enter the Device Settings, choose the menu Settings > Device
Settings or click with the right mouse button on the device and select the
Device Settings from the list that opens.

The Device Settings contain parameters that determine the behaviour of
the device as well as the user interface. These settings are only valid for
Hilscher devices and are included in the download of the configuration.

Figure 20: Settings > Device Settings

•  Handshake of the process data
These various types are used for setting the handshake of the
process data for the Master. The choice of used type is important for
the correct data exchange between the application program and the
device.
The used handshake of the process data needs to be supported by
the application program. Mostly the buffered, host controlled
handshake is supported. The setting no consistence, uncontrolled
works without handshake and the processes run free.

•  Configuration Mode
If the device is to use the parameters of the configuration that is
downloaded from SyCon then the Configuration by SyCon mode
must be selected for the configuration mode. If the configuration is
written online from an application into the Dual-port memory, then the
Configuration by Application mode must be selected.
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•  User program monitoring
The Watchdog time determines how long the device waits for a
triggering of the software watchdog by the application program until it
sets the outputs of the Slave devices to zero. This behaviour must be
activated by the user program and does not start automatically.

•  Startup behaviour after system initialisation
When Automatic release of the communication by the device has
been set, the Master device starts with the data exchange at the Bus
after the initializing has been finished. When Controlled release of
communication by the application program has been set, the
application program has to activate the data exchange at the Bus.
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5.3 Device Parameter
The Device Parameter are the basis for the working data exchange. This
section contains information for setting the Device Parameter and a
description for the individual protocol- and busparameter.
NetLink NetNode

The NetLink device parameters can be
called up with the menu Settings > NetLink
Parameter, if a NetLink configuration is
loaded.

The NetNode device parameters can be
called up with the menu Settings >
NetNode Parameter, if a NetNode
configuration is loaded. The displayed
parameter depend on the protocols which
where selected for the protocol conversion.

Table 11: Settings > Parameter

The settings of the individual parameter is described in the section given
below.
Parameter NetLink NetNode Described in section Page

IP-Address Yes Yes IP Address 36
Ethernet Yes Yes Ethernet Parameter 37

TCP No Yes TCP Parameter 38

PROFIBUS Yes No PROFIBUS Parameter 39
3946R / RK512 No Yes 3964R / RK512 Parameter 42

ASCII No Yes ASCII Parameter 44

Modbus RTU No Yes Modbus RTU Parameter 49

Table 12: Settings of Device Parameter
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5.3.1 IP Address

Figure 21: Settings > NetLink / NetNode Parameter > IP Address

Description:
The description of the device is shown in SyCon as the name of the device.
The description is changeable in this field.
The handing over of the IP parameters (IP address, Net mask, Gateway)
can result in three ways.
1. DHCP:
The device gets the IP parameters from a DHCP server.
2. BOOTP:
The device gets the IP parameters from a BOOTP server.
3. IP address, Net mask and Gateway:
The IP parameters can be entered in this fields. If more than one
configuration way is activated (for example DHCP and manually entered IP
parameters), the device trys to process the different configuration way one
after the other. As soon as it got an IP configuration in one of this ways, the
device starts with this parameters.
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5.3.2 Ethernet Parameter

Figure 22: Settings > NetLink / NetNode Parameter > Ethernet

Description:
The description of the device is shown in SyCon as the name of the device.
The description is changeable in this field.
Auto detect:
If this option is selected an automatic detection of the Ethernet interface
results.
Interface:
Here the manually setting of the Ethernet can be done. The user has the
possibility to select Twisted Pair or AUI but at the moment just Twisted
Pair is supported. The description of this you find in section Twisted Pair
and AUI at page 98.
Auto negotation:
Auto negotation means, that in case of two connected devices the devices
detect the hardware and the features (for example Half- or Full Duplex, 10
or 100 Mbits and so on) of the other device. If this option is selected, both
devices work with the performance of the lower-powered device.
Duplex mode:
Here the Duplex mode of the Ethernet interface can be set. You can select
between Full Duplex and Half Duplex but only Half Duplex is supported at
the moment. The description of this you find in section Full Duplex and Half
Dupelx at page 98.
Speed:
Transmission speed of the data in MBits/s. In this window you can select
between 10 MBits/s and 100 MBits/s, but only 10 Mbits/s are supported at
the moment.
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5.3.3 TCP Parameter

Figure 23: Settings > NetNode Parameter > TCP

Description:
The description of the device is shown in SyCon as the name of the device.
The description is changeable in this field.

With the different Communication references 0, 1, 2 and 3 you are able to
set diffent communication kinds which are independend form each other.
By selecting a communication kind the settings for this communication are
loaded and the communication is done this way.
In the field Connection type you can select between unused, Server and
Client. Depending on the selected Connection type the under settings (IP
address, Connect timeout and so on) are grey.
If the Connection type unused is selected all other field are grey because
no connection is selected.
If Server is selected as Connection type the field Port number, Send
timeout and Close timeout are adjustable.
If Client is selected as Connection type all field are adjustable. In the field
IP Address you have to type in the IP of the wanted Client. The field Send
timeout, Connect timeout, Close timeout and Connect retry time are
adjustable in multiple of 100 milliseconds.
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5.3.4 PROFIBUS Parameter

Figure 24: Settings > NetLink Parameter > PROFIBUS

The busparameters and their meaning:

•  Station Address

The Station Address of the NetLink

•  Baudrate

Transmission speed: Number of bits per second.
Baudrate Bit Time (tBit)

9,6 kBaud 104,2 us
19,2 kBaud 52,1 us
93,75 kBaud 10,7 us
187,5 kBaud 5,3 us
500 kBaud 2 us
1,5 Mbaud 666,7 ns
3 Mbaud 333,3 ns
6 Mbaud 166,7 ns
12 Mbaud 83,3 ns

Table 13: Baud rates and Bit times
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•  Minimum Station Delay of Responders (min TSDR)
This is the shortest time period that must elapse before a remote
recipient (Responder) may send an acknowledgement of a received
query telegram. The shortest time period between receipt of the last
Bit of a telegram to the sending of the first Bit of a following telegram.
Value range: 1 .. 65535

•  Maximum Station Delay of Responders (max TSDR)
This is the longest time period that must elapse before a Sender
(Requestor) may send a further query telegram. Greatest time period
between receipt of the last Bit of a telegram to the sending of the first
Bit of a following telegram.
The Sender (Requestor, Master) must wait at least for this time period
after the sending of an unacknowledged telegram (e.g. Broadcast
only) before a new telegram is sent.
Value range: 1 .. 65535

•  Slot Time (TSL)
'Wait for receipt' – monitoring time of the Senders (Requestor) of
telegram for the acknowledgement of the recipient (Responder). After
expiration, a retry occurs in accordance with the value of 'Max.
telegram retries'.
Value range: 52 .. 65535

•  Quiet Time (TQUI)

This is the time delay that occurs for modulators (Modulator-trip time)
and Repeaters (Repeater-switch time) for the change over from
sending to receiving.
Value range: 0 .. 255

•  Setup Time (TSET)

Minimum period “reaction time” between the receipt of an
acknowledgement to the sending of a new query telegram (Reaction)
by the Sender (Requestor).
Value range: 1 .. 255

•  Target Rotation Time (TTR)
Pre-set nominal Token cycling time within the Sender authorization
(Token) will cycle around the ring. How much time the Master still has
available for sending data telegrams to the Slaves is dependent on
the difference between the nominal and the actual token cycling time.
Value range: 1 .. 16.777.215
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•  GAP Update Factor (G)
Factor for determining after how many Token cycles an added
participant is accepted into the Token ring. After expiry of the time
period G*TTR, the Station searches to see whether a further
participant wishes to be accepted into the logical ring.
Value range: 1 .. 100

•  Max number of telegram retries (Max_Retry_Limit)
Maximum number of repeats in order to reach a Station.
Value range: 1 .. 8

•  Highest Station Address (HSA)

Station address of the highest active (Master) Station.
Value range: 2 .. 126
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5.3.5 3964R / RK512 Parameter

Note: If you use a NetNode 40 you have one register card (- 1) to set the
serial interface. If you have load a NetNode 42 in the configuration three
register cards (- 1, - 2, - 3) appear because the NetNode 42 has three serial
interfaces.

If you have set a 3964R / RK512 configuration and you want to set the
3964R / RK512 Parameter select the menu Settings > NetNode
Parameter > 3964R / RK512.

Figure 25: Settings > NetNode Parameter > 3946R / RK512

Description:
The description of the device is shown in SyCon as the name of the device.
The description is changeable in this field.
Interface:
Interface of the device which is served by the protocol. This option can be
activated or deactivated by the user.
Interface type:
Here you can select the interface type. You can select: RS232, RS422 or
RS485.
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RTS control:
The RTS control must be activated (selected) if you use a RS485 interface.
If you use a RS422 or RS232 interface this option is typically deactivated.
Baud rate:
Determination of the transmission rate. You have the possibility the select a
Baud rate between 50 Baud and 19200 Baud. As default setting 9600 Baud
is selected which is used mostly.
Data bits:
Number of data bits. You can select 7 data bits or 8 data bits.
Stop bits:
Number of stop bits: 1 stop bit.
Parity:
Determination of the Parity bit. You can select no, even and odd.
Priority:
Fixes which device is put back the send telegram in case of a initialisation
conflict. The priority can be set to low or high.
Idle time:
Idle time in milliseconds before the start of a telegram repeat. The range of
value is between 0 and 10000.
Receive mode:
Defines the type of the receive data. The following settings can be selected:
word telegram MSB/LSB, word telegram LSB/MSB, byte telegram or
transparent.
Send mode:
Defines how the word telegrams are sent of the line. Either word telegram
MSB/LSB or word telegram LSB/MSB.
Error SCC:
If set/reset is selected in this field, an occurred error during a data transfer
is deleted after a faultless transmission. If set is selected, the error is
shown also after a faultless transmission and it is only deleted if the device
is resetted.
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5.3.6 ASCII Parameter

Note: If you use a NetNode 40 you have one register card (- 1) to set the
serial interface. If you have load a NetNode 42 in the configuration three
register cards (- 1, - 2, - 3) appear because the NetNode 42 has three serial
interfaces.

If you have set an ASCII configuration and you want to set the ASCII
Parameter select the menu Settings > NetNode Parameter > ASCII.

Figure 26: Settings > NetNode Parameter > ASCII

Description:
The description of the device is shown in SyCon as the name of the device.
The description is changeable in this field.
Interface:
Interface of the device which is served by the protocol. This option can be
activated or deactivated by the user.
Interface type:
Here you can select the interface type. You can select: RS232, RS422 or
RS485.
RTS control:
The RTS control must be activated (selected) if you use a RS485 interface.
If you use a RS422 or RS232 interface this option is typically deactivated.
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Baud rate:
Determination of the transmission rate. You have the possibility the select a
Baud rate between 50 Baud and 19200 Baud. As default setting 9600 Baud
is selected which is used mostly.
Data bits:
Number of data bits. You can select 7 data bits or 8 data bits.
Stop bits:
Number of stop bits. 1 stop bit.
Parity:
Determination of the Parity bit. You can select no, even and odd.
Mode:
The protocol works in two different modes: Master and Slave mode.
Master mode: The data transmission is introduced by the ASCII protocol.
Data is sent to the remote partner and the answers are read in and transmit
to the device internal processing.
Slave mode: The remote partner sends a telegram which is received and
passed on by the ASCII protocol. Depending on the application related
design it is already answered at the protocol layer with a positive
acknowledgement and in case of a transmission error with a negative
acknowledgement. After the processing of the telegram a answer telegram
can be hand out to the remote partner.
This modes are selected to avoid initialisation conflicts by simultaneous
sending. This has to be controlled at the protocol layer by the user.
In the Master mode the remote partner is only allowed to answer, if it has
received a telegram before. Just then the ASCII protocol is ready to
received.
In the Slave mode the ASCII protocol is always ready for send and receive.
As a rule the telegram transfer is started by the Master, which waits for an
answer afterwards before it sends the next telegram. In case of
simultaneous receiving of the receive telegram and the transmit job the
receive telegram has priority. The data transmission in this mode can be
realized only from one transmission direction.
During the ASCII protocol sends data it is not ready to receive. Continuous
receiving of data suppresses the send mode. The Master device and the
user respectively is responsible for the synchronisation.
End mode:
The receive direction of the telegram is fixed over the end mode. At the
moment the following end criterions are configurable:
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only time control: As long as the set time control allows this additional
characters can be received. The ending of the time control is not viewed as
an error but as the end of the telegram.
end identifier: The end of a telegram is recognized at the character
'telegram end'. The time control is active corresponding to the set time.
acknowledge telegram: For the sent telegram only the configured
acknowledge telegrams 'ACK telegram' and 'NACK telegram' are expected.
The time control is active corresponding to the set time. Because in the
Slave mode no acknowledge telegrams are defined in the receive direction,
this mode is not allowed here.
end identifier / acknowledge telegram: This setting is the combination of the
both last modes. That means the received data is controlled for a valid
acknowledge telegram and for the telegram end. The control time is active
according to the set time. Because in the Slave mode no acknowledge is
defined, this mode is not allowed.
fixed data count: The end of the receive telegram is fixed by the 'telegram
length device'. The time control is active according to the set time.
pass data count forward: The end of the receive telegram is defined by a
passed forward data count in the send task. This is only possible in the
Master mode.
Checksum mode:
The ASCII protocol is able to calculate the checksum for the telegrams
which have to be send and it can insert the user data by itself. It also can
check the checksum of the received telegrams. For this different processes
of checksum mode and telegram possibilities for the calculation are
configurable:
none: No checksum is determined and the send- and receive telegram get
no checksum.
binary 7 bit: The checksum is formed by a byte fashioned addition of all
data without overflow. The upper bit (D7) is firmed at 0.
binary 8 bit: The checksum is formed by a byte fashioned addition of all
data without overflow.
CRC: The checksum is formed by 'exclusive or' of all data.
CRC in ASCII: The checksum is formed by 'exclusive or' of all data and
afterwards converted into ASCII.
Checksum area:
Defines the telegram part by which the checksum is formed. You can select
the following settings: only user data, with start identifier, with end
identifier or complete telegram.
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Character filter:
Some protocol use defined characters to mark the telegram end. If these
characters are allowed inside the user data a distinction to the end
character can be made by doubling the character. If the character appears
inside the user data it is sent two times.
By receiving the character two times directly one after the other it is reject
one time. If it was received just one time it is the telegram end.
This function can be activated in the parameter 'character filter'. Additional
the character which has to be filtered must be set.
You have to take care that the ASCII protocol leads the filter function only
inside the user data. The telegram start or the telegram end and the
acknowledge telegram have to be provided with a doubled character and
respectively as end mode with simple characters. The doubled characters
are included for the ascertaining of the checksum. The checksum is
unlessed from the filter function.
Character (Hex):
Gives the character for the active filter. The input is always hexadecimal.
Telegram timeout:
The telegram timeout is activated by switching on the receive mode and
controls the receive of the hole telegram. It has priority over the 'Start
timeout' and the 'character delay time'.
Start timeout:
The start timeout is activated with the switching on of the receive mode and
controls the time until the receive of the first character. Requirement for this
is that the 'telegram control time' is configured with 0.
Character delay time:
Controls the time between the receive of the single characters.
Requirement is that the 'telegram control time' is configured with 0.
Retries:
Number of telegram retries in the case of errors.
Error SCC:
If set/reset is selected in this field, an occurred error during a data transfer
is deleted after a faultless transmission. If set is selected, the error is
shown also after a faultless transmission and it is only deleted if the device
is resetted.
Length of telegram start:
Length of the telegram start. In case of length = 0 no start designation is
sent. In case of negative length the belonging text is interpreted as text as
hex character of 0...F. Otherwise it is used as ASCII text.
Telegram start and Telegram end:
Some transmission protocols expect defined characters at the beginning
and at the end of the telegram. This characters are no user data but serve
for the identification of the telegram start respectively the telegram end.
This data can be independently add or delete by the ASCII protocol. For
this a telegram start and a telegram end can be configured. These can be
max. 8 characters long.
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Length of telegram end:
Length of the telegram end identification. In case of length = 0 no end
identification is sent. In case of negative length the belonging text is
interpreted as hex character of 0...F. Otherwise it is used as ASCII text.
Length of ACK-telegram:
Length of the acknowledge telegram. In case of length = 0 no acknowledge
telegram is sent. In case of negative length the belonging text is interpreted
as hex character of 0...F. Otherwise it is used as ASCII text.
ACK-telegram:
Acknowledge telegram exists of 0-8 characters.
Length of NACK-telegram:
Length of the not acknowledge telegram. In case of length = 0 no not
acknowledge telegram is sent. In case of negative length the belonging text
is interpreted as hex character of 0...F. Otherwise it is used as ASCII text.
NACK-telegram:
Not acknowledge telegram exists of 0-8 characters.
Telegram length device:
Defines the telegram length of the remote partner when it is valid as ended.
Just in the end mode the 'fixed data number' of importance.
Telegram sequence time:
With the parameter 'telegram sequence time' it is possible to definite a
minimum time between the sending. In case the parameter is higher than 0
the ASCII telegram waits the defined time until it sends the next telegram. It
counts the time from telegram start to telegram start. If more telegrams are
sent one after the other these are hand out buffered and in the time of the
'telegram sequence time'.
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5.3.7 Modbus RTU Parameter

Note: If you use a NetNode 40 you have one register card (- 1) to set the
serial interface. If you have load a NetNode 42 in the configuration three
register cards (- 1, - 2, - 3) appear because the NetNode 42 has three serial
interfaces.

If you have set an Modbus RTU configuration and you want to set the
Modbus RTU Parameter select the menu Settings > NetNode Parameter
> Modbus RTU.

Figure 27: Settings > NetNode Parameter > Modbus RTU - 1

Description:
The description of the device is shown in SyCon as the name of the device.
The description is changeable in this field.
Interface:
Interface of the device which is served by the protocol. This option can be
activated or deactivated by the user.
Interface type:
Here you can select the interface type. You can select: RS232, RS422 or
RS485.
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RTS control:
The RTS control must be activated (selected) if you use a RS485 interface.
If you use a RS422 or RS232 interface this option is typically deactivated.
Baud rate:
Determination of the transmission rate. You have the possibility the select a
Baud rate between 50 Baud and 19200 Baud. As default setting 9600 Baud
is selected which is used mostly.
Stop bits:
Number of stop bits: 1 stop bit.
Parity:
Determination of the Parity bit. You can select no, even and odd.
Mode:
The mode defines the operation mode. It makes a differnece between
Slave- and Master mode. It defines additionally the valid address sector of
the data.
Slave / Address: 40001-49999
Master / Address: 40001-49999 (default setting)
Slave / Address: 1-65535
Master / Address: 1-65535
Slave / Address: 0-65535
Master / Address: 0-65535
Modbus address:
The Modbus address gives the state of the address at the Modbus. The
range of value is 1..2..247. 2 is the default setting.
Timeout:
Master mode: Gives the maximum time in milliseconds how long the Master
waits for an answer telegram of the Slave.
Slave mode: Gives the maximum time in milliseconds how long will be wait
for an answer telegram of the application program.
Retries:
Defines the number of telegram retries in the case of errors. This is only of
importance for the Master mode. The range of value is 1 to 10 and 3 is the
default setting.
Error SCC:
If set/reset is selected in this field, an occurred error during a data transfer
is deleted after a faultless transmission. If set is selected, the error is
shown also after a faultless transmission and it is only deleted if the device
is resetted.
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5.4 Project Information
If the you create an own project, the project information can be typed in into
the Settings > Project Information menu. Everybody can then read this
entry when this menu is opened.

Figure 28: Settings > Project Information

5.5 Language
Choose the Settings > Language menu and the following window opens:

Figure 29: Settings > Language

Here can be set the language of the System Configurator. Select the
required language and confirm the entry with the OK button.
A message appears that the System Configurator must be started again in
order to activate the selected language. Please carry this out.
After restarting the System Configurator, the language will have changed to
the selected one.

Note: Up to now not all languages are available for all fieldbuses!
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5.6 Start Options
Starting from the window Network View (menu Window > Network View)
the menu Settings > Startoptions opens the window Start Options. The
different start options or modes can be set. Some of these settings are only
of importance for the OPC server.

Note: The menu option Start Options is only displayed in the selection
Settings, if a project is loaded.

Figure 30: Settings > Start Options

•  Simulation mode ON/OFF
Only valid for the OPC Server.

•  Start SyCon hidden if started via OPC
Only valid for the OPC Server.

•  Start SyCon next time with last Configuration
When this is marked the last saved configuration in the SyCon is
automatically loaded when the SyCon is started again.
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•  Logic Network View visible
When this is marked, there is the possibility of diverting to the network
mode without having to install the SyCon with OPC. It is also possible
to use the Watch List from the network mode.

•  Fast start ON/OFF
Only valid for the OPC Server.

•  TAG tracing ON/OFF
Only valid for the OPC Server.

•  OPC tracing ON/OFF
Only valid for the OPC Server.

•  Auto connect ON/OFF
If this is marked, when opening a configuration automatically a
connection to that Hilscher devices is manufactured without the
device assignment additionally have to be executed.

•  Start with multiple configurations
If this option is selected you have the possibility to start SyCon with
up to four configurations simultaneously. The paths are shown in the
window and they are changable there.
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6 Online Functions
6.1 Introduction

In this section, all the functions that directly influence Hilscher NetDevices.

Note: Please note that this also permits an interruption of the running
communication or that input and output can be switched on or off.
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6.2 Online to the NetDevice

6.2.1 Firmware Download
If you want to carry out a Firmware download, act as follow: Select the
menu Online > Firmware Download. A warning appears, that the
communication on the bus will be interrupted. This warning has to be
confirmed.

Figure 31: Securitiy question before Firmware Download

Caution: The Firmware Download overwrites the configuration in the
device and the existing Gateway function (Image)!

Figure 32: Online > Firmware Download

Note: The Firmware Download can only take place via the serial diagnostic
interface. It is not possible to make a Firmware Download via the Ethernet
interface.

The Firmware is transferred into the selected device and stored there in a
power failure protected FLASH memory.
After the Firmware Download the configuration and after this the Standard
Gateway function (Image file) is reloaded. Then the device is ready for
operation.
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6.2.2 Downloading the Configuration
In order to transfer the configuration, a transfer download to the device
must be carried out with the menu Online > Download. A warning appears
that the communication on the bus will be interrupted. This warning must be
confirmed.

Figure 33: Security question before Download

Attention: The download overwrites the configuration in the device.

Figure 34: Online > Download

The configuration is transferred into the selected device and is stored there
in FLASH memory in a zero voltage manner so that the configuration is
available when the power supply is switched off and on again.
After the Download of the configuration the Standard Gateway function
(Image file) can be reloaded.
After the Download the device makes an internal reset and starts with the
communication.

Note: For NetNode devices it is necessary to select the menu point
Automatic release of the communication by the device in the Device
Settings.
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6.2.3 Image Download
With the menu Online > Image Download you can download a binary data
file (Image). From SyCon the standard Gateway function (Image) can be
loaded.
A question appears, if the Download should be made.

Figure 35: Security question before Image Download

Caution: The Image Download overwrites the existing Image in the device.

Figure 36: Online > Image Download
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6.2.4 Firmware / Reset
First the device must be chosen with a left mouse click on the symbol of the
device. Then the Online > Firmware / Reset menu has to be called up and
the name and the version of the Firmware are displayed.

Figure 37: Online > Firmware / Reset

The device is resetted with the Reset button.

6.2.5 Device Info
Select the menu Online > Device Info in order to obtain information for the
device.
The manufacturer date, the device number and the serial number of the
device is read out and shown.

Figure 38: Online > Device Info
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6.3 Diagnostic Functions

6.3.1 Extended Device Diagnostic NetLink
The Extended Device Diagnostic helps to find bus and configuration errors
when the SyCon menu functions are of no further help.
First select the Hilscher device with a left mouse click on the symbol of the
device. Then select the Online > Extended Device Diagnostic menu.
This menu opens a list of diagnostic structures. These contain online
counters, states and parameter information:

Figure 39: Online > Extended Device Diagnostic NetLink

Task / Task State Page

FDL_TASK Requests 91
FDL_TASK FMA Request 92
TCP_UDP_TASK Information 87
TCP_UDP_TASK Code Diag 87
IP_TASK Task Information 88
IP_TASK Ethernet Status 88
IP_TASK Ethernet Count 89
IP_TASK Packet Count 90
IP_TASK Code Diag 90

Table 14: Online > Extended Device Diagnostic NetLink
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6.3.2 Extended Device Diagnostic NetNode
The Extended Device Diagnostic helps to find bus and configuration errors
when the SyCon menu functions are of no further help.
First select the Hilscher device with a left mouse click on the symbol of the
device. Then select the Online > Extended Device Diagnostic menu.

This menu opens a list of diagnostic structures. These contain online
counters, states and parameter information:

Figure 40: Online > Extended Device Diagnostic NetNode (by the example of ASCII
protocol)

Depending on which protocol was selected for compilation by inserting the
device, you get the diagnostic structures for the existing protocol in the
Extended Device Diagnostic. Select from the following table the protocol
you use. The Extended Device Diagnostic for the existing protocol is
described in the given section.

Protocol 1 Protocol 2 Described in section Page

Ethernet 3946R / RK512 Extended Device Diagnostic with Ethernet / 3946R/RK512 62

Ethernet ASCII Extended Device Diagnostic with Ethernet / ASCII 63

Ethernet Modbus RTU Extended Device Diagnostic with Ethernet / Modbus RTU 64
Ethernet + FTP ASCII Extended Device Diagnostic with Ethernet + FTP / ASCII

Conversion
65

Table 15: Overview protocols in the Extended Device Diagnostic
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6.3.2.1 Extended Device Diagnostic with Ethernet / 3946R/RK512 Conversion

Figure 41: Online > Extended Device Diagnostic with Ethernet / 3946R/RK512 Conversion

Task / Task State Page

3946R / RK512 95
BRIDGE_TASK Task Information 94
ALI_TASK Task Information 93
TCP_UDP_TASK Information 87
TCP_UDP_TASK Code Diag 87
IP_TASK Task Information 88
IP_TASK Ethernet Status 88
IP_TASK Ethernet Count 89
IP_TASK Packet Count 90
IP_TASK Code Diag 90

Table 16: Extended Device Diagnostic with Ethernet / 3946R/RK512 Conversion
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6.3.2.2 Extended Device Diagnostic with Ethernet / ASCII Conversion

Figure 42: Online > Extended Device Diagnostic with Ethernet / ASCII Conversion

Task / Task State Page

ASCII 96
BRIDGE_TASK Task Information 94
ALI_TASK Task Information 93
TCP_UDP_TASK Information 87
TCP_UDP_TASK Code Diag 87
IP_TASK Task Information 88
IP_TASK Ethernet Status 88
IP_TASK Ethernet Count 89
IP_TASK Packet Count 90
IP_TASK Code Diag 90

Table 17: Extended Device Diagnostic with Ethernet / ASCII Conversion
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6.3.2.3 Extended Device Diagnostic with Ethernet / Modbus RTU Conversion

Figure 43: Online > Extended Device Diagnostic with Ethernet / Modbus RTU Conversion

Task / Task State Page

Modbus RTU 97
BRIDGE_TASK Task Information 94
ALI_TASK Task Information 93
TCP_UDP_TASK Information 87
TCP_UDP_TASK Code Diag 87
IP_TASK Task Information 88
IP_TASK Ethernet Status 88
IP_TASK Ethernet Count 89
IP_TASK Packet Count 90
IP_TASK Code Diag 90

Table 18: Extended Device Diagnostic with Ethernet / Modbus RTU Conversion
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6.3.2.4 Extended Device Diagnostic with Ethernet + FTP / ASCII Conversion

Figure 44: Online > Extended Device Diagnostic with Ethernet + FTP / ASCII Conversion

Task / Task State Page

ASCII 96
BRIDGE_TASK Task Information 94
ALI_TASK Task Information 93
TCP_UDP_TASK Information 87
TCP_UDP_TASK Code Diag 87
IP_TASK Task Information 88
IP_TASK Ethernet Status 88
IP_TASK Ethernet Count 89
IP_TASK Packet Count 90
IP_TASK Code Diag 90

Table 19: Extended Device Diagnostic with Ethernet + FTP / ASCII Conversion
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6.4 Message Monitor
The Message Monitor permits access to the Mailbox of the device.

Note: The usage of the Message Monitor assumes advanced knowledge
from the user.

Select the menu Online > Message Monitor.

Figure 45: Online > Message Monitor

A Message can be saved and loaded and has the file extension *.MSG.
File > New: clears the window
File > Open: opens a Message (Message can be loaded)
File > Save or File > Save As: saves a Message
File > Exit: ends the Message Monitor and returns to the SyCon.



SyConND System Configurator NetDevices Online Functions  ••••   67

Copyright •  Hilscher Gesellschaft für Systemautomation mbH •  Oi:SyConND#2EN

Edit > Create answer: creates an answer Message
Edit > Reset counter: resets the Message counter

View > Review the received data: all received data is shown
View > Review the  send data: all the send data is shown
View > Number of receipt errors: the number of the received errors is
shown
View > Decimal/Hexadecimal: Switch the display format

It is recommend to create a sub-directory MSG and to save the messages
in it.

Figure 46: Save a Message
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7 File, Print, Export, Edit and View
7.1 File

7.1.1 Open
An existing project can be opened with File > Open.

7.1.2 Save and Save As
When the file name is known, then the configuration can be saved under
the File > Save menu, otherwise the File > Save As menu must be
selected.

7.1.3 Close
The current project can be closed with File > Close.
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7.2 Print
After the current printer has been selected in the File > Printer Setup
menu, the configuration can be printed out under the File > Print menu. For
a page view, select the File > Page View menu.

7.3 Export Functions

7.3.1 DBM Export
Select the File > Export > DBM menu in order to save the previously
saved project file (*.IB Microsoft Access Format) in a DBM file (Hilscher
binary format). This DBM file can be loaded in the DOS Compro program.
The configuration is stored in the Project directory in the path of the SyCon
installation with the extension *.DBM.

Attention: The file name can have max. 8 characters.

7.4 Edit

7.4.1 Delete
To delete a device you have to have to select the menu Edit > Delete.
Before SyCon deletes the device a security question appears. If you really
want to delete this device you have to confirm this question with Yes, and
the device will be deleted.

Figure 47: Security question delete device

Note: When you delete a device the settings and the configuration of this
device get lost.
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7.5 View

7.5.1 Logical Network View
In the menu View > Logical Network View the user can activate or
deaktivate the network view by selecting ist (with hook) or by not selcting it
(without hook).
The network view is used for example for the Start Options.

7.5.2 Toolbars
In the menu View > Toolbars the user has the possibility to activate or
deactivate the Toolbars Standard and Fieldbus. If this function is
deactivated the toolbars are not shown.

7.5.3 Status Bar
In the menu View > Status Bar this bar can be activated (with hook) or
deactivated (without hook).
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8 Tools
8.1 iCon-L as Graphical Programming System

Note: The menu tools is only displayed if a NetNode configuration is
loaded. In case of a NetLin configuration this menu is not available.

iCon-L is started with the menu Tools > iCon-L.
iCon-L is a graphical programming system on basis of function modules.
These are parameterized and connected graphically with each other via
lines. With this the course and the processing of the data is fixed. The
function modules are developed specially and realize to communication
functions in a really efficient and understanding way.
The produced program is checked for syntax errors afterwards and
downloaded into the NetNode. Start-up and test are done by the Online-
Debugger of iCon-L directly in the graphical desktop.
A description about iCon-L you find in the program as help file.
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9 Error Numbers
9.1 CIF Serial Driver Error Numbers (-20 .. -71)

These is the list of error numbers using the serial driver.
Error Number Description
-20 Driver: No COM port found or COM port already in use.
-21 Driver: COM port already opened
-22 Driver: Function call into driver has failed
-23 Driver: Internal driver error
-24 Driver: Could not create read thread
-25 Driver: Could not create read event
-26 Driver: Could not create write event
-27 Driver: Could not create timer event
-28 Driver: Error by writing data
-29 Driver: Wrong COM state
-30 Driver: COM state error is set
-31 Driver: COM buffer setup failed
-32 Driver: COM set timeout failed
-33 Driver: Receive buffer overrun
-34 Driver: Receive buffer full
-35 Driver: Send busy
-36 Driver: Error during close driver
-40 User: COM port not opened
-41 User: Invalid handle value
-42 User: Invalid COM number
-43 User: Size parameter invalid
-44 User: Size parameter zero
-45 User: Buffer pointer is NULL
-46 User: Buffer too short
-47 User: Setup error

Table 20: CIF Serial Driver Error Numbers (-20..-47)
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Error Number Description
-50 User: Send message, timeout error
-51 User: Could not send a message

Cable not connected.
Wrong cable.
Device does not respond.

-52 User: Send message, no device connected
-53 User: Error by send message, message receiving
-54 User: Telegram collision
-55 User: Telegram, no acknowledgement received
-56 User: Telegram, noise
-57 User: Telegram, data overrun
-58 User: Telegram, parity error
-59 User: Telegram, framing error
-60 User: Telegram, unknown error
-70 User: Timeout by receive a message
-71 User: No message received

Table 21: CIF Serial Driver Error Numbers (-20..-47)
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9.2 RCS Error Numbers (4 .. 93)
This is the list of error numbers returned by the RCS (Realtime
Communication System), that is the operating system of Hilscher devices.
The error number is returned in an answer message. Command messages
and answer messages are used to communicate between the application
(e.g. the System Configurator) and the Hilscher device. An example of this
communication is the download of a configuration.
Error Number Description
4 Task does not exist
5 Task is not initialised
6 The MCL is locked
7 The MCL rejects a send command because of an error
20 The user will download a database into the device that is not valid for

this device type.
21 Data base segment not configured or not existent
22 Number for message wrong during download
23 Received number of data during download does not match to that in the

command message
24 Sequence identifier wrong during download
25 Checksum after download and checksum in command message do not

match
26 Write/Read access of data base segment
27 Download/Upload or erase of configured data base type is not allowed
28 The state of the data base segment indicated an error. Upload not

possible
29 The access to the data base segment needs the bootstraploader. The

bootstraploader is not present
30 Trace buffer overflow
31 Entry into trace buffer too long
37 No or wrong licence. The OEM licence of the System Configurator

allows only communication to devices that have the same licence inside
38 The data base created by the System Configurator and the data base

expected by the firmware is not compatible
39 DBM module missing

Table 22: RCS error numbers (answer message) (4..39)
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Error Number Description
40 No command free
41 Command unknown
42 Command mode unknown
43 Wrong parameter in the command
44 Message length does not match to the parameters of the command
45 Only a MCL does use this command to the RCS
50 FLASH occupied at the moment
51 Error deleting the FLASH
52 Error writing the FLASH
53 FLASH not configured
54 FLASH timeout error
55 Access protection error while deleting the FLASH
56 FLASH size does not match or not enough FLASH memory
60 Wrong structure type
61 Wrong length of structure
62 Structure does not exist
70 No clock on the device
80 Wrong handle for the table (table does not exist)
81 Data length does not match the structure of this table
82 The data set of this number does not exist
83 This table name does not exist
84 Table full. No more entries allowed
85 Other error from DBM
90 The device info (serial number, device number and date) does already

exist
91 Licence code invalid
92 Licence code does already exist
93 All memory locations for licence codes already in use

Table 23: RCS error numbers (answer message) (40..93)
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9.3 Database Access Error Numbers (100 .. 130)
The following table lists the error numbers of the database access errors
Error Number Description
100 Database already opened
101 Dataset could not be opened
103 Error while opening database occurred
104 No valid path name
105 No connection to data base. Call function DbOpen().
106 Error in parameter
107 Error during opening a table
108 Nullpointer occurred
109 Table not opened. Call function OpenTable() first.
110 The first record is reached
111 The last record is reached
112 Unknown type in the record found
113 Data has to be truncated
114 No access driver installed on the system
115 Exception received
116 This table is set to read only
117 There is no data set in the table
118 The requested table could not be edit
119 An operation could not be completed
120 User gives an unexpected length in WritsDs().
121 An assertion failed
122 DLL not found
123 DLL couldn't be freed
124 Specified function not found in the DLL
125 ODBC Function returns an error
126 Count of data bytes in the record exceeds 1938
127 DBM32 DLL is not loaded
128 Field with the given index was not found
129 This table contains no records
130 Invalid character (' ') found in a Table or Column

Table 24: Database Access Error Numbers (100..130)
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9.4 Online Data Manager Error Numbers

9.4.1 Online Data Manager Error Numbers (1000 .. 1018)
The following table lists the error numbers of the Online Data Manager.
Error Number Description
1000 Driver OnlineDataManager not opened
1001 Initialization of the OnlineDataManager has failed
1002 No DriverObject found. OnlineDataManager Sub DLL not found.
1003 No DeviceObject found. Device not found.
1004 Application not found
1010 Application has requested an unknown event
1011 Application has requested an unknown function mode, operating mode.

Known function modes, operating modes are Reset, Download, Register
Server, Unregister Server.

1012 Application has requested an unknown command
1013 Message Server already exists
1014 Message Server not registered
1015 Device already in use
1016 Device not assigned
1017 Device has changed
1018 Command active

Table 25: Online Data Manager Error numbers (1000..1018)

9.4.2 Message Handler Error Numbers (2010 .. 2027)
The following table lists the error numbers of the Message handler of the
Online Data Manager.
Error Number Description
2010 Message handler: Messagebuffer empty
2011 Message handler: Messagebuffer full
2021 Message handler: Invalid Message ID (msg.nr)
2022 Message handler: No entry
2023 Message handler: Message already active
2024 Message handler: Wrong Application
2025 Message handler: Message Timeout
2026 Message handler: Wait for Delete
2027 Message handler: No cyclic Message

Table 26: Error Numbers of the Message Handler of the Online Data Manager (2010..2027)
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9.4.3 Driver Functions Error Numbers (2501 .. 2512)
The following table lists the error numbers of the Driver Functions of the
Online Data Manager.
Error Number Description
2501 OnlineDataManager Sub DLL not found
2502 Function missing
2503 'Read Thread' not created
2504 'Write Thread' not created
2505 'IO Thread' not created
2510 Function failed
2512 Assign reports error. Return neither OK or cancel

Table 27: Error Numbers of the Driver Functions of the Online Data Manager (2501..2512)

9.4.4 Online Data Manager Subfunctions Error Numbers (8001 ..
8035)

The following table lists the error numbers of the Subfunctions of the Online
Data Manager.
Error Number Description
8001 Driver not opened. E.g. CIF Device Driver
8002 Application has requested an unknown event
8003 Application has requested an unknown command
8004 Command has failed
8005 Command active
8006 Device invalid
8010 No device was assigned
8011 Device was already assigned
8020 Driver not connected
8021 Driver already connected
8030 Faulty 'GetState'
8031 Send error (PutMessage returns error)
8032 Send active (PutMessage active)
8033 Receive error (GetMessage returns error)
8034 Receive active (GetMessage active)
8035 IO Error (ExchangeIO returns error)

Table 28: Subfunction Error Numbers of the Driver Functions of the Online Data Manager
(8001..8035)
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9.5 Data Base Functions Error Numbers (4000 .. 4199)
The following table lists the error numbers of the converting functions.
Error Number Description
4000 File does not exist
4001 Success in comprimizing
4002 Dataset does not exist
4003 Last respectively first entry reached
4004 Not enough memory
4005 File directory full
4006 Max number of entries reached
4007 No writing to this table possible, because the table is located in the

FLASH
4008 Table name does already exist
4009 File name does not exist
4010 Free RAM length from RCS_CNF.P86 is smaller than E_F_INDEX * 2
4011 Parameter ‘next’ wrong
4012 Not enough free space to copy data set
4013 Set is deleted
4014 Value for Index is wrong
4015 Access not allowed
4016 open_file used before init_file
4017 Drive is not ready
4018 Not enough drive memory
4019 File name or path does not exist
4020 Cannot create path
4021 Wrong path
4022 Wrong flag
4023 The delete path is the root path
4024 Path file exists
4025 Write error during write a file
4026 Error during create a file
4027 Error during close a file
4028 No DBM file
4029 Length of the read data is unequal of the file length

Table 29: Error numbers of converting functions (4000..4029)
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Error Number Description
4030 Path too long
4031 Directory changed
4032 Directory created
4034 Length of converting stream is 0
4035 Non equal data set found
4036 Non equal data set found
4037 Non equal data set found
4038 Data set has length 0
4039 The function DbmInit has assigned a Zero pointer during RCS

initialisation
4040 Printer not ready
4041 The data base is used from an other function
4042 New length of data base is smaller than used
4043 Unknown access mode
4044 Old data base has to be converted
4045 Error while converting. Function not known
4046 Unknown type in set 0 found
4047 No float function available
4048 Function not in RCS module
4049 Check failed
4050 Checksum check failed
4051 More segments are existing in file, than in the structure FILE_INFO_T in

wMaxEintraege
4052 SegLen in structure FILE_INFO_T is smaller then the length in the file.

Return of function dbm_restore_data
4053 The header file holds an other information for a length than in the

segment itself
4054 Not enough memory for allocation on the PC
4055 No index for file handle in structure FLASH_DIR of RCS found
4057 File type 2 can not be printed because of too many definitions
4058 The definitions need too many lines to display them, than in the program

available
4059 An unknown format for the parameter. Valid is U, H, or S
4060 Unknown parameter type

Table 30: Error numbers of converting functions (4030..4060)
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Error Number Description
4061 The data base was transmitted into the FLASH
4062 Set 0 contains no structure definition
4063 Set 0 can not be deleted
4064 Error during execution of a ODBC data base access
4065 Initialising of DBM through RCS had no success
4066 Passed data length incorrect
4067 Sorting function not linked
4068 Error in function parameter
4069 Error from ODBC table
4070 No free handle available. Too many data base links are already opened
4071 Unknown data type found in the table
4072 Structure of table GLOBAL not correct or no such table existing
4073 No name of an ACCESS data base
4074 Download window can’t be created
4075 Download not fully performable

Table 31: Error numbers of converting functions (4061..4075)
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Error Number Description
4082 More than 32 tables should be created
4083 No entry in element szSourceFile
4084 ODBC connection initialisation not possible. This could happen when in

file ODBCINST.INI in section [Microsoft Access Driver (*.mdb)] is no
valid path to ODBCJT16/32.DLL.

4085 Error in structure in the ACCESS data base that is in DBM format
4086 Error in structure in the ACCESS data base that is in DBM format
4087 No data in a ODBC table
4088 No entry
4089 ODBC set length not valid
4090 Not enough data sets in ODBC table
4091 Table CreateTab not found
4092 Error in structure of table CreateTab
4093 No entry in element szSourceTable
4094 No entry in element szDestTable
4095 Entry in iSourceType of table CreateTab is wrong
4096 Entry in iTranslate of table CreateTab is wrong
4097 Function SQLAllocStmt reports an error
4098 ODBC source table not found
4099 ODBC data truncated
4100 Download timeout
4101 Library load error
4102 Library function error
4103 Error in description 'toggle'
4104 Error in description 'KB'
4105 Column does not exist
4106 ODBC structure different
4107 ODBC address error
4108 No CRC sum exists (table GLOBAL exists or old)
4109 Table GLOBAL is old
4110 Calculated CRC different to CRC in table GLOBAL
4199 Programming error

Table 32: Error numbers of converting functions (4082..4199)
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9.6 Converting Functions Error Numbers (5001 .. 5008)
The following table lists the error numbers of converting functions.
Error Number Description
5000 Function PackLongToByteShort: Not enough space in pvD (Number of

elements greater than reserved memory)
5001 Function PackLongToByteShort: Not enough space in pvD. Detected

during converting of pvS
5002 Function PackLongToByteShort: Not enough space in pvD
5003 Function StringToByte: Not enough space in pvD
5004 Function IntToByte: Not enough space in pvD
5005 Function LongToShort: Not enough space in pvD
5006 Function PackStringDumpToByteArray: Not enough space in pvD
5007 Function PackStringBumpToByteArray: A character was found, which is

not convertible into a HEX value
5008 Function PackStringDumpToByteArray: Number of character odd
5009 Function PackStringDumpToByteArray: Not enough space in pvD
5010 Function PackStringDumpToByteArray: The current data set needs to be

appended the previous one
5011 Function PackStringDumpToByteArray: No corresponding function to the

given number exist
5012 Converting error

Table 33: Error Numbers of data base functions (5000 .. 5012)
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10 Appendix
10.1 Extended Device Diagnostic

10.1.1 Extended Device Diagnostic TCP UDP TASK

10.1.1.1 TCP_UDP_TASK Information

Figure 48: TCP_UDP_TASK Task Information

Variable Meaning

Task state State of the task
Error count Number of appeared errors
Last error Last appeared error

Table 34: TCP_UDP_TASK Task Information

10.1.1.2 TCP_UDP_TASK Code Diag

Figure 49: TCP_UDP_TASK Code Diag

Variable Meaning

Info count Counter for information reports
Warning count Counter for warning reports
Error count Counter for errors
Severity level Level of the last appeared error
Code Code of the last appeared error
Parameter Additional information to the error
Module Software-module
Line number Line number inside the software-module

Table 35:  TCP_UDP_TASK Code Diag
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10.1.2 Extended Device Diagnostic IP TASK

10.1.2.1 IP_TASK Task Information

Figure 50: IP_TASK Task Information

Variable Meaning

Task state State of the Task:
1 = Task is running
2 = initialization is running
3 = initialization has failed

Error count Counter for appeared errors
Last error Last appeared error
IP address IP-Address of the device
Net mask Net mask of the device
Gateway Gateway of the device

Table 36: IP_TASK Task Information

10.1.2.2 IP_TASK Ethernet Status

Figure 51: IP_TASK Ethernet Status

Variable Meaning

MAC address (hex) MAC address of the device
Interface Actual known Ethernet interface
Speed Transmission rate
Duplex mode Shows the actual Duplex mode: Half-/Fullduplex
Twisted Pair link State of the Twisted Pair connection

Table 37: IP_TASK Ethernet Status
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10.1.2.3 IP_TASK Ethernet Count

Figure 52: IP_TASK Ethernet Count

Variable Meaning

IRQ count Counter for interrupts of the Ethernet controller
Last event (hex) Last appeared interrupt type
Events OK Counter for known interrupt types
Events unknown Counter for unknown interrupt types
Frame recv OK Counter for received Ethernet frames
Frame recv missed Counter for missed Ethernet frames
Frame recv bad CRC Counter for Ethernet frames with CRC errors
Frame sent OK Counter for sent Ethernet frames
Frame sent errors Counter for send errors
Frame sent collisions Counter for sending collisions
Frame sent late collision
errors

Counter for late sending collisions

Table 38: IP_TASK Ethernet Count
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10.1.2.4 IP_TASK Packet Count

Figure 53: IP_TASK Packet Count

Variable Meaning

Packet recv TCP Counter for received TCP packets
Packet recv UDP Counter for received UDP packets
Packet recv ICMP Counter for received ICMP packets
Packet recv IP header err Counter for received IP packets with errors
Packet recv ARP Counter for received ARP packets
Packet recv unknown Counter for received packets of an unknown type

Table 39: IP_TASK Packet Count

10.1.2.5 IP_TASK Code Diag

Figure 54: IP_TASK Code Diag

Variable Meaning

Info count Counter for information reports
Warning count Counter for warning reports
Error count Counter for errors
Severity level Level of the last appeared error
Code Code of the last appeared error
Parameter Additional information to the error
Module Software-module
Line number Line number inside the software-module

Table 40: IP_TASK Code Diag
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10.1.3 Extended Device Diagnostic PROFIBUS

10.1.3.1 FDL_TASK Requests

Figure 55: FDL_TASK Requests

Variable Bedeutung

SDA request Number of 'SDA' Request
SDA confirmation pos. Number of 'SDA' Confirmation, positive
SDA confirmation neg. Number of 'SDA' Confirmation, negative
SDA indication Number of 'SDA' Indication
SDN request Number of 'SDN' Request
SDN confirmation pos. Number of 'SDN' Confirmation, positive
SDN confirmation neg. Number of 'SDN' Confirmation, negative
SDN indication Number of 'SDN' Indication
SRD request Number of 'SRD' Request
SRD confirmation pos. Number of 'SRD' Confirmation, positive
SRD confirmation neg. Number of 'SRD' Confirmation, negative
SRD indication Number of 'SRD' Indication
SRD update request Number of 'SRD' Update Request
SRD update con. pos. Number of 'SRD' Update Confirmation, positive
SRD update con. neg. Number of 'SRD' Update Confirmation, negative

Table 41: FDL_TASK Requests
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10.1.3.2 FDL_TASK FMA Request

Figure 56: FDL_TASK FMA Request

Variable Bedeutung

SAP act. Request Number of 'SAP Activate' Request
SAP act. Confirmation pos Number of 'SAP Activate' Confirmation, positive
SAP act. Confirmation neg Number of 'SAP Activate' Confirmation, negative
RSAP act. Request Number of 'RSAP Activate' Request
RSAP act. Confirmation
pos

Number of 'RSAP Activate' Confirmation, positive

RSAP act. Confirmation
neg

Number of 'RSAP Activate' Confirmation, negative

SAP deact. Request Number of 'SAP Deactivate' Request
SAP deact. Confirmation
pos

Number of 'SAP Deactivate' Confirmation, positive

SAP deact. Confirmation
neg

Number of 'SAP Deactivate' Confirmation, negative

LiveList request Number of 'LiveList' Request
LiveList confirmation pos Number of 'LiveList' Confirmation, positive
LiveList confirmation neg Number of 'LiveList' Confirmation, negative

Table 42: FDL_TASK FMA Request
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10.1.4 Extended Device Diagnostic ALI TASK

10.1.4.1 ALI_TASK Task Information

Figure 57: ALI_TASK Task Information

Variable Meaning

Task state State of the ALI Task:
0 = Task is not initialized
1 = Task is initialized and running
2 = Task is initializing
3 = Initialization error
4 = Task is initialized and waits for TCP-UDP Task

Error count Number of occurred errors
Last error Number of the last occurred error
Socket status Information about the actual used TCP socket:

1 = Socket 0 (Connection 0 Close/Open, Bit 0)
2 = Socket 1 (Connection 1 Close/Open, Bit 1)
4 = Socket 2 (Connection 2 Close/Open, Bit 4)
8 = Socket 3 (Connection 3 Close/Open, Bit 8)

Message sent to TCP task Number of messages which were sent to the TCP-UDP Task
Messages recv. from TCP
task

Number of messages which were received by the TCP-UDP
Task

Messages sent to user Number of messages which were sent by the user
Messages received from
user

Number of messages which were received by the user

Table 43: ALI_TASK Task Information



94  ••••   Appendix SyConND System Configurator NetDevices

Copyright •  Hilscher Gesellschaft für Systemautomation mbH •  Oi:SyConND#2EN

10.1.5 Extended Device Diagnostic Bridge TASK

10.1.5.1 BRIDGE_TASK Task Information

Figure 58: BRIDGE_TASK Task Information

Variable Meaning

Task state State of the task
0 = not initialized
1 = Basic state/ Bridgeprogram is running
2 = Bridgeprogram is not running

DSP state State of the Icon-L Bridgetask:
1 = ICON_MODE_ONLINE
2 = ICON_MODE_OFFLINE
3 = ICON_MODE_STEP
4 = ICON_MODE_STOP
5 = ICON_MODE_RESET
6 = ICON_MODE_LOAD

Received messages Number of messages which were sent to the Bridge
Last error last occured error
Error count Number of occured errors
Event count shows if the Bridge is running cyclic
Messages refused number of messages which were refused by the Bridge.

Messages are refused, if the internal order book of the Bridge
is full.

Table 44: BRIDGE_TASK Task Information
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10.1.6 Extended Device Diagnostic 3946R / RK512

10.1.6.1 3946R / RK512

Figure 59: Extended Device Diagnostic 3946R / RK512 Protocol 1

Variable Meaning

Task state Actual state of the protocol process
0 = not initialized
1 = basic state
2 = telegram sequence time expires
3 = sending mode
4 = receiving mode

Send telegrams Number of faultless transmitted telegrams
Receive telegrams Number of faultless received telegrams
Send repetitions Gives, how often a send telegram was repeated before it was

transmit faultless or the max. number of repetition was
reached

Receive repetitions Gives, how often a receive telegram was refused before it
was transmit faultless or the max. numer of repetiotions was
reached

Send errors Number of send tasks which got lost because of Syntax or
transmission errors

Receive errors Number of errors which have occurred by receiving data
Error bits (hex) Assigns every reported error to an error class and shows this

by setting a bit. It is only displayed, if the error has executed
in spite of repeat a telegram loss

Last error Number of the last reported error. It is only displayed, if the
error has occurred in spite of repeat a telegram loss

Table 45: Extended Device Diagnostic 3946R Protocol 1

Note: For NetNode 40 devices only the protocol 1 is avaiable. For NetNode
42 device there also exist the protocols 2 and 3.
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10.1.7 Extended Device Diagnostic ASCII

10.1.7.1 ASCII

Figure 60: Extended Device Diagnostic ASCII Protocol 1

Variable Meaning

Task state Actual state of the protocol process
0 = not initialized
1 = basic state
2 = telegram sequence time expires
3 = send mode
4 = receive mode

Send telegrams Number of faultless transmitted telegrams
Receive telegrams Number of faultless received telegrams
Send errors Number of send tasks which got lost because of Syntax or

transmission errors
Receive errors Number of errors which have occurred by receiving data
Error bits (hex) Assigns every reported error to an error class and shows this

by setting a bit. It is only displayed, if the error has executed
in spite of repeat a telegram loss

Last error Number of the last reported error. It is only displayed, if the
error has occurred in spite of repeat a telegram loss
The description of the error numbers see on the CD in the
manual asc_pre.pdf

Table 46: Extended Device Diagnostic ASCII Protocol 1

Note: For NetNode 40 devices only the protocol 1 is avaiable. For NetNode
42 device there also exist the protocols 2 and 3.
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10.1.8 Extended Device Diagnostic Modbus RTU

10.1.8.1 Modbus RTU

Figure 61: Extended Device Diagnostic Modbus RTU Protocol 1

Variable Meaning

Task state Actual state of the protocol process
0 = not initialized
1 = basic state
2 = telegram sequence time expires
3 = sending mode
4 = receiving mode

Send telegrams Number of faultless transmitted telegrams
Receive telegrams Number of faultless received telegrams
Send repetitions Gives, how often a send telegram was repeated before it was

transmit faultless or the max. number of repetition was
reached

Transmit errors Gives the number of tranmit errors
Error bits (hex) Assigns every reported error to an error class and shows this

by setting a bit. It is only displayed, if the error has executed
in spite of repeat a telegram loss

Last error Number of the last reported error. It is only displayed, if the
error has occurred in spite of repeat a telegram loss
The description of the error numbers see on the CD in the
manual asc_pre.pdf

Table 47: Extended Device Diagnostic Modbus RTU Protocol 1

Note: For NetNode 40 devices only the protocol 1 is avaiable. For NetNode
42 device there also exist the protocols 2 and 3.
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10.2 Full Duplex and Half Dupelx
Full Duplex:
Full Dupelx is the designation for a process of data transmission which
allows a simultaneously transmission of the data in both directions. That
means both devices can send and receive simultaneously.

Half Duplex:
In contrast to Full Duplex where two wires can be used to transmitt data
(one for send and one for receive) the Half Duplex works mutually with one
channel. That means one the device can send and the other device can
receive.

10.3 Twisted Pair and AUI
Twisted Pair:
Twisted Pair cable are used for point to point connections and they need
four cores therefore two pairs of cores for separate towards and back
transmission. Partly this cable has to be crossed, for example by using two
repeaters. In view of faster network constellations everywhere four double
wires (eight wires) with Cat 5 cable should be used.
Twisted Pair is exclusively connected with RJ45 connectors.

AUI:
The interface between an Ethernet-Transceiver and an Ethernet-Interface
which is connected by a direct connection beteween the Transceiver and
the Interface or via an AUI cable.

10.4 MAC Address
(Media Access Control-Address) This is the hardware address of a
component in the network which can generate the data packet on its own.
The MAC Adress is given by the manufacturer who has a reservated
memory location. The manufacturer guarantee that the address is unique.
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