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Kurzbeschreibung

Description

Diese CD beinhaltet

« ladbare Firmware*

« Systemkonfigurator SyCon**

* GSD-Dateien

« Beispielprojekte

« Dokumentation

fiir das Rockwell-InterFace 1788.

Das Rockwell-Interface als PROFIBUS-DP-Master fiihrt
den gesamten Datenaustausch zwischen den ange-
schlossenen Feldbusteilnehmern bzw. als PROFIBUS-
DP-Slave den Datenaustausch mit dem angeschlosse-
nen Master und dem FlexLogix-Controller durch. Dabei
werden die Daten als Prozessabbild im Dual-Port
Memory des Rockwell-Interface 1788 zur Verfligung
gestellt.

Beim RIF 1788-DPM erfolgt die Konfiguration und Inbe-

triebnahme durch den Systemkonfigurator SyCon. Die-

ser kommuniziert mit dem RIF 1788-DPM tiber eine
serielle Verbindung zwischen dem COM-Port des PCs
und der Diagnoseschnittstelle des RIFs. Die Kon-
figuration wird im FLASH-Speicher auf dem RIF gespei-
chert, sodass das RIF beim Starten sofort betriebsbereit
ist.

Beim RIF 1788-DPS wird die Konfiguration vom Master

in der Startphase lbergeben oder alternativ Gber den

Konfigurationsbereich des Programms

FlexLogix/DriveLogix SPS vorgegeben.

* Falls es eine neue Firmwareversion gibt, kdnnen Sie
diese fiir das RIF 1788-DPM von unserer Homepage
herunterladen.

** Zum Betrieb des Systemkonfigurators benétigen Sie
einen Lizenzcode. Wenn dieser im Lieferumfang mit
enthalten ist, finden Sie ihn fiir den Systemkonfigura-
tor als Label auf dieser CD oder in einem Briefum-
schlag ein Lizenzcodeanforderungsformular. Andern-
falls wenden Sie sich bitte an Ihren Distributor oder
direkt an Hilscher.

This CD contains

* loadable Firmware*

« System Configurator SyCon**

+ GSD files

« Example projects

» Documentation

for the Rockwell 1788 Interface cards.

As a PROFIBUS-DP Master the Rockwell 1788
Interface handles the complete data exchange between
the connected fieldbus stations, respectively as
PROFIBUS-DP Slave the data exchange with the
connected Master and the FlexLogix Controller. The
data is available as process image in the dual-port
memory of the RIF 1788 cards.

With the RIF 1788-DPM the configuration is done
through the System Configurator SyCon. It
communicates via a serial connection between the
COM port of a PC and the diagnostic interface of the
RIF 1788-DPM card. The configuration is stored perma-
nently in FLASH memory on the 1788 card and is avai-
lable immediately on power up.

In case of RIF 1788-DPS the configuration is transmit-

ted by the network Master during start-up or loaded via

configuration parameter from the FlexLogix/DriveLogix

PLC program.

* Firmware upgrade for RIF 1788-DPM cards can be
downloaded from our homepage.

** Alicense code is required to use the System Con-
figurator. If this is included with the card you will find
a label on the System Configurator CD or an
envelope containing a license code request form.
Otherwise please contact your distributor or Hilscher
directly.



Verzeichnisstruktur der CD

Directory Structure of the CD

Sie erhalten auf dieser CD alle Dokumentationen im
Adobe-Acrobat-Reader-Format (PDF). Im Verzeichnis

All manuals are on the CD and in the Adobe Acrobat
Reader format (PDF). A runtime version of the Acrobat

ACROREAD ist eine Runtime-Version des Acrobat Rea- Reader can be found in the ACROREAD directory.

ders enthalten.
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Systemvoraussetzungen

System Requirements

Rockwell-Software
+ RSLogix 5000, V12.00 oder héher

Hilscher-Software
« SyCon V2.869 oder héher (Systemkonfigurator)

Hinweis: SyCon benétigt einen Lizenzcode auf der
Karte. Fehler 37/-14 zeigt an, dass kein Lizenzcode auf
der Karte vorhanden ist.

SyCon-Voraussetzungen:

« PC mit 486-, Pentium-Prozessor oder hoher

» Windows 95/98/ME, Windows NT 4.0/2000/XP
« Freier Festplattenspeicher: 30-80 MByte

* CD-ROM-Laufwerk

* RAM: mind. 16 MByte

« Grafikaufldsung: mind. 800 x 600 Bildpunkte

« Windows 95: Service Pack 1 oder héher

» Windows NT: Service Pack 6 oder hoher

« Tastatur und Maus

Rockwell Software
* RSLogix 5000, V12.00 or higher

Hilscher Software
+ SyCon V2.869 or higher (System Configurator)

Note: SyCon checks for a license code on the card.
Error 37/-14 will be reported if there is no license code
on the card.

Requirements for SyCon:

« PC with 486-, Pentium processor or higher

+ Windows 95/98/ME, Windows NT 4.0/2000/XP
« Free disk space: 30-80 MByte

+ CD ROM drive

* RAM: min. 16 MByte

* Graphic resolution: min. 800 x 600 pixel

» Windows 95: Service Pack 1 or higher

» Windows NT: Service Pack 6 or higher

» Keyboard and Mouse



Installation des RIFs

Installation of the RIF

Um eine Beschadigung des Rockwell-Controllers
,FlexLogix/DriveLogix"“ und des RIFs zu vermeiden, ent-
laden Sie sich, bevor Sie das RIF einbauen.

1. Schalten Sie zuerst die Betriebsspannung des Rock-
well-FlexLogix/DriveLogix-Contollers und aller ange-
schlossenen Geréte aus.

2. Offnen Sie das Geh3use des Rockwell-
FlexLogix/DriveLogix-Contollers und stecken Sie das
RIF auf einen freien Steckplatz.

3. SchlieRen Sie wieder das Gehause und schalten Sie
die Betriebsspannung des Rockwell-
FlexLogix/DriveLogix-Contollers ein.

4. Das RIF kann mit dem Systemkonfigurator SyCon
Uber die serielle Schnittstelle des PCs und die serielle
Diagnoseschnittstelle des RIF 1788-DPM verbunden
werden.

Hinweis: Eine ausfiihrliche Beschreibung der Installati-
on der Daughtercards finden Sie in dem Handbuch
FlexLogix System Installation Instructions
1794-INO02E-EN-P von Rockwell Automation.

To prevent damage to the Rockwell Controller
“FlexLogix / DriveLogix” or the RIF discharge yourself
before installing the RIF.

1. First switch off the power of the Rockwell FlexLogix /
DriveLogix Controller and all connected devices.

2. Open the cabinet of the Rockwell FlexLogix /
DriveLogix Controller and plug in the RIF on a free slot.

3. Close the cabinet and switch on the power of the
Rockwell FlexLogix / DriveLogix Controller.

4. The System Configurator SyCon can be connected to
the RIF via the serial interface of the PC and the serial
diagnostic interface of the RIF 1788-DPM.

Note: You find a detailed description about the
installation of the daughtercards in the manual
FlexLogix System Installation Instructions 1794-
INOO2E-EN-P from Rockwell Automation.



Geratezeichnungen Device Drawings

Typ / Type Dual-Port Memory Funktion / Function
RIF 1788-DPM 8 KByte PROFIBUS-DP-Master
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Typ / Type Dual-Port Memory Funktion / Function
RIF 1788-DPS 8 KByte PROFIBUS-DP-Slave
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PROFIBUS Interface

Isolated RS-485 interface per EN 50170.

PROFIBUS-Schnittstelle

Potentialfreie RS-485-Schnittstelle gemalk EN 50170.

Anschluss mit Signal
DSub-Buchse
Connection with DSub
female connector

Bedeutung

Signal

Meaning

3 RxD/TxD-P Empfangs-/Sendedaten-P bzw. Anschluss B am Stecker /
Receive / Send Data-P respectively connection B plug

B DGND Datenbezugspotential / Reference potential

6 VP Versorgungsspannung Plus / Positive power supply

8 RxD/TxD-N Empfangs-/ Sendedaten-N bzw. Anschluss A am Stecker /

Receive / Send Data-N respectively connection A plug

Bitte beachten Sie, dass an beiden Enden des Kabels
Abschlusswiderstande vorhanden sind. Wenn Sie
spezielle PROFIBUS-Stecker verwenden, sind diese
Widerstande oft innerhalb des Steckers und miissen
nur zugeschaltet werden. Fir Baudraten tber

1,5 MBaud verwenden Sie nur PROFIBUS-Stecker, die
zusétzliche Induktivitaten enthalten.

Ebenso ist es nicht zulassig, Stichleitungen bei diesen
hohen Baudraten zu verwenden. Bitte verwenden Sie
nur ein Kabel, welches fiir PROFIBUS-DP zugelassen
ist. Machen Sie auRerdem eine grofRflachige Verbin-
dung zwischen dem Kabelschirm und dem Erdpotential
bei jedem Gerét und stellen Sie sicher, dass Sie keine
Potentialunterschiede zwischen diesen Punkten haben.

Wenn Sie nur das RIF mit einem weiteren Teilnehmer
verbinden, missen beide Gerate an den Enden des
Kabels angeschlossen sein, damit die Abschlusswider-
stande mit Spannung versorgt werden. Ansonsten kann
der Master an jeder beliebigen Stelle angeschlossen
werden.

Please ensure that termination resistors are available at
both ends of the cable. If special PROFIBUS connec-
tors are being used, these resistors are often found
inside the connector and must be switched on.

For baud rates above 1.5 MBaud use only special
connectors, which also include additional inductance.

It is not permitted to have T stubs on PROFIBUS at
high baud rates. Use only a special cable which is
approved for PROFIBUS-DP. Make a solid connection
from the cable shield to ground at every device and
make sure that there is no potential difference between
the grounds at the devices.

If the RIF is linked with only one other device on the
bus, they must be at the ends of the bus line. The rea-
son is that these devices must deliver the power supply
for the termination resistors. Otherwise the Master can
be connected at any desired position.



Erstes Gerat Letztes Gerat
First device Last device

VP VP

RxD/TxD-P

RxD/TxD-N

DGND

Sie kénnen bis zu 32 PROFIBUS-Geréte in einem Up to 32 PROFIBUS devices can be connected to one
Bussegment miteinander verbinden. Wenn Sie mehrere bus segment. If several bus segments are linked to
Bussegmente mit Repeater miteinander verbinden, each other with repeaters, there can be up to 127
kénnen Sie maximal 127 Geréate anschlieRen. devices on the network.

Die maximale Lénge eines Bussegments ist abhangig The maximum length of a bus segment depends on
von der verwendeten Baudrate. Bitte verwenden Sie the baud rate used. Only PROFIBUS certified cable,
nur spezielles, fiir PROFIBUS zugelassenes Kabel, preferably the cable type A, should be used.

vorzugsweise den Typ A.

Baudrate in kBit/s . i Parameter Wert
Baud rate in kBit/s g Parameter Value
9,6 1.200 Wellenwiderstand 135...165 Ohm
19,2 1.200 Impendance
93,75 1.200 Kapazitatsbelag < 30 pF/m
187,5 1.000 Capacity
500 400 Schleifenwiderstand 110 Ohm/km
1,500 200 Loop resistance
3.000 100 Ad‘erndurchmesser 0,64 mm
Wire gauge
6.000 100
12.000 100
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Diagnoseschnittstelle Diagnostic Interface

Potentialgebundene RS-232C-Schnittstelle zum Non isolated RS-232C interface to connect with the
Anschluss an die COM-Schnittstelle des PCs. Die COM port at the PC. The Hilscher part number for the
Bestellbezeichnung fiir das Diagnosekabel ist CAB- diagnostic cable is CAB-SRV-MDS8.
SRV-MD8.
Anschluss mit Bedeutung
Mini-DIN-Buchse 8-polig Meaning
1 RXD Empfangsdaten / Receive Data
2 TXD Sendedaten / Send Data
3 GND Betriebserde / Signal Ground
4 DTR Datenendeinrichtung betriebsbereit / Data Terminal Ready
5 RTS Sendeteil einschalten / Ready to Send
8 CTS Sendebereitschaft / Clear to Send
RIF PC
Schirm am Steckergehause
AN N 5 Shield at connector casing
B 1 4 ’ N 3 (/ \\
RXD = , f ; f ; ; RXD
TXD = i i i i TXD
4 4
o et | L [yow
G N D " 3 L N ’ ) ‘\ N ’ ) G N D
RTS 5 N7 N7 6 RTS
CTS m8 8. cTs
Mini-DIN8-Stecker 8-polig DSub-Buchse 9-polig
Mini DIN8 male connector 8 pin DSub female connector 9 pin
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Installation der Software

Installation of the Software

SchlieRen Sie alle Programme!

Legen Sie die CD in das lokale CD-ROM-Laufwerk.
Das Installationsprogramm startet selbststandig
(Autostart eingeschaltet). Andernfalls wechseln Sie
in das Root-Verzeichnis der CD und starten Sie
Autorun.exe (Autostart ausgeschaltet).

HINWEIS Unter Windows NT/2000/XP benétigen Sie
Administratorrechte zur Installation!

Das Installationsprogramm fragt, welche Komponenten
installiert werden sollen. Beantworten Sie diese Fragen
mit Ja bzw. Nein.

Installiert werden

» Systemkonfigurator SyCon
« Beispielprogramme.

13

Close all application programs on the PC!

Insert the CD in the local CD ROM drive. The install-
ation program will start by itself (Autostart enabled).
Otherwise go to the root directory on the CD and start
Autorun.exe (Autostart disabled).

NOTE Administrator privileges are required on
Windows NT/2000/XP systems for installation!

The installation program asks for the components you
want to install. Answer these questions with Yes or No.

It will install

+ System Configurator SyCon
« Example Programs.



Installation des
Systemkonfigurators SyCon

Installation of the
System Configurator SyCon

Bei der Installation miissen Sie lhren Namen und den
Firmennamen eingeben.

Wenn ein Lizenzcode im Lieferumfang mit enthalten ist,
finden Sie ihn flr den Systemkonfigurator als Label auf
dieser CD oder in einem Briefumschlag ein Lizenzcode-
anforderungsformular.

Beantworten Sie die Frage nach einem vorhandenen
Lizenzcode mit Ja und geben Sie den vorhandenen
Lizenzcode ein.

Folgen Sie den Anweisungen des Installationsprogram-
mes, wahlen Sie die zu installierenden Feldbussysteme
aus und beantworten die Fragen mit JA oder WEITER.

14

During the installation process, the user and the com-
pany name must be entered.

If a license code is included in the scope of delivery you
will find it for the System Configurator on a label on this
CD or in an envelope a license code request form.

Answer the question for an “existing license code” with
Yes and enter the license code.

Follow the instructions of the installation program by
selecting the fieldbus system to be installed and
answering all the questions with OK or NEXT.



Konfiguration des
PROFIBUS-Netzwerks

Configuration of the
PROFIBUS Network

RIF 1788-DPM:

Beim RIF 1788-DPM legen Sie mit Datei > Neu >
PROFIBUS das Bussystem fest, wahlen mit Einfligen
> Master > RIF 1788-DPM das Geréat an lhrem
PROFIBUS-Netzwerk aus und vergeben die Stations-
adresse.

Fir PROFIBUS-DP machen Sie einen Doppelklick auf
die Slaves und konfigurieren Sie die einzelnen Gerate.
Die Adressen im Prozessabbild werden bei Autokonfi-
guration ein vom SyCon vergeben, andernfalls mus-
sen Sie diese manuell eingeben.

Stellen Sie beim Master die Baudrate in Einstellungen
> Busparameter ein.

Waéhlen Sie mit Einstellungen > Gerédtezuordnung >
CIF Serial Driver den Treiber, tiber welchen der
Systemkonfigurator das RIF ansprechen kann.
Speichern Sie die Konfiguration zunéachst auf dem PC
mit der Funktion Datei > Speichern und tbertragen sie
diese anschlieRend auf das Interface mit Online >
Download.

Fir PROFIBUS-DP Uberpriifen Sie die Kommunikation
mit Online > Debugmode starten. Alle Gerate missen
griin dargestellt werden. Wenn nicht, machen Sie einen
Doppelklick auf die roten Icons und tberpriifen Sie die
Diagnosebits. Priifen Sie mit der Funktion Online >
Live List, welche Stationen der Master am PROFIBUS
erkennt.

RIF 1788-DPM:

In case of RIF 1788-DPM with File > New >
PROFIBUS, select the bus system, with Insert >
Master > RIF 1788-DPM select the device of the
PROFIBUS network and assign the station address.
For PROFIBUS-DP double click on the Slaves and con-
figure the different devices. The addresses at the pro-
cess image are defined by SyCon if Auto
configuration is on, otherwise these must be entered
manually.

Set the baudrate in Settings > Busparameter for the
Master.

Also assign the driver in Settings > Device Assign-
ment > CIF Serial Driver via which SyCon will com-
municate to the RIF.

Store the configuration on the PC with the menu item
File > Save and afterwards transfer to the interface with
Online > Download.

For PROFIBUS-DP check the communication with
Online > Start Debug Mode. All bus devices must be
displayed in green. If not, double click on the
corresponding icons and look at the diagnostic flags.
Check with the function Online > Live List to display all
devices on the network recognized by the PROFIBUS-
DP-Master.



RIF 1788-DPS:

Beim RIF 1788-DPS fiigen Sie die GSD-Datei
HIL_07C6.GSD in das Konfigurationstool des Masters
hinzu und konfigurieren den verwendeten PROFIBUS-
DP-Master, wie der Geréatehersteller dies angibt.

Es gibt zwei Moglichkeiten:

(1) Der Master Ubertragt die Konfigurationsdaten tiber
den PROFIBUS an das RIF 1788-DPS. Diese werden
automatisch tibernommen.

(2) Der Slave erhalt die Information vom Konfigurations-
Baustein im Programm FlexLogix SPS. Diese Informati-
on muss bei der Konfiguration des Masters angegeben

werden. Die Slave-Konfiguration muss mit der Konfigu-

rationsinformation im Master tbereinstimmen.

Der Systemkonfigurator ist zur Konfiguration des Slaves
nicht notwendig.

RIF 1788-DPS:
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In case of RIF 1788-DPS add the GSD file
HIL_07C6.GSD into the configuration tool of the
PROFIBUS-DP-Master and configure as instructed by
the manufacturer.

There are two options:

(1) The data length for the slave can be downloaded by
the Master. This information will be transfered to the
RIF 1788-DPS via PROFIBUS.

(2) The Slave controller can define the data length and
then this information can be loaded into the Master at
time of configuration. In either case the slave data width
and Master data width must match for the system to
function properly.

The System Configurator is not necessary for the
configuration of the Slave.



Fehlersuche

Troubleshooting

Kabel

« Prifen Sie, dass die Pinbelegung des verwendeten
Kabels richtig ist.

< Prifen Sie, dass die Busterminierungswiderstande
am Anfang und am Ende der Leitung eingeschaltet
und bei allen anderen Steckern des Bussegments
ausgeschaltet sind.

LED
« Siehe Abschnitt Kontrolle der LED-Anzeigen.

Diagnose beim RIF 1788-DPM mit dem
Systemkonfigurator

Prifen Sie mit Online > Live List, welche Statio-
nen/Geréte am Bus vorhanden sind und ob diese den
Konfigurationsvorgaben entsprechen.

Prifen Sie mit Online > Debugmode starten, zu wel-
chen Geraten ein Nutzdatenaustausch stattfindet
(gruin dargestelltes Symbol).

Zeigen Sie mit Online > Geratediagnose die Dia-
gnoseinformation des Slaves an.

Wenn der Slave einen Konfigurationsfehler meldet,
dann Uberpriifen Sie mit Online > Geratediagnose
und Konfiguration vergleichen, ob die Konfiguration
des Slaves mit der im Systemkonfigurator iberein-
stimmt.

Wenn der Slave einen Parameterfehler meldet, dann
Uberprifen Sie die Parameterdaten in der Slave-
Konfiguration bei Parameterdaten.

.

Diagnose beim RIF 1788-DPS

+ Mit RSLogix5000: Das RIF 1788-DPS Ubertragt
Statusinformationen lber den Statusbereich an das
Programm FlexLogix Controller.
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Cable

Check that the pin occupation of the used cable is
correct.

Check to confirm that the bus termination resistors
are switched on at the beginning and the end of the
cable and switched off at all other connectors in bet-
ween.

LED
 See section Check the LED Displays.

Diagnostic for RIF 1788-DPM with the

System Configurator

Check which stations are present on the bus using
Online > Live List and that these match the actual
network.

Check to see which devices a process data exchange
is executed (green colored icons) by using Online >
Start Debug Mode.

Display the diagnostic information of a Slave using
Online > Device Diagnostic.

If the slave reports a configuration error, then check to
confirm that the configuration of the slave is the same
as in the master by using Online > Device
Diagnostic and Compare Configuration.

If the slave reports an parameter error, then check the
parameter data in the Slave configuration in Parame-
ter data.

Diagnostic for RIF 1788-DPS

« With RSLogix5000: The RIF 1788-DPS transfers sta-
tus information via the status area to the FlexLogix
Controller Program.



LED-Anzeigen
RIF 1788-DPM

LED Displays
RIF 1788-DPM

LED

SYS Ib /
gel
yellow'
gelb /

yellow O
gelb /
yellow O
gelb /
yellow ®
griin/
green

griin /
green O

griin/
green ®
O

CO¥e s
yellow .
gelb / O

yellow

rot/
red

O

(*) 3-mal schnell bei 5 Hz, 8-mal zwischen 0,5 Hz und

1Hz

Zustand / State

Ein/ On

Blinkt zyklisch bei 5 Hz /
Flashing cyclic at 5 Hz

Blinkt zyklisch bei 1 Hz /
Flashing cyclic at 1 Hz

Blinkt unregelmagig (*) /
Flashing irregular (*)

Ein/On

Blinkt zyklisch bei 5 Hz /
Flashing cyclic at 5 Hz

Blinkt unregelmagig (*) /
Flashing irregular (*)

Aus / Off

Ein/On

Blinkt unregelmafig (**) /
Flashing acyclic (**)

Ein/On

Aus / Off

(**) zwischen 0,5 Hz und 100 Hz

Bedeutung bei RIF 1788-DPM / Meaning in case of RIF 1788-DPM

RIF ist bereit / RIF is ready

Firmware-Download wird durchgefiihrt /
Firmware download is in progress

Gerat ist in Bootstraploadermodus und wartet auf Firmware-Download /
Device is in bootloader mode and is waiting for firmware download

Hardware- oder schwerer Systemfehler erkannt /
Hardware or heavy runtime error detected

Kommunikation lauft, das Gerat hat mindestens eine Verblndung zu einem
konfigurierten Teilnehmer aufgebaut / communication is running,
the device has established at least one configured fieldbus connection

Kein Fehler in der Konfiguration, Kommunikation gestoppt (COM-LED rot
aus) oder bereit fir Kommunikation, aber keine Verbindung zu einem
Slave (COM-LED rot an) / No error in configuration found, communication
is stopped (COM-LED red off) or ready for communication but no
connection to any Slave (COM-LED red on)

Anlauf: Fehlende oder fehlerhafte Konfiguration, Laufzeit: Host-Watchdog-
Timeout / Power Up: Configuration missing or faulty, device needs
commissioning, Runtime: Host Watchdog timeout

Versorgungsspannung fiir das Gerat fehlt oder Hardwaredefekt /
Device has no power supply or hardware defect

Gerat halt den PROFIBUS-Token und kann Telegramme Ubertragen /
Device is holding the PROFIBUS token and is able to transmitt telegrams
Gerat istim PROFIBUS-Ring und teilt das Token mit anderen PROFIBUS-
Mastergeraten / Device is sharing the PROFIBUS token with other master
devices in the PROFIBUS network
Gerat hat ein Kommunikationsproblem zu mindestens einen PROFIBUS-
DP-Slave-Gerat / Device has found a communication problem to at least
one PROFIBUS-DP slave device
Gerat ist nicht konfiguriert oder hat das Token nicht erhalten und ist
somit nicht im PROFIBUS-Netzwerk / Device is not configured or has not
received the Token permission on the PROFIBUS network
(*) 3 times fast at 5 Hz, 8 times between 0.5 Hz and
1Hz
8 (**) between 0.5 Hz and 100 Hz



LED-Anzeigen
RIF 1788-DPS

LED Displays
RIF 1788-DPS

LED

SYgser / °
yellow
gelb /
yellow O

gelb / O

yellow
gelb/
yellow ®
griin /
green

griin /
green O
griin / ®
green

O

[ele]]
gelb/
ysllow.

O

(*) 3-mal schnell bei 5 Hz, 8-mal zwischen 0,5 Hz und

1Hz

Zustand / State

Ein/ On

Blinkt zyklisch bei 5 Hz /
Flashing cyclic at 5 Hz

Blinkt zyklisch bei 1 Hz /
Flashing cyclic at 1 Hz

Blinkt unregelmafig (*) /
Flashing irregular (*)

Ein/On

Blinkt zyklisch bei 5 Hz /
Flashing cyclic at 5 Hz

Blinkt unregelmagig (*) /
Flashing irregular (*)

Aus / Off

Ein/On

Aus / Off

Bedeutung bei RIF 1788-DPS / Meaning in case of RIF 1788-DPS

RIF ist bereit / RIF is ready
Firmware-Download wird durchgefiihrt /
Firmware download is in progress

Gerét ist in Bootstraploadermodus und wartet auf Firmware-Download /
Device is in bootloader mode and is waiting for firmware download

Hardware- oder schwerer Systemfehler erkannt /
Hardware or heavy runtime error detected

Slave ist mit DP-Master im zyklischen Datenaustausch /
Slave in cyclic data exchange with DP Master

Slave hat keinen zyklischen Datenaustausch mit DP-Master /
Slave has no cyclic data exchange with DP Master

Anlauf: Fehlende oder fehlerhafte Konfiguration, Laufzeit: Host-Watchdog-
Timeout / Power Up: Configuration missing or faulty, device needs
commissioning, Runtime: Host Watchdog timeout

Versorgungsspannung fiir das Gerat fehlt oder Hardwaredefekt /
Device has no power supply or hardware defect

Slave hat Parameter-/Konfigurationsdaten vom DP-Master erhalten /
Slave has received parameter data/configuration data from the DP Master

Slave hat keine Parameter-/Konfigurationsdaten vom DP-Master erhalten /
Slave has not received parameter data/configuration data from the DP
Master

(*) 3 times fast at 5 Hz, 8 times between 0.5 Hz and
1Hz
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Technische Daten RIF 1788-DPM/-DPS /
Technical Data 1788-DPM/-DPS

PROFIBUS-DP-Master

DP-Master-Eingangsdaten /
DP-Master Input Data
DP-Master-Ausgangsdaten /
DP-Master Output Data
PROFIBUS-DP-Slave

Statusdaten / Status Data
Prozessor

Processor

Speicher

Memory

Master ASIC / Master ASIC
Slave ASIC / Slave ASIC
PROFIBUS-Schnittstelle
PROFIBUS Interface
Diagnoseschnittstelle
Diagnostic Interface
Betriebsspannung

Power Supply
Betriebstemp. / Operating Temp.
MaRe (L x B x H)
Dimensions (L x W x H)
Gewicht / Weigth
CE-Zeichen

CE Indication
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Headquarters

Subsidiaries

Germany

Hilscher Gesellschaft fiir
Systemautomation mbH
Rheinstrasse 15

65795 Hattersheim

Phone: +49 (0) 6190 9907-0
Fax: +49 (0) 6190 9907-50
E-Mail: info@hilscher.com
Web:  www.hilscher.com

World-wide: Distributors
Please visit our homepage on
www.hilscher.com

Haftungsausschluss

Der Inhalt dieses Manuals wurde auf Ubereinstimmung
mit der beschriebenen Hard- und Software geprift.
Dennoch kdnnen Abweichungen nicht ausgeschlossen
werden, sodass wir fir die vollstandige Ubereinstim-
mung keine Gewahr tibernehmen. Die Angaben in die-
sem Manual werden jedoch regelmaRig tUberprift. Not-
wendige Korrekturen sind in den nachfolgenden
Auflagen enthalten. Fir Verbesserungsvorschlage sind
wir dankbar.

Exemption from Liability

The contents of this manual were checked for agreement
with the described hardware and software. However,
deviations may occur so that no guarantee can be made
for complete agreement with the documentation.
However, the information in this manual is controlled
regularly. Necessary corrections are contained in the
following editions. We are grateful for improvement sug-
gestions.
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France
Hilscher France S.a.r.l.

12, rue du 35 iéme Régiment d’Aviation

Miniparc du Chéne

69500 Bron
Phone: +33 (0) 4 72 37 98 40
Fax: +33 (0) 4 78 26 83 27

E-Mail:
Web:

info@hilscher.fr
www.hilscher.com

Italy

Hilscher Italia srl

Via Grandi, 25

20090 Vimodrone (MI)
Phone: +39 02 25007068
Fax: +39 02 25029973
E-Mail: info@hilscher.it
Web:  www.hilscher.com

Switzerland

Hilscher Swiss GmbH
Hubelmattstrasse 29
4500 Solothurn

Phone: +41 (0) 32 623 6633
Fax: +41 (0) 32 623 6632
E-Mail: info@hilscher.ch
Web: www.hilscher.com
USA

Hilscher North America, Inc.
Suite 100
2443 Warrenville Road

Lisle, IL 60532

Phone: +1 630-505-5301

Fax: +1 630-505-7532

E-Mail: info@hilscher.us

Web:  www.hilscher.com



RIF 1788-DPM
RIF 1788-DPS

y 4
hilscher

COMPETENCE IN
COMMUNICATION

Bei weiteren Fragen wenden Sie sich
bitte an eine unserer Geschéftsstellen,
lhren lokalen Distributor

oder an unseren technischen Support:

If you have any question
please contact our subsidiaries,
your local distributor

or our technical support:

Phone: +49 (0) 6190 9907-99
E-Mail: hotline@hilscher.com
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